Stop iTunes from automatically copying songs into it's folder

Discussion in 'iPhone' started by RealSkyDiver, Sep 6, 2011.

  1. macrumors 6502

    Jun 15, 2010
    Every-time I listen to audio-files it copies them into it's folder which gets really annoying. How can I stop that.
  2. macrumors 68020

    Jan 9, 2007
    Go to Preferences>Advanced>Uncheck 'Copy files to iTunes Media folder when adding to library"
  3. macrumors 603


    Jun 30, 2008
    Have you tried looking in preferences?
  4. macrumors regular

    May 2, 2010
    I know this is a little old now, but by doing this EXACTLY what is it doing?
    If I choose
    File>Add to Library
    I of course want the song/album to be copied to iTunes.

    What I do not want is a song that I double click (elsewhere in finder) to play to be added to iTunes, I just want to listen to it (until I decide to do File>Add to Library )

    How do I get iTunes to do this then please?
  5. macrumors G4

    Small White Car

    Aug 29, 2006
    Washington DC
    This is different. Select a music file in finder and hit command-i.

    Find the 'open with' section and change it from iTunes to Quicktime. Then click the 'change all' button.

    You'll have to do this once for each file type. So once with an AAC, once with an MP3, once with a WAV, etc.
  6. macrumors regular

    May 2, 2010
    Thats great thanks.
    But lets say I STILL want iTunes to play it, I just dont want it to get added to the library (Unless I say I want to add it to the library).
    How is this done please?
  7. macrumors G4

    Small White Car

    Aug 29, 2006
    Washington DC
    I don't think that's possible. iTunes' role as a media library is to play files in its library. It doesn't have the ability to play things outside of its library.

    What they did add is the ability for the file behind the song to reside anywhere...that's what the OP was after. But that's on the back-end. On the front side the file has to be in iTunes to play from iTunes. It's not made to be a standalone media player...that's what Apple has assigned Quicktime to be.
  8. macrumors regular

    May 2, 2010
    thanks for your help. I think what the OP said is a little ambiguous and can be taken my way too (not having a go here or anything)
  9. macrumors regular

    Aug 8, 2011
    reviving this old thread, but despite unchecking the "Copy files to iTunes Media folder when adding to library", iTunes persistently copies into its assigned folder.

    I guess to stop that from happening, the best choice would be to remove iTunes and let VLC take over it's job as a media player. Any thoughts on that?
  10. macrumors newbie

    Mar 7, 2014

    my issue is that i constantly resync my phone to itunes, and every purchase is immediately duplicated. I've gone to preferences>advanced and the box asking if id like to copy my music has never been checked. i check it and uncheck it to see if it will fix the problem but it doesnt and im not sure what will. does anybody know?

Share This Page