1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Stuffit help

Discussion in 'General Mac Discussion' started by bumfilter, May 26, 2004.

  1. macrumors regular

    Ok, I have a bit of a problem which is really frying my noodle.

    I somehow deleted Stuffit from the /app.../Utilities/ directory. I realised I had made a mistake and so decided to visit the stuffit website and download a new copy.

    Well, for some weird reason, my ISP won't let me access the stuffit website. So, I tried accessing it via the IP,, which worked, but it directs me to the aladdinsys website. So I have no luck there.

    So I hunted down a dialup cable, connected to the first dialup isp I could find and viewed the website that way. It worked and about half an hour later I had downloaded a copy (lucky they put a .dmg version up, as without stuffit I can't decompress the .sit version).

    Tried to install and I get a (-38) system error. So it can't be installed.

    Finally, I had the idea that I could maybe reinstall it using the Panther CD but it doesn't appear to be on it.

    So does anyone else have any ideas? I don't seem to be getting very far!

  2. macrumors demi-god


    That's weird - I know that my Panther installer has a StuffIt Expander package. Try Pacifist for extracting a specific installer from a Mac OS X install package, like the ones on the Panther install CD (or DVD). I've never used it, but I've heard that it works like a charm for installing something that came on the Panther install CDs/DVD. If you have CDs, make sure you check all 3 of them - the package you need may not be on the bootable CD.
  3. macrumors G4

    You seem to be going all around Job's barn to avoid paying for your software. Care to enlighten us?
  4. macrumors regular

    I don't know what gave you that idea, I deleted Stuffit (which came with Panther) by mistake, all I'm trying to do is re-install it, which is harder than it seems. The Stuffit website offers a free version, I just can't access the website to download it, so wanted to know if there was another way to get it.

    Turns out there is a problem with Level3 (due to some TCP problem) which is stopping me from accessing the website, I think I remember seeing an FTP site on AOL that had stuffit files, luckily google is still working for me.
  5. macrumors G4

    No, it isn't harder than it seems. All you have to do is to reinstall the OS. Nothing will be deleted by the install, but missing stuff will be replaced. There is no need to go to the Stuffit website.
    As I said above, there is no need to access the Aladdin website. But, even if there were, your assertion that your ISP won't allow you to access the Aladdin site is so unbelievable as to be laughable. In your earlier post, you described how you tried to sneek into this site. Then you related tales of searching around for accessible dial-up ISPs. I have no idea what you are doing, but you are clearly up to no good.
  6. macrumors regular

    I didn't know that, that's why I asked in the first place. I've never tried using the CD for any other reason than a complete re-installation and I wasn't prepared to try it out, incase it went pear shaped and I lost my data.

    It's not that my ISP won't allow me, it's because of Level3 upgrading their network. If you don't believe me, here is the information from my ISP's status page, which you may not be able to view (you may need to login, I'm not sure), http://usertools.plus.net/status/archive/1084397331.htm.

    Unfortunatley for me, the Stuffit website is unavailable, as is Microsoft.com, Hotmail.com, Google (except the UK version) and various other websites I visit. Although I can use a proxy to view it:


    becuase that website works for me.

    I wasn't "sneaking" into the site, I was trying to access it like a normal person. As my ISP was clearly having troubles, I searched for a dial-up ISP which would allow me to view the site, as the dial-up ISP probably wouldn't be having the same problems. I'm using ADSL, so my only other alternative is to use dial-up.

    Regards the AOL mirror, it's an official one. AOL does happen to work ftp://members.aol.com/aladdin/pub/, so I was able to download their version, which for some reason, worked.

    If I was up to no good, I would be straight onto a P2P network and downloading from there. BUT I WASN'T.

    This post was completley useless but I felt I had to prove my point.
  7. macrumors 6502a


    wtf? reinstall the os for stuffit expander?

    and last i checked, trying to download a free product isn't stealing.
  8. macrumors 6502a


    I don't see what the big fuss is about. If you can't access the StuffIt Expander page at home, download it somewhere else then bring it home. Or just get the software wrldwzrd89 mentioned in the 2nd post and extract Expander from the Panther CD.

    Jesus, what's w/ the ADD.
  9. macrumors G4

    First off, you don't delete essential utilities like Stuffit Expander. If in the unfortunate event that you do, then rerunning the installation restores your missing files while leaving your other files intact. You are not reinstalling the whole OS, just your missing files.
  10. macrumors regular

    I've got it installed now, so things are back to normal. Thanks to everyone who helped. I'll try not to delete it again!

Share This Page