Tap to click on the login screen

Discussion in 'OS X Mountain Lion (10.8)' started by s.m.t., Apr 14, 2013.

  1. macrumors regular

    s.m.t.

    Joined:
    Mar 7, 2010
    #1
    I have been able to get this to work on my Mac Pro and iMac that have Magic TrackPads using:

    Code:
    sudo defaults write com.apple.driver.AppleBluetoothMultitouch.trackpad Clicking -int 1
    
    But this doesn't work on my MacBook Air. All 3 are running the latest 10.8.3.

    What am I missing?
     
  2. macrumors 68020

    Joined:
    Jun 15, 2012
    #2
    I have copied these commands from https://github.com/mathiasbynens/dotfiles/blob/master/.osx

    Code:
    # TRACKPAD: enable tap to click for this user and for the login screen
    defaults write com.apple.driver.AppleBluetoothMultitouch.trackpad Clicking -bool true
    defaults -currentHost write NSGlobalDomain com.apple.mouse.tapBehavior -int 1
    defaults write NSGlobalDomain com.apple.mouse.tapBehavior -int 1
    Note that you're using the first command, but not with a boolean key.
     
  3. thread starter macrumors regular

    s.m.t.

    Joined:
    Mar 7, 2010
    #3
    Cool, that is the first I have seen that command with a boolean... Will give it a shot...
     
  4. thread starter macrumors regular

    s.m.t.

    Joined:
    Mar 7, 2010
    #4
    hmm, no luck there either...
     
  5. macrumors newbie

    Joined:
    Jun 19, 2013
    #5
    Solved!

    As this is the newest thread I've found on that topic, I decided to post my solution here.

    To enable the tap to click on the login screen in Mac OS X 10.8.4, I've done the following:

    1. Set your desired preferences in your user account.
    2. Start a terminal.
    3. Make yourself root (sudo su -) You should be in the directory /var/root
    4. cd to Library/Preferences and backup the file com.apple.AppleMultitouchTrackpad.plist if it exists.
    5. cp the same file from your user account into this folder.
    (e.g.: "cp ~user/Library/Preferences/com.apple.AppleMultitouchTrackpad.plist /var/root/Library/Preferences")

    Tap to click works!

    It could be sufficient to just type
    Code:
    sudo defaults write com.apple.AppleMultitouchTrackpad Clicking -bool true
    But I have not tested this.

    I hope I could help. :)
     
  6. macrumors newbie

    Joined:
    Mar 14, 2014
    #6
    That didn't work for me. I'm sure it copied because now the one in var/root... is exactly the same from my profile.

    I'm running 10.9.2.
     
  7. macrumors newbie

    Joined:
    Oct 22, 2014
    #7
    Works for me! You need to restart for it to take effect.

    10.9.5 here.

    ----------

    You should put this at the top of your post (or its unlikely to ever be tested).
     
  8. macrumors newbie

    Joined:
    Mar 14, 2014
    #8
    This does not work on 10.10.

    Any solutions?
     
  9. macrumors newbie

    Joined:
    Oct 22, 2014
    #9
    Did you restart your Mac?
     
  10. macrumors newbie

    Joined:
    Mar 14, 2014
    #10
    Yes.
     
  11. macrumors member

    Joined:
    Oct 13, 2011
    #11
    I, too, can confirm that the solution does not work under 10.10.
     
  12. thread starter macrumors regular

    s.m.t.

    Joined:
    Mar 7, 2010
    #12
    There is another way to do this now... If you enable the root account then log in as root, change the trackpad to tap to click. Be sure to disable root again...
     
  13. macrumors member

    Joined:
    Oct 13, 2011
    #13
    I logged in as root, opened the Trackpad preferences in System Preferences, and found that tap to click was already enabled. Anyway, for good measure, I disabled tap to click from the preference pane and then re-enabled it. Then I restarted. I still can't tap to click from the login screen.

    Am I missing something? Can you be more specific?

    EDIT: P.S. I have a mid-2013 Air running 10.10.2.
     

Share This Page