Terminal help - Compiling and Stuff

Discussion in 'Mac Programming' started by Xenesis, Jan 21, 2007.

  1. macrumors regular

    Xenesis

    #1
    Okay, there's two things that I want to compile and use.

    Visualboy Advance (Simply because the 'offical OSX port') seems to have removed all of the devtools (Disassembler, Memory Viewer, etc.) which means that for my hobbyist ROMhacking I have to reboot into windows. Which I don't really like doing if I don't have to.

    I'd also like to compile Chemtool, a utility for drawing chemistry structures. Again, it gives me a reason to avoid using windows.

    Now, for Visualboy, the install tells me to have these dependencies. However I don't really know how to install dependencies so they can be used...or if they're even installed or not.

    And also before I configure/make it to do this:
    aclocal fails, telling me

    , despite the fact that I already installed gettext via ./configure, make and then sudo make install.

    Automake then complains that the aclocal.m4 is created for Automake 1.7.9 and I only have 1.6.3

    Now, as for Chemtool, the compile just fails with ten squillion error messages, which I'm assuming is because I don't have the dependencies installed, which brings me back to my first point with VBA...

    Any and all help is much appreciated. This open source community thing frightens me. <_<;

    I'm running 10.4.8, and my computer is as in my sig. I installed the latest version of the Apple Developer tools yesterday. I managed to get nethack (<_<; ) to compile, so it must be working okay at some level.
     
  2. macrumors G4

    Eraserhead

    #2
    This should probably be in the programming forum, (I've asked the mods to move it).

    You probably should install Fink, as you will probably need to install some Linux stuff on your Mac to get this stuff to work.

    EDIT Here is the Fink page for chemtool.
     
  3. macrumors regular

    Xenesis

    #3
    Okay, I installed fink and I'm running dselect, but chemtool doesn't appear in the list of possible packages....

    Some more help? :S
     
  4. macrumors G4

    Eraserhead

    #4
    email the package maintainer as shown here. If you get stuck.
     

Share This Page