trouble adding fonts to MS Word

Discussion in 'Mac Apps and Mac App Store' started by khunsanook, Nov 19, 2007.

  1. macrumors 6502


    Jul 2, 2006
    East Asia
    I'm trying to add Thai fonts to Microsoft Word (Office Mac 2004). These are fonts that are in the OSX Leopard font book (Ayuthaya, Krungthep, Thonburi, etc.), but when I add them to the Font folder of Office, they do not show up when I reopen Word. The Thai fonts "just work" in other applications.:rolleyes: Any ideas what I'm doing wrong?

  2. macrumors G4

    Jul 17, 2002
    I have no additional fonts in my Office fonts folder, yet all of my installed fonts show up in my Office font menus. You should not need to add fonts to the Office fonts folder. Placing them in one of the standard MacOS X fonts folders should suffice. You may add them manually or you may use Font Book.
  3. thread starter macrumors 6502


    Jul 2, 2006
    East Asia
    Hmmm, well that's good news i guess. But since these fonts are already in my osx system fonts folder I guess the next step would be to reinstall office and hope they show up again in MS WORD.

    Thanks for you reply
  4. macrumors G4

    Jul 17, 2002
    See if this helps.
  5. macrumors newbie

    Apr 15, 2008
    Here's how I did it

    Download the font, go to "Window" in Safari, click "Downloads," click the font folder, copy it (Ctrl-V), go to Finder, then Macintosh HD, then Library, then Fonts, then paste it there. It should be immediately available to your Word document, even if it's still open. Hope this helps.
  6. macrumors 6502a

    Jan 18, 2005
    Southern California
    You're probably placing them in your user fonts folder as opposed to the system font folder.
  7. macrumors newbie

    Jan 5, 2009
    Los Angeles

    Khunsanook (love the name by the way) - did you ever get this to work out, and if so, how? I'm curious because I'm dealing with the same problem.
  8. macrumors newbie

    Dec 3, 2009
    Yeah, did anyone resolve this? I am also having the same problem. I am using Snow Lepoard and using Microsoft Word for Mac 2011
  9. macrumors newbie

    Dec 4, 2011
    Clear your font cache for MS Word.

    /Users/XXX/Library/Preferences/Microsoft/Office2008/Office Font Cache(12)

    Find the above file and delete it, then restart your Mac. It will rebuild your font cache for Microsoft.

    If your afraid to delete it right out, just move it to a different folder or rename it.
  10. macrumors newbie

    Oct 21, 2012
    This didn't work for me

    Everything worked except for using it in word. I have a new 2012 MAC os x version. Please help! I'm needing walt disney font for grandson's invitations. :)

  11. macrumors 6502a

    deep diver

    Jan 17, 2008
    Solon, OH
    Is it disabled in FontBook? I've had some disabled fonts show up in other applications but not MSWord. If that's the case, enable it in FontBook and you should be good.
  12. macrumors newbie

    Dec 30, 2008
    I have tried everything to have new fonts added to MS Word without success. I believe MS purposely limited any additions from outside source. That's the very reason I quit using a PC!! Any fonts downloaded will work in a Mac text edit. Forget MSOffice and get iWork from Apple. I'm cutting the umbilical cord to MS altogether! :mad:
  13. macrumors newbie

    Jul 23, 2010
    Found A Solution For Myself

    I'll be the first to say Microsoft is the devil.

    I do not doubt they will run Hell. Granted, with incompetence, but still...

    Anyway, I have been FRUSTRATED BEYOND WORDS about the font issues I have with Microsoft Word. Every program I run on my computer (MBP, 2.8 GHz Intel Core i7, 16 GB RAM, Mavericks 10.9.2) uses the fonts I install through Font Book FLAWLESSLY (including Adobe CC).

    I finally found help with a free utility which searches out the font caches on your computer (all font caches, not just my MS caches) and clears them out ( I have nothing to do with the guy who created Font Nuke, but dang -- I ran the program once and it solved all my font issues with MS Word.

    Which is awesome. I can now use MS Word without homicidal tendencies. :cool:

    I ran Font Nuke, then restarted the computer twice, and then opened MS Word. The font cache was re-written, and the new fonts which had not worked loaded up and are working normally. I recommend this method if you've tried everything else and nothing worked.

Share This Page