1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Trying to "make" from source code

Discussion in 'Mac Programming' started by coconn06, May 12, 2006.

  1. macrumors regular

    #1
    I'm trying to build a unix application ("mdf2iso") on my PowerMac, for the purpose of converting a .mdf (windows Alcohol 120% disk image file) to .iso so I can mount it on my Mac. The instructions say to run the following commands in order:

    1. ./configure
    2. make
    3. sudo make install

    The problem comes when I run "make" (and then "sudo make install" even though the previous make command didn't work), I get the following output:

    Code:
    make  all-recursive
    Making all in src
    make[2]: Nothing to be done for `all'.
    

    Code:
    Making install in src
    test -z "/usr/local/bin" || mkdir -p -- "/usr/local/bin"
      /usr/bin/install -c 'mdf2iso' '/usr/local/bin/mdf2iso'
    make[2]: Nothing to be done for `install-data-am'.
    make[2]: Nothing to be done for `install-exec-am'.
    make[2]: Nothing to be done for `install-data-am'.
    I posted this in another thread, but I think the Mac Programming forum is more appropriate for this particular issue. Any ideas?
     
  2. macrumors 6502a

    #2
    I've just tried to compile mdf2iso and it looks like just the install script is failing.

    Change directory into the src directory contained in the mdf2iso source directory. In this directory you should find the mdf2iso command and be able to run it by typing ./mdf2iso.

    If you need this program for more than this one conversion, just put the executable somewhere like in your home directory and add that location to your shell path.
     
  3. macrumors regular

    #3
    Thank you, that worked :D

    Unfortunately the program didn't do what I needed it to do, but that's beside the point ;)
     

Share This Page