unexpected 2nd IP on en0

Discussion in 'Mac OS X Server, Xserve, and Networking' started by fdpo, Apr 12, 2010.

  1. macrumors newbie

    My wife's mac-mini (running Leopard) exhibited a strange problem yesterday. She could not access www.youtube.com, but other web sites seemed fine. There was nothing wrong with the youtube site -- I tried it from another computer (they are all behind a lynxsys router running NAT) and had no problems, but from her computer I could not even ping it.

    I finally traced it to the fact that en0 had two IPv4 IP addresses. One was the expected 192.168.1.x address and the other was a class A address 74.x.x.x. It just happens (coincidence?) that the youtube address is also a 74.x.x.x address, so I guess the second address upset the routing to youtube. I removed the address using 'ifconfig -alias' and that fixed the problem, but of course that fix only worked until I rebooted (at which time it came up with a different second address: 204.x.x.x). I tried switching from dhcp to static, but still had the problem.

    I would really like to (a) fix this problem and (b) understand what is causing it. Any ideas?
  2. macrumors 601

    Check Network Preferences. Is there an additional adapter assigned to the Ethernet interface?
  3. macrumors newbie

  4. macrumors 601

    Normally, this sounds like you have your network designed incorrectly, such as having your ISP and firewall connected to the same network. Although, usually, this causes a client to fail to get an IP, not obtain two of them.

    That said, if other machines are not having an issue, I'd suspect there's something misconfigured in that particular machine. Simplest method is to backup and rebuild.

Share This Page