Unplugging Macbook Pro lowers Gpu clock...

Discussion in 'Windows, Linux & Others on the Mac' started by imperialnavy, Sep 15, 2009.

  1. macrumors regular

    Jul 22, 2009
    i am using the newest Macbook pro (2,8ghz, 9600m gt and windows 7) and i am having following problem. This morning i decided to install a new nvidia driver (190.89) and everything works fine so far. When i unplug my ac cable however, something automatically decreases my gpu clock from formerly 500mhz to 393 and gpu memory clock from 792 to 700. Although it might not seem much, but it dramatically affects my framerate in pretty much any game..
    I already checked powermizer, and deactivated it with powermizer switch 1.2.
    (That worked in the 185 series. 186 and higher didnt work anymore..)
    Powermizer reports that its switched off, gpu z however tells me different. (And my framerates tell me that too ;) )
    My question now is, is anyone having the same issues ? Is there any way to solve that problem ?

    Help is very appreciated :)
  2. thread starter macrumors regular

    Jul 22, 2009
  3. macrumors Nehalem


    Feb 19, 2005
    Are you sure your energy saving settings aren't the cause of this since you're switching from ac to battery power?
  4. macrumors 6502


    Apr 23, 2009
    The Highlands, Scotland
    I think this might be completely normal, intended, behaviour on some laptops. My Dell laptop (sorry!) lowers its CPU clock rate automatically when switched from AC power to battery - obviously to conserve power.
  5. thread starter macrumors regular

    Jul 22, 2009
    I am very sure that the energy saving setting dont have anything to do with it ;) You see, i can use all the Nvidia Forceware drivers of the 185 series without that problem. The minute i switch to the 186 or 190 series, that problem occurs :(
    The 185 drivers are way too old for a "framerate hunter" like me :p, so i really want to update..
  6. thread starter macrumors regular

    Jul 22, 2009
  7. thread starter macrumors regular

    Jul 22, 2009
    I just tried installing 2 new drivers, 191.03 and 190.62....problem still persists :(
    After using Powermizer, my clock stays at 500mhz and 792 mhz when i have my ac cable plugged in. Once removed it lowers both clocks to 393 and 700mhz...
    Does no one else have this problem ????

Share This Page