Usb problems

Discussion in 'MacBook Pro' started by cool11, Mar 18, 2007.

  1. cool11 macrumors 65816

    cool11

    Joined:
    Sep 3, 2006
    #1
    I cannot understand why my mouse stopped to work properly.
    It is a logitech wireless.

    When I connect the wireless unit to a usb hub, attached to my mbp of course, it does not function. It freezes. Only touchpad works properly.

    If I connect it directly to usb port of mbp, it works.

    What is going on?
     
  2. cool11 thread starter macrumors 65816

    cool11

    Joined:
    Sep 3, 2006
    #2
    Maybe it is just a speculation but it seems that usb hubs do not work on my pc after 10.4.9 instalation.
    Everything I want should be directly connected to mbp.
    I have 2 usb hubs.
    What is going on?
     
  3. richard4339 macrumors 6502a

    richard4339

    Joined:
    Sep 6, 2006
    Location:
    Illinois
    #3
    Have you tried multiple ports on your USB hubs? And, does anything else work when coming through the hubs?
     
  4. cool11 thread starter macrumors 65816

    cool11

    Joined:
    Sep 3, 2006
    #4
    My hubs are multiport.
    I have them since I buy my mbp, 2 months ago.
    It is not normal to malfunction simultaneously the 2 of them.
    No device can function when it is connected on these hubs.

    Only direct usb connections work.

    Any settings on mac os x? System preferences or something else?

    I was everything ok, just few days ago.
    What happened?
    What I should do now?
     

Share This Page