1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Using a Netgear router with a Linksys modem?

Discussion in 'Macintosh Computers' started by jamdr, Mar 8, 2005.

  1. macrumors 6502a


    I recently switched from DSL to Cable broadband. With my previous setup, I had a Netgear wireless router connected to my DSL modem and everything worked fine. However, now that I switched to Cable, a Linksys cable modem was provided to me. The problem is that now my wireless router no longer works. The strange thing is that an IP address is assigned to me and the green icon shows up next to "Built-in Ethernet" in the Network prefpane, but I'm still not able to get on the internet. Is there some incompatibility between Linksys and Netgear equipment or is something else wrong?
  2. macrumors 65816

    Are you sure the Linksys isn't a router. Plugging a router into another router isn't going to work.
  3. macrumors 6502a


    Sorry if I messed that up:

    The Linksys is a cable modem.
    The Netgear is a wireless router.

    The way I see it, there are three possibilities:
    1. The two brands are incompatible (seems unlikely, but is it possible?)
    2. My new ISP doesn't support wireless routers (this would surprise me...)
    3. My setup is wrong (also seems unlikely because I haven't changed anything from before when it worked fine--just replaced the DSL modem with the cable modem).
  4. macrumors 6502a


    I just finished playing around with the setup some more and I'm convinced that there must be some incompatibility between Netgear and Linksys. My ISP says they are setup for wireless access and I know my setup is right because OS X thinks it's connected to the internet. It says "Built-in ethernet is currently active" in the Network prefpane with a green dot next to it. I'm even assigned an IP address from the ISP. Still, no pages load. Does anyone out there have a similiar setup?
  5. macrumors 65816

    It sounds like the Netgear is responding with an IP address to your system, so I suspect it's a config problem between the Netgear and Linksys. I've never used DSL, and I'm not at home to check my setup, but I believe there's a setting in the router setup pages called PPOE which is used with DSL. With a cable modem I think this should not be used.
  6. macrumors 68000


    Plugging a router into a second router will work, but the first router needs to be a switch/hub, while the second router can give out DHCP address.

    Number 2 isn't an issue, you cable service provider has no control over weather or not you have a WAP.

    I believe the problem lies in the way the router and modem are configured. For the most part all you have to do to access the internet is turn on you Linksys cable modem, wait a few moments for it to obtain and IP, then plug in your Netgear router. I'd first start by resetting you Netgear router to the default settings. Usually there is a button you can push with paper clip that will reset it.

    A Netgear/Linksys incompatibility is very unlikley IMO, it shouldn't matter what is plugged into what. But then again I don't own and Netgear/Linksys equipment. I use a D-Link router, plugged into an Airport Extreme plugged into a Motorola Surfboard cable modem with no problems.

Share This Page