1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Weird FTP Issue... Please help

Discussion in 'Mac OS X Server, Xserve, and Networking' started by JasonDawg18, May 26, 2009.

  1. macrumors regular



    I use Fetch as my FTP client. I recently upgraded to the new unibody MBP, and transfered all of my old files and settings over to this new mac.

    In Fetch, I've got about 10 FTP servers I regularly connect to, for web projects, and for uploading files to a print shop.

    All of my connections are working, except for the one for my local print shop. I know the FTP Server is working, because I've had others connect to it.

    Is there potential that a Firewall or some other programs are blocking it? I've tried connecting through Fetch, Apple's Finder, and CyberDuck.

    I'm trying to connect at home, where everything on my network is wide open. I have no problem connecting to any of my other FTPs.

    Thanks for your suggestions...

  2. macrumors regular

    Do you connect to it using an IP address or a domain name? What is the specific error you are getting? If multiple apps have the same issue connecting to the one server, yet others can, yet you can connect fine to other FTP servers, it seems like the problem should be around the way you are trying to connect.

    Does this server run any other kind of service, like web or file sharing? Can you connect to it in any other way (not as an alternative to FTP but to test connectivity)?
  3. macrumors regular


    Thanks for the reply. I'm not sure what their server does and does not do.

    I connect to it though a domain name, not an IP address.

    I cannot figure out any way to connect. Whether I try through Fetch, Safari (they have a way to do web uploads, but it's not working), connecting through Finder, and a couple other FTP clients, I get the same message: "Connection Timed Out."

    Any thoughts? Any settings wrong on my computer, maybe?
  4. macrumors regular

    Without more specifics I'm not sure how much more one can offer. I would try connecting via an IP address instead of a domain name. Perhaps there is some kind of DNS issue. Might be on their end, or it might be your ISPs DNS server. One way to tell is to manually setup your DNS to use the servers from OpenDNS.org.
  5. macrumors 6502a


    Can you telnet to it via port 21?
  6. macrumors G4

    FTP connections can be "active" or "passive". Different port is used for each type. I'll bet your connections work or not based of if they are active or passive. If so then yes you have a firewall issue

    Here is a good writeup

    Very hard to debug using a point and click FTP client. Work the problem using just plain "ftp" in the terminal so you can see what is going on.
  7. macrumors regular


    How can I check to see if it's a Firewall issue? What settings can I change or test?

    Nothing else has worked.

  8. macrumors regular

    Do you connect via FTP or SFTP? Whichever it is, it is set properly?
  9. macrumors regular

    Have you tried connecting to it via an IP address instead of a domain name?

Share This Page