Weird Launchpad Bug

Discussion in 'OS X Mountain Lion (10.8)' started by DavidMarks, May 7, 2013.

  1. DavidMarks, May 7, 2013
    Last edited by a moderator: May 7, 2013

    macrumors member


    Mar 6, 2013
    So I was rearranging my launchpad icons, when I got surprised with this cubic art Picasso thing while I was trying to drag an app to a folder:


    Has anybody experienced this before?

    I was quick enough to take a snapshot. Then launchpad froze and restarted. Now the folder I was dragging the icon to doesn't work anymore: I click on it, an launchpad quits. Same with dragging. Now i have a useless Utilities folder with 4 apps on it that I can't access through Launchpad. What a weird bug. I like the concept of Launchpad but somehow I feel there's a lot of improving left to do, such as an edit/delete button to easily rearrange apps instead of one at a time. And an easier way to change the background effect other than control+option+command+b. Which, by the way, resets to default every time you restart.

    Here's how it normally looks like for comparison:


  2. justperry, May 7, 2013
    Last edited: May 7, 2013

    macrumors 603


    The only way to resolve this is to move (Don't delete yet) the following Folder to (For instance) your Desktop and relaunch the Dock.

    /Users/****/Library/Application Support/Dock

    **** = your Home Folders name.

    Move this Folder to the Desktop, Open Activity Monitor, look for the Dock Application and Quit it.
    Be aware, all your settings in Launchpad are reset, if you click on the Launchpad App in your Dock after you quit the Dock it will take a bit of time to reload the Applications again.

    If you are not happy with it move the Folder back again, quit the Dock again, but, the problem will likely get back again.

    I don't think you can rebuild the database file but I might be wrong, there might be a Terminal command to rebuild it.

    Edit: Before you do the above I recommend you to first quit the Dock and see if that cleared the issues you have, quit the Dock in Activity Monitor and see if that resolved it, if not go ahead and do the above.
  3. thread starter macrumors member


    Mar 6, 2013
    Thank you, it worked!

    Still wondering what the hell that artistic pixelation was though... It actually looked nice! :D
  4. macrumors 603


    No worries.:D

    Glad it's solved, now you can set that screenshot as your Desktop picture.:p
  5. macrumors P6


    Jan 24, 2010
    That pattern was one of Mac OS X's OpenGL filters not working correctly.

Share This Page