Windows 7 can see but not access OS X share

Discussion in 'Mac OS X Server, Xserve, and Networking' started by toronado455, Sep 18, 2013.

  1. macrumors regular

    Apr 2, 2009
    In OS X, Windows sharing is on and I have "Shared folder" checked on the folders I want to share. OS X can access shared folders on the Windows box, but Windows can't access the OS X shared folders. Windows prompts for a "network password". I don't know what that would be, but I set up user accounts on both machines with the same user names and passwords. I've tried entering these credentials but nothing ever works.
  2. thread starter macrumors regular

    Apr 2, 2009
    Got this (sort of) working...

    I believe the problem is that OS X isn't on the same workgroup (or ANY workgroup) as the Windows box.

    In OS X, System Preferences > Network > Advanced... > WINS tab:
    If I enter the NetBIOS name of the OS X computer and the name of the Windows Workgroup (default "WORKGROUP") click OK, then Apply, this fixes it and Windows can access the shares on OS X and doesn't prompt for a network password.

    But it is only a temporary fix. Rebooting OS X clears out the values I entered in the WINS tab, even if I have "clicked the lock to prevent further changes".

    I'm not even sure that this is the correct place to designate a Windows Workgroup name on OS X. Anyone know?
  3. macrumors 68040


    Dec 19, 2004
  4. thread starter macrumors regular

    Apr 2, 2009
    OK, yeah, thanks. I think I found your thread when I was searching for answers.

    But what I really would like to know now is, on the OS X side, why don't the values I enter into the WINS tab stick?
  5. macrumors 6502

    Sep 26, 2011
    Sorry, but this has nothing to do with Vista or Win 7. This has to do with the fact that Apple dumped SMB due to licensing issues and uses a home baked SMB client that does not work well and is buggy. Like the fact that it does not show mounted SMB shares anymore in the left side of finder. The WINS bug is just one of many. If you have a domain controller, join the macs and the pc to the same domain sometimes helps. Sometimes you need to turn off file sharing and then fix the wins and then turn your file sharing back on. I have contacted Apple many times about should as well.
  6. thread starter macrumors regular

    Apr 2, 2009
    Wow. So what does Apple expect us to do? Buy OS X server?
  7. macrumors regular

    Feb 7, 2013
    No, OS X server has the same problems. Samba changed to the GPLv3 license and apple did not accept the license, so they made their own SMB implementation.

    The easiest way to fix this is to setup an old computer as a WINS server for your local network and the OS X box can pull those wins values from the server on boot.
  8. thread starter macrumors regular

    Apr 2, 2009
    Wow. This sucks. Why does Apple's SMB implementation have to suck so bad? I don't want to be running an old computer all the time just to fix this.

    What if I entered a "dummy" IP address into the WINS servers list? Would that work LOL? All that's needed is for OS X to know the name of the workgroup it is supposed to be on. As long as it knows that, everything works.
  9. macrumors regular

    Feb 7, 2013
    unfortunately no, you have to remember that apple had to write their smb code from scratch starting with lion. Maybe it's based on an old samba version though, not really sure.

    perhaps you could put together a script to add the workgroup name at boot up?
  10. thread starter macrumors regular

    Apr 2, 2009
    OK, I suppose I can try to be a bit forgiving of Apple then. :rolleyes:
    I like your idea about the startup script as a workaround. I used to write scripts in AppleScript years ago, maybe I can devise something.
  11. macrumors demi-god


    Dec 30, 2009
    DFW, TX
    Mavericks and the new OS X Server should solve your problems hopefully. SMB2.
  12. macrumors regular

    Feb 7, 2013
    Which is a big reason i am looking forward to mavericks! Maybe we will get some other nifty things as well. We can only hope.
  13. macrumors newbie

    Sep 27, 2014
    See your OS X from Windows 7

    on Your mac computer, Go to System Preferences, check File Sharing, on New Window check "share files and folders using SMB"
    On Windows file sharing bottom filed you must see your user name, press done

    Go to windows pc, go to network, give user name and password !!!!:)
  14. macrumors 601


    Feb 19, 2008
    The Finger Lakes Region
    Plus going from a 10.9.x or better OS X system and are trying to connect to Windows 7 or better using the string cifs:// instead of the smb://. This forces SMB2 to use the SMB1 connection instead. Windows 7 or better connects better with this command.
  15. macrumors newbie

    Dec 29, 2013
    Try direct IP address

    We have two servers running using OS X Server, occasionally and under duress I connect with a Windows machine. One server operates as normal, the other (identical settings, even with lots of tweaks) I have the issue where the Windows machine can "see" the server but never prompts for the login information and gives me "Windows cannot access" I solved this by typing the IP address of the computer I am trying to access instead of using the host name. You can see the IP address when viewing the File Sharing panel in System Preferences.
  16. thread starter macrumors regular

    Apr 2, 2009
    Wow, way to bump a thread - one year later TO THE DAY! Thanks! I'll give this a try once I've got my network going again. I'm currently in single computer mode.
  17. Gorazd, Oct 23, 2014
    Last edited: Oct 27, 2014

    macrumors newbie

    Oct 23, 2014

    run regedit.exe as administrator on the Win 7 machine.

    Delete this DWORD line in the Win 7 registry and you shall be fine:


    You do not need to restart the Win 7 system in order that you can now successfully connect for example to the: \\MACPRO\HARDDRIVESHARE from Win 7 machine.

    You only need to fill the administrator name and password login for the Mac OSX computer and you shall now successfully map the Mac network drive on the Win 7 machine.

    Best regards,

  18. thread starter macrumors regular

    Apr 2, 2009
    Hi, what exactly does this registry edit do?
    (I like to know what I'm doing and why before messing with the registry.)
  19. Gorazd, Oct 24, 2014
    Last edited: Oct 24, 2014

    macrumors newbie

    Oct 23, 2014

    The registry variable:


    is used to set the minimum challenge/response algorithm.

    The DWORD value can be: 0, 1, 2, 3, 4, 5.

    Please know that the Mountain Lion OSX, Mavericks OSX and Yosemite OSX domian controllers does not accept LM, NTLM, LMv2, and NTLMv2 responses so if the Win 7 and Win 8.1 sends the LM, NTLM, LMv2, and NTLMv2 responses to MAC with these OSes it does not get responses back so the connection is unsuccessfull from the Win 7 or Win 8.1 side so the problem is in the Win 7 or Win 8.1 operating system which does not allow the connection to be made!

    If you need this DWORD line in the registry you can stil connect from the MAC environment to the Win 7
    or Win 8.1 shares!
    But you can not connect from Win 7 or Win 8.1 environment to MAC OSX shares!

    Best regards,

  20. macrumors newbie

    Oct 23, 2014
  21. msh
    macrumors member

    Jun 13, 2009
    Redondo Beach, CA

    I have WIN7 Ultimate; is it safe to delete LmCompatibilityLevel as well?

    Also, I have disabled smb2/3 in WIN7; can that now be safely enabled?

    Finally, are you mapping the Mac shared drive to a drive letter bypassing the NETBIOS name?
  22. macrumors newbie

    Sep 15, 2008

    This worked for me, thanks so much. I was worried that my problem was that my Windows laptop is on a domain rather than a workgroup, and hence my I wouldn't be able to assign the same workgroup in WINS on my Mac. But I tried this and voila, I can map my shared folders onto my Win7 laptop.
  23. macrumors newbie

    Jan 31, 2015
    Windows 7 File Sharing

    @Gorazd Thank you ever so much. Your solution was spot on.
  24. macrumors newbie

    May 15, 2015
    Just change settings on OSX

    Just an update for future people that find this thread: You do NOT need to go changing registry keys in Windows to get this to work.

    Do what SStamatis has mentioned, which is simply to change file sharing settings on OSX (Yosemite in my case) to use SMB _and_ individually select which OSX accounts should be accessible by the windows machine.

    Here are SStamatis instructions again (edited for clarity):

    "on Your mac computer, Go to System Preferences, enable File Sharing, click on the Options button, enable "share files and folders using SMB" and then enable (via the checkbox) each OSX account in the "Windows file sharing" section"
  25. thread starter macrumors regular

    Apr 2, 2009

Share This Page