Xcode: "Unknown Error. Failed to Save."

Discussion in 'Mac Programming' started by TheBritishBloke, Dec 9, 2011.

  1. macrumors 68030

    TheBritishBloke

    #1
    I'm continually getting this error whenever I open up a project in Xcode or when I close a project. Anybody had any similar problems? I've tried a fresh install from the Mac App Store and only using a freshly made project file.

    I also sometimes get "The file 'main.cpp' is locked and cannot be saved", even though the file isn't locked.
     
  2. macrumors 68020

    LostSoul80

    #2
    Do you have the write privilege for the directory of the project?
     
  3. macrumors 68030

    TheBritishBloke

    #3
    Read & Write has been set for everything and all enclosing folders for everything even remotely close to where it's being saved (My Home Folder > Documents)
     
  4. macrumors 603

    #4
    Is the folder locked? Locked takes precedence over having write permission.

    Try this command in Terminal.app (copy and paste it):
    Code:
    ls -lOR ~/Documents | grep chg
    
    Post any output.
     
  5. macrumors 68030

    TheBritishBloke

    #5
    Didn't get any output, and still getting the same error.
     

Share This Page