Yahoo Mail

Discussion in 'Mac Basics and Help' started by 06Honda, Jan 5, 2013.

  1. macrumors regular

    May 25, 2011
    Got this message when attempting to check my yahoo mail:

    You're almost there, but your web browser doesn’t support the newest version of Yahoo! Mail
    Upgrade to a faster, more secure version of a supported browser. It's free and it only takes a few moments:

    I use a Macbook Pro; Snow Leopard and Safari Version 5.1.7 (6534.57.2)
  2. simsaladimbamba

    Nov 28, 2010
    Strange, I just tried it myself with Safari 5.0.5 and Mac OS X 10.6.8 and I could check mail via
    But nowadays I use Sparrow to have my accounts checked.
  3. thread starter macrumors regular

    May 25, 2011
    May have been a glitch, will try in am. Thanks for posting back.
  4. macrumors 6502

    Sep 28, 2009
  5. macrumors regular

    Mar 5, 2008
    Anyone else have a solution to this issue?

    I have the latest version of MacOS and Safari, but everyone once in a while, Yahoo will claim I don't have the latest Safari to run their webmail.

    Attached Files:

Share This Page