Your Apple TV is not authorised to play this content...

Discussion in 'Apple TV and Home Theater' started by gazfocus, Feb 22, 2008.

  1. macrumors 68000

    gazfocus

    Joined:
    Jan 3, 2008
    Location:
    Liverpool, UK
    #1
    I have got an Apple TV and it will not let me log into my iTunes account at all. Also, I have sync'd all of my music from iTunes to the Apple TV and some of it won't play and I just get the message "Your Apple TV is not authorised to play this content" although other 'purchased' content plays fine.

    Also, YouTube doesnt work on my Apple TV.

    Any ideas?
     
  2. macrumors 6502

    Joined:
    Jul 17, 2007
    Location:
    San Diego, CA
    #2
    When I had that problem I unplugged the power to the Apple TV and when I plugged it back in it worked fine.
     
  3. macrumors 6502a

    Joined:
    Aug 7, 2007
    Location:
    Newton, MA
    #3
    Are you sure you're on the internet?
     
  4. thread starter macrumors 68000

    gazfocus

    Joined:
    Jan 3, 2008
    Location:
    Liverpool, UK
    #4
    Hi. Thanks for the comments. I have tried unplugging it, and system restoring it a few times with no joy.

    I also know it's connecting to the internet because I was able to do the Take 2 update and I can watch TV show previews etc.

    Thanks again and any advice welcome.
     
  5. macrumors member

    Joined:
    Feb 22, 2004
    Location:
    South Dakota
    #5
    I had the "Your Apple TV is not authorized..." message just the other day. It was happening because one of my Macs that was connected to my Apple TV for streaming was not logged into the iTunes music store. The weird thing was that the media I was trying to play was not on the computer that wasn't logged it....it was on a properly logged in machine.

    Check your iTunes on your computer(s) and make sure you are logged in with your Apple ID and password. For me, as soon as my iTunes was logged in, the Apple TV started playing all the media again.
     
  6. thread starter macrumors 68000

    gazfocus

    Joined:
    Jan 3, 2008
    Location:
    Liverpool, UK
    #6
    Thanks for your message. I'm a bit confused. I have more than one computer with iTunes on, but only have 1 computer sync'd/connected to the Apple TV. Would I still need to log onto iTunes with all the other computers?
     
  7. macrumors regular

    Joined:
    Apr 15, 2006
    Location:
    San Francisco Bay Area
    #7
    I got my ATV this week and I'm having the same problems. It won't play any iTunes store purchased content and it won't let me login to the store to buy content directly using ATV. I've tried unplugging the ATV, I've deauthorized and reauthorized the shared computer on iTunes....... nothing has worked.

    Has anyone found a solution to these problems?
     
  8. macrumors 6502a

    mojohanna

    Joined:
    Jul 7, 2004
    Location:
    Cleveland
    #8
    Have you authorized that device? I think that the ATV is counts as one of the 5 computers you can authorize for use with content. If it is not registered and authorized then content will not play on it.
     
  9. thread starter macrumors 68000

    gazfocus

    Joined:
    Jan 3, 2008
    Location:
    Liverpool, UK
    #9
    The Apple TV is supposed to authorize automatically when you sync your iTunes library and according to Apple it doesn't count as one of your 5 computers (this is the same with an iPod which doesnt count either).

    When I first sync'd my AppleTV, iTunes tried to authorize the AppleTV but it still won't play my purchased content.
     
  10. macrumors regular

    Joined:
    Apr 15, 2006
    Location:
    San Francisco Bay Area
    #10
    Ditto. I have the same issues.
     
  11. macrumors 603

    netdog

    Joined:
    Feb 6, 2006
    Location:
    London
    #11
    Are your purchases made with a US account at iTS or with an account with the UK store?
     
  12. thread starter macrumors 68000

    gazfocus

    Joined:
    Jan 3, 2008
    Location:
    Liverpool, UK
    #12
    I have both a US and a UK iTunes account and neither will log on with the AppleTV. Thanks
     
  13. macrumors regular

    Joined:
    Apr 15, 2006
    Location:
    San Francisco Bay Area
    #13
    I've just spent 2-hours on the phone with a "wireless specialist" at Apple Support. He is baffled as to why the ATV won't recognize my Apple ID. He had me change the password to the Apple ID, unplug the ATV, wait a few minutes and try again. Still no luck.

    On the ATV when I try to enter my Apple ID and password it instantly says that my ID is not recognized. It doesn't appear to even try to authorize it.

    The support tech said he needed to talk to "engineering" and he'll call me back in 10 - 15 minutes.

    At this point I just want to exchange the ATV for another unit but I'm hopeful that he'll call me back with the fix.
     
  14. macrumors member

    Joined:
    Feb 22, 2004
    Location:
    South Dakota
    #14
    Here's what happened to me....my Apple TV was synced with my main computer (mac mini) and all was well. Then I thought I would try streaming from my iBook just for fun. I connected the iBook's iTunes to the Apple TV via streaming. However the iBook's iTunes was not logged in to the Apple Store. Instantly, the content on my Apple TV would not play anymore. While troubleshooting, I noticed that the iBook's iTunes was not logged in. I logged it in and the ATV content started working again. The really weird thing was that ALL content that was purchased via iTunes could not be played regardless of whether it was on the iBook or the Mac Mini.

    Long story short, it appears to me that all your connected sources need to be authorized in iTunes to make your ATV content play. Not sure if that's true always, but it worked for me.
     
  15. thread starter macrumors 68000

    gazfocus

    Joined:
    Jan 3, 2008
    Location:
    Liverpool, UK
    #15
    If you could keep us updated when they contact you, that would be great. I am seriously considering returning this...although it's a refurb so not sure how to go about returning it.
     
  16. macrumors newbie

    Joined:
    Jun 12, 2007
    #16
    I had a similar problem. I was connected to internet using a proxy server. Appletv did not play nicely with this even though everything else looked ok. Turned off proxy all is well...
     
  17. thread starter macrumors 68000

    gazfocus

    Joined:
    Jan 3, 2008
    Location:
    Liverpool, UK
    #17
    I'm not using a proxy server as far as I know, and as I said before, I can see all the albums/films/tv shows that are available on the iTunes store but just can't authorize my Apple TV or log into my iTunes Account
     
  18. macrumors regular

    Joined:
    Apr 15, 2006
    Location:
    San Francisco Bay Area
    #18
    I spoke again with the Apple support guys..... after trying all of the fixes that they could think of, including some tinkering with my Airport Extreme wireless settings, they finally recommended that I take the ATV to my local Apple Store for an exchange as they could not figure out why it would not accept my Apple ID.

    I'll fire up the new ATV later tonight.
     
  19. macrumors regular

    Joined:
    Apr 15, 2006
    Location:
    San Francisco Bay Area
    #19
    I just setup the exchanged ATV. Everything works correctly on the first try.

    If you're still having trouble getting it to accept your Apple ID, then you should take it back to the store and tell them it was DOA. I think there is a bad batch of new ATVs out there that won't work no matter what you try.
     
  20. thread starter macrumors 68000

    gazfocus

    Joined:
    Jan 3, 2008
    Location:
    Liverpool, UK
    #20
    Hi
    Thanks for this. Will I still be able to take mine to an Apple Store even if I bought it from the online refurb store?

    Thanks
     
  21. macrumors newbie

    Joined:
    Feb 24, 2008
    Location:
    Valley Park, Missouri
    #21
    Are you using wifi with your Apple TV?

    I had the same problem. I was using wifi to set up my Apple TV. The problem was with my router. I had originally set up my router to require a login password to access wifi. This is like the password needed when you go to a hotel. It's not WEP or WPA. So if someone was in my home, in order to access my wifi they would have to type in a password I originally set up. The problem was, the Apple TV box couldn't enter this password. So when I originally installed the Apple TV, it found immediately my wireless signal, and on the network setting, everything looked perfect. The problem was, though, it wasn't communicating with the router, and therefore no signal was ever sent to ITunes to authorize the Apple TV box. As soon as I removed the password requirement from my router, it all synched perfectly, and I was then able to watch everything on my Apple TV. So, you might want to check your router settings. It may have nothing to do with the Apple TV itself.
     
  22. thread starter macrumors 68000

    gazfocus

    Joined:
    Jan 3, 2008
    Location:
    Liverpool, UK
    #22
    Thanks for this, however, I am able to sync my iTunes library etc, and I can watch TV show previews and Movie Trailers strait from the itunes store on the AppleTV, just can't buy anything or play anything I've bought on my computer as I can't log in :(
     
  23. macrumors 6502a

    Joined:
    Sep 8, 2006
    Location:
    Michigan
    #23
    I recently got the same issue. Any sure fixes for this other than taking it in?
     
  24. macrumors newbie

    Joined:
    Feb 24, 2008
    Location:
    Valley Park, Missouri
    #24
  25. macrumors newbie

    Joined:
    Oct 19, 2007
    #25
    just had the same issue

    Had the exact same issue. i had transfered a movie i had rented from iTunes. it wouldnt allow me to play it and under the movie it said i had 2624 days left to watch it. but i could watch trailers and tv show previews. I went back to my computer and noticed when i first opened ATV and set it up i skipped the Register Apple TV and instead just hit continue. after rebooting my ATV the register screen came back up again so i registered it and had to put in my login name and password verified my address info and it was done. went to my atv and bam it is allowing me to do everything now.
    If rebooting your atv doesnt bring up the register screen im not sure how to bring it up, or if this doesnt fix your problem sorry, just thought i would share. Good luck
     

Share This Page