Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > OS X

Reply
 
Thread Tools Search this Thread Display Modes
Old Mar 30, 2010, 01:22 PM   #1
surferfromuk
macrumors 65816
 
Join Date: Feb 2007
10.6.3 trackpad & Keyboard Hanging

Since installing 10.6.3 my trackpad (i.e mouse pointer) and keyboard are hanging up for 10 seconds at a time every couple of minutes.

It's seriously annoying - this happening to anyone else?
__________________
Why do I love Apple - Simple. They make products that enhance my life in a positive way.
surferfromuk is offline   0 Reply With Quote
Old Mar 30, 2010, 01:46 PM   #2
smogsy
macrumors 6502a
 
Join Date: Jan 2008
not on my macbook 2007 model nope
__________________
Mac Pro 2009, 2.26GHz, 12GB Ram, 4870 512MB 2.6TB HDD
Macbook 2.2 C2D, 4GB, 120GB, X3100
smogsy is offline   0 Reply With Quote
Old Mar 30, 2010, 02:11 PM   #3
Vonswanko
macrumors regular
 
Join Date: Oct 2008
Same has been happening to me. 2009 13in MBP I have run Onyx, and repaired permissions. Still the same. Very intermittent, and very annoying.
Vonswanko is offline   0 Reply With Quote
Old Mar 30, 2010, 02:46 PM   #4
surferfromuk
Thread Starter
macrumors 65816
 
Join Date: Feb 2007
Quote:
Originally Posted by Vonswanko View Post
Same has been happening to me. 2009 13in MBP I have run Onyx, and repaired permissions. Still the same. Very intermittent, and very annoying.
If it helps I just binned all the PACE support stuff and I haven't had it since.

Strike that - it's still happening.
__________________
Why do I love Apple - Simple. They make products that enhance my life in a positive way.

Last edited by surferfromuk; Apr 2, 2010 at 10:08 AM.
surferfromuk is offline   0 Reply With Quote
Old Mar 30, 2010, 03:07 PM   #5
Vonswanko
macrumors regular
 
Join Date: Oct 2008
Quote:
Originally Posted by surferfromuk View Post
If it helps I just binned all the PACE support stuff and I haven't had it since.
Not really sure what that means, but I am willing to try it out. I reset my PRAM and I think that may have helped.
Vonswanko is offline   0 Reply With Quote
Old Mar 30, 2010, 05:42 PM   #6
macjonnny
macrumors newbie
 
Join Date: Mar 2010
Same thing happening to me too. MBP late 2008. Unresponsive keyboard and trackpad for 10-15 secs or so. Have never had this problem before 10.6.3. I have tried resetting PRAM and that didn't help. I just reset my SMC, so we'll see if that holds.

I was working most of the day just fine with an external keyboard and mouse. Then as soon as I started using it at home, consistent lockups. Amazingly, it hasn't done it all since I started typing this, so maybe it was the SMC.

Nope, just happened as I typed that last line. If anyone has any other suggestions, please reply.
macjonnny is offline   0 Reply With Quote
Old Mar 30, 2010, 08:25 PM   #7
benthewraith
macrumors 68030
 
benthewraith's Avatar
 
Join Date: May 2006
Location: Miami, FL
Send a message via AIM to benthewraith Send a message via MSN to benthewraith
Quote:
Originally Posted by macjonnny View Post
Same thing happening to me too. MBP late 2008. Unresponsive keyboard and trackpad for 10-15 secs or so. Have never had this problem before 10.6.3. I have tried resetting PRAM and that didn't help. I just reset my SMC, so we'll see if that holds.

I was working most of the day just fine with an external keyboard and mouse. Then as soon as I started using it at home, consistent lockups. Amazingly, it hasn't done it all since I started typing this, so maybe it was the SMC.

Nope, just happened as I typed that last line. If anyone has any other suggestions, please reply.
I have this problem. It mostly only happens when the computer is left to sit idle for awhile. Then the bug resolves itself. Still quite annoying. This happened only once under 10.6.2. Needless to say, I have an appointment with the Genius Bar tomorrow for two unrelated issues, and will bring the issue up with them tomorrow.
__________________
Late-2013 13" rMBP, 2.4GHz, 8 GB RAM 250GB SSD,
benthewraith is offline   0 Reply With Quote
Old Mar 31, 2010, 01:55 AM   #8
cleric
macrumors 6502a
 
cleric's Avatar
 
Join Date: Jun 2008
Location: Minneapolis, MN
Having this issue on my early 09' mini started immedately after upgrading to 10.6.3
__________________
MacBook Air Rev D. 1.86ghz 4gb Ram 128gb SSD
iPhone 4 16gb
cleric is offline   0 Reply With Quote
Old Mar 31, 2010, 07:51 AM   #9
duffy666
macrumors newbie
 
Join Date: Mar 2010
Same thing here on a MBP June 2008.
duffy666 is offline   0 Reply With Quote
Old Mar 31, 2010, 09:36 AM   #10
funkytastic3
macrumors newbie
 
Join Date: Aug 2008
same problem - very, very irritating
funkytastic3 is offline   0 Reply With Quote
Old Mar 31, 2010, 10:07 AM   #11
Signal-11
macrumors 65816
 
Signal-11's Avatar
 
Join Date: Mar 2008
Location: 2nd Star to the Right
Been happening since I updated to 10.6.3 on an early 2008 MBP. Just the trackpad. Keyboard responds fine. Seems completely random and i can't find the trigger. Driving me nuts.
Signal-11 is offline   0 Reply With Quote
Old Mar 31, 2010, 10:29 AM   #12
mac donalds
macrumors newbie
 
Join Date: Mar 2010
Quote:
Originally Posted by surferfromuk View Post
Since installing 10.6.3 my trackpad (i.e mouse pointer) and keyboard are hanging up for 10 seconds at a time every couple of minutes.

It's seriously annoying - this happening to anyone else?

Im having exactly the same problems with my late 2008 MB Pro.
The Trackpad seems to "freeze" for 5-10 seconds.! It happens randomly, sometimes 1 times per hour, somethimes 2 times per minute .

It happend the first time only minutes after the update to 10.6.3

... the mouse isn`t affected so far ...

apple needs to patch that ASAP


I found another thread about this problem:

http://discussions.apple.com/thread....art=0&tstart=0

Last edited by mac donalds; Mar 31, 2010 at 10:42 AM.
mac donalds is offline   0 Reply With Quote
Old Mar 31, 2010, 11:23 AM   #13
Signal-11
macrumors 65816
 
Signal-11's Avatar
 
Join Date: Mar 2008
Location: 2nd Star to the Right
Quote:
Originally Posted by mac donalds View Post
I found another thread about this problem:

http://discussions.apple.com/thread....art=0&tstart=0
I've been keeping up with that thread - nothing on it seems to be helping, either.

The randomness is driving me crazy. I'm not even close to being able to isolate this - nothing seems out of the ordinary, no console messages, no spikes in activity, nothing. Just random malfunctions.

Anyone else using Steermouse?
Signal-11 is offline   0 Reply With Quote
Old Mar 31, 2010, 01:09 PM   #14
mac donalds
macrumors newbie
 
Join Date: Mar 2010
Quote:
Originally Posted by Signal-11 View Post

Anyone else using Steermouse?
nope, I don`t.

Im getting insane.
mac donalds is offline   0 Reply With Quote
Old Mar 31, 2010, 01:16 PM   #15
Signal-11
macrumors 65816
 
Signal-11's Avatar
 
Join Date: Mar 2008
Location: 2nd Star to the Right
Quote:
Originally Posted by surferfromuk View Post
If it helps I just binned all the PACE support stuff and I haven't had it since.
Can you give a description of how you did this, please?

Trying to resolve this trackpad issue has been taking up all of my time.
Signal-11 is offline   0 Reply With Quote
Old Mar 31, 2010, 02:56 PM   #16
funwithamar
macrumors regular
 
Join Date: Dec 2008
try onyx .. and do all the maintenance work .. should help
funwithamar is offline   0 Reply With Quote
Old Mar 31, 2010, 03:02 PM   #17
Signal-11
macrumors 65816
 
Signal-11's Avatar
 
Join Date: Mar 2008
Location: 2nd Star to the Right
Quote:
Originally Posted by funwithamar View Post
try onyx .. and do all the maintenance work .. should help
Way ahead of you. Didn't help.
Signal-11 is offline   0 Reply With Quote
Old Mar 31, 2010, 05:16 PM   #18
Beaverfish
macrumors regular
 
Join Date: Dec 2008
I too have this issue on my late 2008 MBP I have my dock to automatically hide. And it doest pop up anymore. Things were working fine earlier. Now i can't seem to do anything. I'm really pissed off. I think I'm gonna have to reinstall 10.6 :-(
__________________
2011 i7 HR Macbook Pro 2.2 Ghz
iPhone 5 64GB
Mac Mini 2012
Beaverfish is offline   0 Reply With Quote
Old Mar 31, 2010, 05:44 PM   #19
Signal-11
macrumors 65816
 
Signal-11's Avatar
 
Join Date: Mar 2008
Location: 2nd Star to the Right
This shouldn't matter but....

How many of you on the early 2008 MBPs were using the multitouch kext hack on 10.5?

Console errors (as brought up on the Apple support forums):

Code:
30/03/10 16:12:48	kernel AppleUSBMultitouchDriver::validateChecksum 
- 18-byte packet checksum is incorrect 
(expected 0x3af, checksum bytes were 0xb5e)
How many of you applied the applied the combo update?

Driving me nuts....
Signal-11 is offline   0 Reply With Quote
Old Mar 31, 2010, 07:45 PM   #20
Vonswanko
macrumors regular
 
Join Date: Oct 2008
Well its not really a fix as much as a work around, but I am using JItouch, and has cured my issues. Lets see if Apple gets something working soon.

JITouch link here
Vonswanko is offline   0 Reply With Quote
Old Mar 31, 2010, 08:58 PM   #21
88888888
macrumors 6502
 
Join Date: May 2008
Same here.. wtf it's gettting really annoying.
I'm early 2008 MBP.
i didnt use the hack.
__________________
Flickr
88888888 is offline   0 Reply With Quote
Old Apr 1, 2010, 04:04 AM   #22
Beaverfish
macrumors regular
 
Join Date: Dec 2008
Has anyone tried an erase and install of snow leoprad. My MBP is pretty much unusable at the mo :-(
__________________
2011 i7 HR Macbook Pro 2.2 Ghz
iPhone 5 64GB
Mac Mini 2012
Beaverfish is offline   0 Reply With Quote
Old Apr 1, 2010, 06:42 AM   #23
mac donalds
macrumors newbie
 
Join Date: Mar 2010
Quote:
Originally Posted by Beaverfish View Post
Has anyone tried an erase and install of snow leoprad. My MBP is pretty much unusable at the mo :-(
some people in the other thread did that and it fixed the problem.

Has somebody informed apple about this??? They need to fix this mess! I need to work with that machine.

I`m going to email apple now.
mac donalds is offline   0 Reply With Quote
Old Apr 1, 2010, 07:29 AM   #24
hmadacompaq
macrumors newbie
 
Join Date: Mar 2010
i have this problem also
when h press reject it show me message shutdown and sleep and restart

i think i have to format or downgrade sno
hmadacompaq is offline   0 Reply With Quote
Old Apr 1, 2010, 07:51 AM   #25
Beaverfish
macrumors regular
 
Join Date: Dec 2008
Quote:
Originally Posted by mac donalds View Post
some people in the other thread did that and it fixed the problem.

Has somebody informed apple about this??? They need to fix this mess! I need to work with that machine.

I`m going to email apple now.
Can you please post your email and any responses you get from apple?
__________________
2011 i7 HR Macbook Pro 2.2 Ghz
iPhone 5 64GB
Mac Mini 2012
Beaverfish is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Unresponsive Keyboard & Trackpad (Possible Temp Fix) iShorty MacBook Pro 4 Nov 6, 2013 05:10 PM
MB Pro 2010 Keyboard & Trackpad Freeze black0ut MacBook Pro 0 Apr 9, 2013 06:28 PM
What dock For MBP Wireless Keyboard & Trackpad 86nji MacBook Pro 0 Nov 26, 2012 03:21 PM
rMBP keyboard & trackpad unresponsive anteksiler MacBook Pro 1 Oct 13, 2012 04:01 PM

Forum Jump

All times are GMT -5. The time now is 05:31 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC