how to mount ext3

Discussion in 'OS X' started by silverwhalle, Feb 27, 2010.

  1. macrumors newbie

    Joined:
    Mar 31, 2008
    Location:
    seoul
    #1
    i have a macbook 5,2.
    i've been trying to mount ext3 partition on which fedora is installed.
    to do that, i'd searched internet for the howto to mount ext3.
    as a result, i installed macfuse and ext2fx on mac and tried to mount with
    command mount. but failed..

    root# mount_ext2 -o rdonly -x /dev/disk0s5 /Volumes/Linux/
    mount_ext2: /dev/disk0s5 on /Volumes/Linux: Resource busy

    fuse-ext2 wasn't working as well..
    is it impossible ? if i change that ext3 partition to ext2, will it be working?
     
  2. Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    I'd say ext2fx Is made for ext2 file systems and ext3 being different isn't supported.

    You can use dropbox to move files between the two or a thumb drive or even an external disk formatted to FAT.

    Ext3 and now ext4 are much more advanced then ext2 that I wouldn't recommend going backwards to ext2. Heck F12's default is ext4 at this point and is pretty much rock solid
     
  3. thread starter macrumors newbie

    Joined:
    Mar 31, 2008
    Location:
    seoul
    #3
    ㅜㅜ

    k. thank you maflynn.
     
  4. macrumors 65816

    Joined:
    Nov 26, 2007
    Location:
    Austin, TX
    #4
    Haven't tried it myself, but a google search found this
     
  5. macrumors 6502a

    Joined:
    Oct 13, 2007
    #5
    ext3 is a strict superset of ext2, so the drivers for the ext2 should support ext3 as well, just without the journaling part.
     
  6. macrumors regular

    Joined:
    Jun 12, 2009
    #6
    Where is this partition physically, a external drive? If it was on a linux box I could give you instructions on how to mount it across your network using NFS. Let me know if this would be a possibility for you.
     

Share This Page