1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

ibook g4 won't boot cause of front row mod enabling. help.

Discussion in 'PowerPC Macs' started by Sniper78, Oct 9, 2006.

  1. macrumors newbie

    #1
    I have an ibook g4 tiger 10.4.8 and now it wont boot because I did the front row mod and did not use the updated version for 10.4.8. Now when I boot the computer the apple logo comes up then goes to loading mac osx then doesn'y go further but keeps a blinking screen. Any help would be greatful.
     
  2. macrumors G4

    Chundles

    #2
    Boot from the OSX restore disk and do an erase and install, you'll lose all your data but get your Mac back.

    Sorry mate but Front Row just isn't worth the hassle.
     
  3. macrumors 603

    2nyRiggz

    #3
    ^Indeed...just leave it alone when you do the restore.



    Bless
     
  4. macrumors newbie

    #4
    How do I go about restoring the mac? I tried putting the install disc in when the computer starts up but nothing happens.
     
  5. macrumors 68000

    Shadow

    #5
    Hold C on boot with the disk in.
     
  6. macrumors G4

    Chundles

    #6
    Hold down C when you reboot with the disk in the drive to boot from the CD.
     
  7. macrumors newbie

    #7
    should i hold c before its on then turn it on cause nothing is happening when i hold c.
     
  8. macrumors G4

    Chundles

    #8
    Yeah, you have to hold C while it's booting. That tells the computer to boot from the disk in the drive, not the hard drive.
     
  9. macrumors newbie

    #9
    ok theres weird security on this mac so idk if its not going to let me boot this way. cause with the non secure mac it worked fine. i think im screwed.
     
  10. macrumors 603

    2nyRiggz

    #10
    Did you buy the computer from someone?
    There shouldn't be a problem trying to boot from the CD...



    Bless
     
  11. macrumors newbie

    #11
    it was given to me by the state and i had no problem installing tiger by inserting it then having the computer restart and have the installation begin. But nothing happens when i do any commands at the boot up. Something happened with the mac my friend has that he bought when we held c it brought him to a screen where it says put batteries in a mouse.
     
  12. macrumors 603

    2nyRiggz

    #12
    Do you have the restore disk or the retail version of tiger? You shouldn't need a mouse to do this...just pop the disk in..restart and hold down the C button.:)

    Are we dealing with your mac or your friend's mac?

    Bless
     
  13. macrumors newbie

    #13
    My mac I tried the c thing on my friends mac his and it worked. Now on my mac thats messed up from installing front row mod wrong doesn't want to boot up. I have a cd retail version of tiger for my mac that has a cdrom drive only. When its in there after shutting down then restarting and holding c nothing happens. I dont know if the security is blocking it or what but i had no problem installing tiger when the computer worked.
     
  14. macrumors newbie

    #14
    Is there anything else I can do? Open it reset button somewhere? Anything?
     
  15. macrumors 65816

    Mr_Brightside_@

    #15
    Yeah, same thing happened to me :eek: but I sent it to a friend, who fixed it no hassle, no Erase, nothing; it was brilliant. If nothing works, (nothing worked for me) I can ask him how he did it, it shouldn't be too hard, and I don't even think he used the boot disks... reply soon! (I didn't ask how he did it...)
    Cheers
     
  16. macrumors newbie

    #16
    Yea nothing worked for me if you can ask him that would be awesome. Of all times this happens when I am selling this to in auction. Anything would be greatful. Cheers for helping.
     
  17. macrumors 65816

    Mr_Brightside_@

    #17
    ****, an auction. Well, I can get you a reply, but it'll take a day or so. I'll email him, then forward it to you.
    talk to you later
     
  18. macrumors newbie

    #18
    Well I have til saturday to fix it. But there may be a way for me to get a new one tommorow but it might not be the same condition. So this would be a great help if there is a way to fix it.

    Does anyone here know what mr brightside is talking about now?
     
  19. macrumors 65816

    Mr_Brightside_@

    #19
    It'll be fixed for Saturday ;)
    (I sent it Monday morning, back Mon. night :D )
     
  20. macrumors newbie

    #20
    cheers but this laptop has some security that i have not been able to get by from the people who gave it to me so i hope this is another way.
     
  21. macrumors 65816

    Mr_Brightside_@

    #21
    Right. Well, the first thing noticed about the machine was that it was getting almost all the way through the boot up: maybe rebooting in verbose mode (hold apple-v at start up) might shed some light on what was causing it to freeze?

    Turns out it was generating a crash report (/Library/Logs/CrashReporter/loginwindow.crash.log), so had a peek at that. Apparently, there was a bad call coming out of a certain system plug-in (/System/Library/LoginPlugins/BezelServices.loginPlugin). With any luck, replacing that with a clean copy might do the trick.

    So, booted into target mode (hold T at start up) and chained the iBook to another machine that was also running 10.4.8 using a FireWire cable. That brought the iBook hard drive up on the other machine, and I replaced the bad plug-in. Then I entered a few lines in Terminal to make sure the file permissions were all kosher.

    cd /Volumes/your_drive_name/System/Library/LoginPlugins
    sudo chown -R root BezelServices.loginPlugin
    sudo chgrp -R wheel BezelServices.loginPlugin

    (IIRC the mode flags were already set right, so I didn't bother with those.)

    Then restarted the machine one more time. It booted without a problem, so hopefully that's that, though it might not be a bad idea to back stuff up, just in case.
    Cheers
     
  22. macrumors newbie

    #22
    cheers cheers mate! u saved my mac! this worked right away i would of never thought of this. horray!
     
  23. macrumors 65816

    Mr_Brightside_@

    #23
    You have another Mac? slick. glad it worked.
    have a good one (PS, you can thank me by buying Sam's Town by The Killers:D )
     

Share This Page