Safari Crashes When Tapping URL field

Discussion in 'iOS 9' started by JackieInCo, Jan 27, 2016.

Thread Status:
Not open for further replies.
  1. JackieInCo macrumors 68040

    Joined:
    Jul 18, 2013
    Location:
    Colorado
    #1
    I have four iPhones and when I tap on the URL field or if I get as far as getting the keyboard to popup, as soon as I type the first character, Safari closes.

    This is happening on my 6S on 9.2, 6S+ on 9.2, 5S on 9.0.2 and on my iPad Mini 2 on 9.0.2. My jailbroken 6+ is working ok so far.

    All but the 6S and 6S+ are jailbroken so it's not a jailbreak issue. Google turns up lots of others with this problem but in trying all their suggestions, nothing helps.

    Anyone have any ideas here?
     
  2. ssong macrumors 6502

    ssong

    Joined:
    May 3, 2015
    Location:
    London, UK
    #2
    That is extremely odd cos that just started happening on my iOS 9.2.1 iPad pro but not on my iOS 9.2.1 iPhone 6
     
  3. JackBauer24 macrumors newbie

    Joined:
    Aug 19, 2004
    #3
    I was having the same on my mac and iphone until disabling search suggestions.

    There is a thread about it on the mac forum too, seems to be people with all different versions having the same issue.
     
  4. JackieInCo thread starter macrumors 68040

    Joined:
    Jul 18, 2013
    Location:
    Colorado
    #4
    This seems to have fixed it. Thanks you! In case this matters, my search engine was set to Google.
     
  5. ssong macrumors 6502

    ssong

    Joined:
    May 3, 2015
    Location:
    London, UK
    #5
    That actually did it for me.. Wow thank you. Kind of odd though that it seems to be happening all of a sudden across multiple devices. Could it be that 'search suggestions' works from a central server? (Meaning our searches are recorded?)
     
  6. dtuck90 macrumors member

    Joined:
    Apr 15, 2012
    #6
    Started this morning on my iPad Air running 9.2.1

    My iPhone on 9.2.1 is working fine though
     
  7. JackieInCo thread starter macrumors 68040

    Joined:
    Jul 18, 2013
    Location:
    Colorado
    #7
  8. mdellepi macrumors newbie

    Joined:
    Jun 15, 2015
    Location:
    Italy
    #8
    The same on MacOS!

    In both cases (iPhone and Mac) I solved turing the "Safari suggestions" off...
     
  9. lagwagon Suspended

    lagwagon

    Joined:
    Oct 12, 2014
    Location:
    Calgary, Alberta, Canada
    #9
    So strange how it's worked fine all day and literally right after reading this thread it starts to crash. I was even able to tap the URL bar and search just minutes before reading this thread.
     
  10. recoil80 macrumors 65816

    Joined:
    Jul 16, 2014
    #10
    I noticed the bug today and the only workaround is to turn off safari suggestions.
    I guess it is something they can fix on their servers since the problem started today and 9.2.1 has been out for a while
     
  11. oldmacs macrumors 68040

    Joined:
    Sep 14, 2010
    Location:
    Australia
  12. MartyCan macrumors 65816

    MartyCan

    Joined:
    Oct 31, 2012
    Location:
    Near Toronto, ON
    #12
    I had the very same problem this morning on my IPP. I'll turn off search suggestions and see if it helps.
     
  13. markgpearse macrumors regular

    Joined:
    Nov 11, 2010
    #13
    Just started happening on my iPad and iPhone.
     
  14. fullauto macrumors 6502a

    fullauto

    Joined:
    Oct 19, 2012
    Location:
    Brisbane
    #14
    Yup, Safari OS X - kicked in about 45 mins ago.. I thought it was the Magic Trackpad messing up.
     
  15. Michaelgtrusa macrumors 603

    Michaelgtrusa

    Joined:
    Oct 13, 2008
    Location:
    Everywhere And Nowhere
  16. stulaw11 macrumors 6502a

    Joined:
    Jan 25, 2012
    #16
    Mine still works fine. It must be a server issue which is why iOS and Mac are affected; but possibly only certain areas of the world.
     
  17. MartyCan macrumors 65816

    MartyCan

    Joined:
    Oct 31, 2012
    Location:
    Near Toronto, ON
    #17
    It has been reported as a server issue by MacLife I think. Weird though my phone was fine.
     
  18. oldmacs macrumors 68040

    Joined:
    Sep 14, 2010
    Location:
    Australia
    #18
    This is why I don't trust Apple to make a car. "Oh sorry, tapping the accelerator causes your engine to shut off, but thats ok in 48 hours our servers will be fixed".

    The emails from my family members and friends are starting to roll in.
     
  19. C DM macrumors Nehalem

    Joined:
    Oct 17, 2011
    #19
    Pretty much the case with almost all software companies out there. To some degree even applies to actual car manufacturers too in the sense that often it might take a long time for them to even recognize and admit there's some issue and then even longer to deal with it in any meaningful manner.
     
  20. oldmacs macrumors 68040

    Joined:
    Sep 14, 2010
    Location:
    Australia
    #20
    Oh I agree - its more I worry about autonomous cars from any company out there, as this sort of thing is not unusual even on iOS where Apple is fairly good at keeping bugs at bay.
     
  21. M5RahuL macrumors 68020

    M5RahuL

    Joined:
    Aug 1, 2009
    Location:
    Colorado
    #21
    Same issue on all my iOS devices running 9.3 beta 2

    No issues on Mac though.
    --- Post Merged, Jan 27, 2016 ---
    I find, browsing in Private Mode does not cause the crash.

    Does that work for you guys ?
     
  22. C DM macrumors Nehalem

    Joined:
    Oct 17, 2011
    #22
    Have you tried disabling Safari suggestions in settings for Safari? What about resetting and deleting Safari data?
     
  23. M5RahuL macrumors 68020

    M5RahuL

    Joined:
    Aug 1, 2009
    Location:
    Colorado
    #23
    Yup, tried all that but still crashes as soon as I tap the URL bar. Even did a soft reset, in vain.

    The only way it's working right now is in Private Mode.
     
  24. Max(IT) Suspended

    Max(IT)

    Joined:
    Dec 8, 2009
    Location:
    Italy
    #24
    It's happening to many people worldwide.
    Luckily enough it doesn't happen on any of my devices, iDevices or Macs
     
Thread Status:
Not open for further replies.

Share This Page