Bizarre bug in Apple TV 4k - can’t access specific programme

Discussion in 'Apple TV and Home Theater' started by The Boatman, Nov 28, 2017.

  1. The Boatman macrumors newbie

    Joined:
    Sep 28, 2007
    #1
    Hi there,

    I bought an Apple TV 4k on Saturday. On Saturday evening I purchased Halt and Catch Fire Seasons 1-4 and the Season Pass for Mr. Robot Season 3 on my iPad. I already owned Season 2, but not Season 1, of Mr Robot. (I’m in the UK and so there is no TV app here.)

    Halt and Catch Fire plays without any problems on both my iPad and Apple TV. But whenever I tried to access Season 3 Of Mr Robot, the TV would just get stuck and show ‘Mr Robot’ with the spinning wheel beneath it without any further progress. I could access it perfectly fine on the iPad.

    I contacted Apple Support by both online chat and phone and none of the steps they suggested - restarting, resetting, signing out and in, turning off Quickplay, made any difference. In the end they refunded my purchase of Mr Robot and now it no longer shows up in my purchased shows on either the iPad or the Apple TV.

    However, I still can’t even look at Mr Robot Season 3 on the Apple TV - I can look at the first two seasons, but whenever I try to look at the third on the iTunes Store on the Apple TV it still just hangs on the spinning wheel.

    Any suggestions? This is annoying me far more than it reasonably should.
     
  2. Rok73 macrumors 65816

    Rok73

    Joined:
    Apr 21, 2015
    Location:
    Planet Earth
  3. The Boatman thread starter macrumors newbie

    Joined:
    Sep 28, 2007
    #3
    As I said in the OP - the only thing Apple Support could do was refund my purchase, not fix the problem.
     
  4. The Boatman thread starter macrumors newbie

    Joined:
    Sep 28, 2007
    #4
    Update - even after I sign out of ITunes in the Settings, the Apple TV still hangs when I try to view Mr Robot Season 3 or any of its episodes.
     
  5. grinnelljd, Dec 1, 2017
    Last edited: Dec 1, 2017

    grinnelljd macrumors newbie

    Joined:
    Jun 23, 2003
    Location:
    MA
    #5
    I am experiencing the same thing with my AppleTV. I have the slightly older 4th Generation with Siri (model A1625). I own season passes for seasons 1, 2 and 3 of Mr Robot that I purchased via my AppleTV. Everything was working fine until last week when the last episode of Mr Robot would not load on my AppleTV. It would not load under the TV App or the TV Shows iTunes App. In each case when I clicked on the Mr Robot show icon I would get the splash screen and the spinning wait icon; it would never load past that screen. All my other purchased shows load and play just fine on this AppleTV. Oddly, Mr Robot will open and play fine on my iMac, MacBook Air, iPhone and on my older 3rd Generation AppleTV.

    I tried Restarting the AppleTV and tried logging out of my Apple iTunes account and then back in; still didn't work. I called Tech support twice. The first time they suggested I do a Reset and Update which I did. That didn't change anything. The second tech then told me to try a Reset and Update, but to do it with my AppleTV connected to a Mac via USB-C and using iTunes. Like setting up an iPhone or iPod back in the old days. I was also advised to do a manual setup once it was Restored. I haven't done that yet because I don't have a USB-C cable. That's my next step, but I do find it odd that this only impacts Mr Robot and it only started last week. Before that Season 3 episodes played fine on my AppleTV. I still think it is an issue with them, server side, but I won't get any traction there until I first jump though all their support hoops.

    edit: Forgot to mention that if you go to the TV Shows iTunes App and do a search for Mr Robot you'll see all three seasons individually listed. When I do this I can play episodes from season 1 and 2, but not season 3. That makes me think that season 3 is preventing the show from loading past the splash screen when you just click on the Mr Robot show icon. I wonder if I have them credit me for the season 3 season pass and then I repurchase it if my problem will go away.
     
  6. The Boatman, Dec 4, 2017
    Last edited: Dec 4, 2017

    The Boatman thread starter macrumors newbie

    Joined:
    Sep 28, 2007
    #6
    It won’t load for me even if I’m signed out of iTunes on the ATV, and someone else I know can’t load it either. It seems that this specific season is just bugged. Edit: still hangs after updating to 11.2.
     
  7. thehumanwire macrumors newbie

    thehumanwire

    Joined:
    Dec 5, 2017
    Location:
    Los Angeles, CA
    #7
    I've been having this issue for weeks. You need to put on your Elliot hoodie for a moment find a workaround. Use Siri on the Apple TV remote to go directly to any one of the Season 3 episodes and it'll get you into the Season 3 menu! For example, just say "Mr Robot Season 3 Episode 4".
     
  8. daflake macrumors 6502a

    Joined:
    Apr 8, 2008
    #8
    Same here with Season 3 of Big Bang Theory. I haven't tried siri yet to get around it, but it is annoying.
     

Share This Page