FTP Upload Problem

SAdProZ

macrumors 6502a
Original poster
Mar 19, 2005
562
277
Hi,
I have an ftp upload problem. Ive had it ever since I bought my first mac, a powerbook, a year ago. I first trying using several free ftp programs (+ Transmit), but everytime i would upload a file to a folder it would just freeze immediately. so i went and bought Cute FTP Mac cause the demo rid this problem, but not entirely. It freezes immediately, but when I close connection and connect again, everything works. So now i have gotten into the habit of 'uploading, it freezing, me closing and re-opening the connection', and then it working. This is a really long and annoying way to go about things. Anybody have a clue as to what is going on?
 

SAdProZ

macrumors 6502a
Original poster
Mar 19, 2005
562
277
belvdr said:
Try using passive mode. Issue "pasv" or "passive" in the command-line or find this option in your GUI clients.
thanks for responding. yeah i checked the connection settings in 'Preferences'. Its already in Passive mode.
 

superbovine

macrumors 68030
Nov 7, 2003
2,872
0
Are you trying to ftp to a windows box with firewall enabled, but not configure properly for ftp? That is exactly what happens.
 

Seasought

macrumors 65816
Nov 3, 2005
1,093
0
Have you tried firing up the Terminal program in OSX and using the ftp command-line interface?

Does that freeze up as well?
 

SAdProZ

macrumors 6502a
Original poster
Mar 19, 2005
562
277
superbovine said:
Are you trying to ftp to a windows box with firewall enabled, but not configure properly for ftp? That is exactly what happens.
uh, i dunno...what do you mean by windows box? i do have firewall enabled, and i am uploading to a website of mine (www.sadproz.com)
 

OutThere

macrumors 603
Dec 19, 2002
5,730
0
NYC
You might try turning off passive mode...I've had it make some problems for me when I was behind a heavy school firewall and some packet shapers...give it a shot.
 

SAdProZ

macrumors 6502a
Original poster
Mar 19, 2005
562
277
OutThere said:
You might try turning off passive mode...I've had it make some problems for me when I was behind a heavy school firewall and some packet shapers...give it a shot.
says "getting folder list..." for a very long time in 'Port Mode'.
 

SAdProZ

macrumors 6502a
Original poster
Mar 19, 2005
562
277
Heres a screen shot. As you can see, pointed at by the red arrow, that it opens connection but freezes immediately. its gotta be a simple solution, i can justfeel it. why would it take that I reconnect to my site again in order for it to accept an upload?

screen.jpg
 

SAdProZ

macrumors 6502a
Original poster
Mar 19, 2005
562
277
Seasought said:
Have you tried firing up the Terminal program in OSX and using the ftp command-line interface?

Does that freeze up as well?
no and i have no idea how to do that. terminal is a bit intimidating.


im using Verizon DSL. Im connected to a wireless router.
 

Seasought

macrumors 65816
Nov 3, 2005
1,093
0
SAdProZ said:
no and i have no idea how to do that. terminal is a bit intimidating.


im using Verizon DSL. Im connected to a wireless router.
Ok, just thought I'd ask. You can certainly experiment with it. Open Terminal and type ftp. Type the name of the server, your username and password and play around a bit. Type help once you get logged into your server and take a look at the put and mput commands (they're for uploading files). It's ugly, but it works and may be a good workaround until you resolve your GUI issues.

Just a thought, you can read up on how to use Terminal in help or online. I'll refrain of typing up some huge confusing instruction set on how to do it since it's not really your first choice here.