iCloud drive sync—DOA for a year

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by Sandy Santra, Aug 24, 2016.

  1. Sandy Santra macrumors 6502

    Joined:
    Feb 1, 2008
    Location:
    Brooklyn
    #1
    I have a 2014 iMac (fully-loaded, max memory and SSD) and an iPhone 6 Plus. I cannot get my iMac to automatically sync iCloud drive documents (Pages, Numbers, TextEdit, etc.). Every few months or so, when I really need iCloud to work, it doesn't; docs created on my iPhone in Numbers and Pages properly sync to iCloud (this can be checked by using a browser to view iCloud drive contents on the web), but they will not sync to my iMac.

    I am really tired of turning iCloud drive off and then back on (on my iMac) to fix this. It takes three hours to re-download everything. Apple has no clue as to what's wrong. I've called several times.

    Believe me, if I could switch over to Dropbox for all these, I would; but I don't think Numbers and Pages support that.

    Running Yosemite 10.10.5 on the iMac. iPhone is totally up to date.

    Any suggestions greatly appreciated!
     
  2. YatBob macrumors regular

    YatBob

    Joined:
    Apr 23, 2014
    Location:
    Louisiana
    #2
    Having the same issues, wish I knew solution other than the steps you posted
     
  3. Sandy Santra thread starter macrumors 6502

    Joined:
    Feb 1, 2008
    Location:
    Brooklyn
    #3
    Sorry you're having the same problem.

    What's doubly disturbing, is that Apple tried to "buy me off"—i.e., throw free bling at me to distract me (so I wouldn't complain further). Instead of troubleshooting the problem, they offered to gift me $100 worth of merchandise from the Apple Store. I would have to sign a waiver, and there were various contingencies—like my iMac couldn't be an engraved, personalized one—WTF? My iMac has nothing to do with this! Keep your hands off my iMac, Apple! I paid 4K for it.

    Getting free merchandise is nice, but the whole thing sounded like a scam—or worse.

    What's up with that, Apple? Just fix my iCloud sync, OK? I don't need your free keyboard.

    What is the world coming to.
     
  4. Brookzy macrumors 601

    Brookzy

    Joined:
    May 30, 2010
    Location:
    UK
    #4
    You're running a two year old operating system on your iMac, and being offered free stuff for when something goes wrong, and you're still finding a way to be negative.

    Update your Mac to El Capitan at the very least.

    And, Pages and Numbers do support Dropbox.

    (Also, even though it is totally irrelevant, you can't get iMacs engraved.)
     
  5. Sandy Santra thread starter macrumors 6502

    Joined:
    Feb 1, 2008
    Location:
    Brooklyn
    #5
    Done! Thanks for the kick in the arse.
     
  6. Sandy Santra thread starter macrumors 6502

    Joined:
    Feb 1, 2008
    Location:
    Brooklyn
    #6

    So I updated ALL my Macs to El Capitan, my iPhone 6 Plus and my brand-new iPad are all updated to the latest version of iOS, and it STILL takes 3 hours to sync my Numbers documents (a mere 2MB of data). I am ready to tear my hair out.

    I used to think this problem was because my (old) iPad was an (old) iPad 3. Now I have a brand-new iPad, and same problem.

    You said Numbers supports Dropbox. I don't understand that. To try as a workaround, I put a Numbers file in a dropbox folder, opened Dropbox on the iPad, double tapped on the file, nothing happens. You can "copy" it, I think, to Numbers, but that's not really a syncing system, is it? YOu'd then have to export it back to Dropbox every time you finished editing it.
     
  7. Phil A. Moderator

    Phil A.

    Staff Member

    Joined:
    Apr 2, 2006
    Location:
    Shropshire, UK
    #7
    If you tap the small + at the top left of the screen (not the new document button), you'll bring up the standard file selector and you can open a file directly from Dropbox (and it will be automatically saved back to there too).

    If you don't see Dropbox as an option, tap the more option in the file selector and turn Dropbox on
     
  8. Sandy Santra thread starter macrumors 6502

    Joined:
    Feb 1, 2008
    Location:
    Brooklyn
    #8
    Doesn't work: it says "Dropbox doesn't support opening files." It appears in the list, and I can turn it on, but I don't see a way to gain access to it directly from Numbers.
    --- Post Merged, Aug 28, 2016 ---
    Thoughts? It's on, but no dice. I don't see what the point is to having it turned on when it won't open files.
    --- Post Merged, Aug 28, 2016 ---
    What really gets me upset is that it's only 2MB of data. I have twice as much as that in iCloud Drive Pages, and I've never had a problem.

    2MB! iTunes will download 6GB of movies for me without breaking a sweat (about 20-25 mins).
     
  9. Phil A. Moderator

    Phil A.

    Staff Member

    Joined:
    Apr 2, 2006
    Location:
    Shropshire, UK
    #9
    I haven't used Dropbox for years and just assumed it would support the functionality (google drive and OneDrive both do, which is what I use) - apologies for any confusion and misinformation! There's a thread about it on the Dropbox forum here: https://www.dropboxforum.com/hc/en-...t-the-UIDocumentPickerModeOpen-mode-in-iOS-8-

    Back to your syncing issue - if you create a document on your Mac, does it sync quickly to iCloud or also take ages to upload?

    Have you tried turning the numbers sync off and back on in iCloud settings on the Mac?
     
  10. Sandy Santra thread starter macrumors 6502

    Joined:
    Feb 1, 2008
    Location:
    Brooklyn
    #10
    Thanks for the thread link!

    Documents created on the iMac are part of the problem, I think. I was working on four Numbers documents on my iMac yesterday morning, and those were the ones that gave me so much headache in the evening (I'm still up at 2 am!). I don't know what the hell the problem is. I thought it might be a glitch with the logins, but every time I go to check iCloud Drive on the Web, the documents always look fully synced (there); it's always the devices (iMac, MacBook Air, iPhone, iPad) that won't sync a few new documents, taking longer than 5 minutes (when 1.2MB in the aggregate is involved).

    Someone might have once told me that the numbers docs are different because they are so heavily graphic.
    --- Post Merged, Aug 28, 2016 ---
    Yes. I've done that over and over, with both the iMac and the iPad and iPhone.

    I read that link you gave me. It recommended G Drive (google's cloud). The integration was a little better, but I got an error message when I tried to send the Numbers document to Google Drive (local). Also: G Drive does the same thing as Dropbox when you upload a file to the (its) cloud: it changes the extension to .zip! I can't just tap on that to try to open it in iOS! Google and Dropbox, you crazy.
    --- Post Merged, Aug 28, 2016 ---
    Even when I did everything right by creating a Numbers document and moving it to Google Drive, it still won't open in Numbers on the iPad. Same error: "Failed to launch 'Google Drive'; The document picket 'Google Drive' failed to launch (0).

    I studied how google handled the file, and it turned it into a zip folder with a bunch of little files inside. Maybe that's why Numbers has such a hard time syncing: a meta-file structure has to be created, maintained, secured, and checked during every transfer or sync.
     
  11. Phil A. Moderator

    Phil A.

    Staff Member

    Joined:
    Apr 2, 2006
    Location:
    Shropshire, UK
    #11
    Numbers does seem to do some weird things with files and converting between desktop and iOS versions. For example, I create a numbers file on my iPad and saved it to my Synology NAS and it saved as a single file with a .numbers extension (it's actually a zip file with a .numbers extension).

    I copied it across to my iCloud drive Numbers folder and opened it on my iPad from iCloud, made a change and saved it back: It came back on my Mac as a package with separate files in the contents

    While I was doing that, I did get chance to see how well the syncing on iCloud works with Numbers and on my machine it was within a few seconds and as soon as I saved it on my iPad, the "updating" message appeared on my Mac, so there's definitely something wrong with your iCloud setup on your mac, but I can't think what it is.
    One thing that might be worth checking is that you're logging in with exactly the same user name on all devices (for example, my iCloud account started as a .mac one so I can login with myname@mac.com, myname@me.com or myname@icloud.com) - if they aren't, it can potentially cause issues
     
  12. Traverse macrumors 604

    Traverse

    Joined:
    Mar 11, 2013
    Location:
    Here
    #12
    image.png I just discovered that you can check the progress of an iCloud Drive upload from the iOS settings app.
     
  13. Sandy Santra thread starter macrumors 6502

    Joined:
    Feb 1, 2008
    Location:
    Brooklyn
    #13
    I've checked that. I'm aware of that problem. Apple still "auto-converts" my login from me.com to mac.com on certain occasions, so I have to guard against that and diligently intercept that whenever Apple tries it. I've verified that on iMac, MBA, iPhone, and iPad…they are all correctly using the me.com address.

    As you said, Apple has to do a lot of conversions between iOS and OS X for Numbers files, apparently. It's worth noting that the Numbers file I care about is only 400K. I have other iCloud folders (Keynote, Pages) with dozens and dozens of files; they never take any substantial time to sync.

    Whereas if I clone my favorite Numbers file (400K, once again) on my iPad, it will take A DAY OR TWO for it to sync to the iMac and the MacBook Pro; and I have no way of reasonably gauging how long it is taking.

    Now that I have an iPad Pro, which can handle very large spreadsheets with ease, I will probably turn off iCloud for the Numbers folder. Troubleshooting this has become too much of a pain. I'll just have some Numbers files reside on the iPad, and some on the iMac. Silo-ing goes against the whole idea of cloud data technologies, but I see no other choice.

    OK, Apple, you got me; I give up.
     

Share This Page