iPad iPad Fix: Jailbroken without Cydia icon

braddick

macrumors 68040
Original poster
Jun 28, 2009
3,861
830
Encinitas, CA
A few days ago I ran iLEX RAT on my iPad Air 7.1.2 (cellular). Afterward I noticed Cydia was not showing up and after searching the internet discovered I could load cydia by using Safari and typing, 'cydia://' in the search bar.

So far, so good. All my tweaks I need were reloaded other than I noticed iCleaner would not. It appears my iPad accepts all Cydia tweaks that can be adjusted in settings (such as Winterboard and Eclipse) but would not load tweaks that used a springboard icon.

Is there any fix for this you are aware of? I am sort of OK with my setup as is yet would like to add iCleaner back.

It's an odd problem I am hoping someone is familiar with and can help me out.
Thanks!
 

darricksailo

macrumors 601
Dec 18, 2012
4,354
113
A few days ago I ran iLEX RAT on my iPad Air 7.1.2 (cellular). Afterward I noticed Cydia was not showing up and after searching the internet discovered I could load cydia by using Safari and typing, 'cydia://' in the search bar.

So far, so good. All my tweaks I need were reloaded other than I noticed iCleaner would not. It appears my iPad accepts all Cydia tweaks that can be adjusted in settings (such as Winterboard and Eclipse) but would not load tweaks that used a springboard icon.

Is there any fix for this you are aware of? I am sort of OK with my setup as is yet would like to add iCleaner back.

It's an odd problem I am hoping someone is familiar with and can help me out.
Thanks!
do you have iFile? you could try reinstalling cydia from this deb file: http://apt.saurik.com/debs/cydia_1.1.9_iphoneos-arm.deb
 

braddick

macrumors 68040
Original poster
Jun 28, 2009
3,861
830
Encinitas, CA
^
No iFile already installed.

An added note: Upon 'refresh' nothing will load after 09/22 and when I attempt to tap manage account I am taken to the Facebook connect page and after taping that receive:


 

braddick

macrumors 68040
Original poster
Jun 28, 2009
3,861
830
Encinitas, CA
Figured out a fix:
The date was way off and once it was properly set all is now good.
(I still don't have the Cydia icon, but at least it loads under Safari.)
 

braddick

macrumors 68040
Original poster
Jun 28, 2009
3,861
830
Encinitas, CA
I had this happen and simply doing a restore from a backup in iTunes from before the icon disappeared brought it back.
I was late in doing so what with 7.1.2 no longer being signed.
This may also be helpful: For Cydia tweaks that no longer show up on my springboard I simply assigned an Activator action. (I was able to download Activator as although I don't have the icon it also shows up in settings.)
For example, iCleanerPro is loaded yet no icon. I set Activator to open iCleanerPro with a long hold of the home button.

With this final 'fix', although Cydia doesn't show up on my springboard it really doesn't matter anymore as using Safari gets it to load and using Activator gets tweaks to work.
 

JackieInCo

Suspended
Jul 18, 2013
5,178
1,598
Colorado
I was late in doing so what with 7.1.2 no longer being signed.
This may also be helpful: For Cydia tweaks that no longer show up on my springboard I simply assigned an Activator action. (I was able to download Activator as although I don't have the icon it also shows up in settings.)
For example, iCleanerPro is loaded yet no icon. I set Activator to open iCleanerPro with a long hold of the home button.

With this final 'fix', although Cydia doesn't show up on my springboard it really doesn't matter anymore as using Safari gets it to load and using Activator gets tweaks to work.
I'm not talking about a full restore. Just connect your iPad to the computer and in iTunes, right click on the iPad in the left pane and select restore backup.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.