Message failed to send - IPhone 7 Plus problem

OzCrayfish

macrumors newbie
Oct 18, 2016
10
0
To those that this is happening to. Are the messages that are failing all longer than 160 characters by any chance? All of mine are but this could just be a coincidence.
 

Gryfter

macrumors 6502
Apr 15, 2011
367
78
Brooklyn, NY
Im on an iPhone 6 Plus and I have to resend after getting the failed message and this is to non-iPhone people. My texts are usually a couple words or a sentence, so definitely less than 160 characters.
 

Thor_1

macrumors 6502a
Sep 18, 2016
950
599
Texas
4 iPhone 7 (2 each) and a 6s. Zero issues with iMessages or message. All running some version of 10.
 

tj411

macrumors newbie
Oct 26, 2016
1
0
Iphone 7 Plus
IOS 10.1 updated 2 days ago
AT&T, NY and Miami

I got the iPhone 7 Plus as soon as it came out. It started exhibiting this behavior immediately.
I don't use iMessage. So I would send a text, and it says "Failed to Send" in red and an exclamation point.
This occurs on maybe 25% of the texts I attempt to send, in other words constantly.
Gives you the option to "Try Again" at the bottom. I would try again, 90% of the time when you try again immediately it goes thru. 10% of the time it takes 2 to 3 attempts for it to go thru. Everyone and then it takes 5-10 attempts.
This occurs when the signal is full bars and the data has "LTE", so it's not in marginal coverage.

I have reset all settings.
This never occurred on my iPhone 6S even once.
So I think it's clearly some issue of IOS 10 coupled with the iPhone 7.
Really annoying, sigh.
 

OzCrayfish

macrumors newbie
Oct 18, 2016
10
0
It's especially annoying considering it's the most elementary of functions. Even more annoying is the fact that the messages are usually going through for me, even though I get the fail message. When I resend my friends ask me why I've sent the message twice.
 

Thor_1

macrumors 6502a
Sep 18, 2016
950
599
Texas
Does it happen only on LTE or wifi or both. I have been texting to a mix of imessage, regular text and a mix of both with zero issues. Only time it was messing up is when I had zero signal inside a building with no cell coverage or wifi.
 

Benz63amg

macrumors 68030
Original poster
Oct 17, 2010
2,972
458
Does it happen only on LTE or wifi or both. I have been texting to a mix of imessage, regular text and a mix of both with zero issues. Only time it was messing up is when I had zero signal inside a building with no cell coverage or wifi.
On LTE with full bar as well as 4G with full bar, and happens on wifi as well
 

OzCrayfish

macrumors newbie
Oct 18, 2016
10
0
I'm in Australia and I "think" my problem is fixed. A week ago I changed service providers. . So far I haven't had a single failed message. My wife switched three days ago. She hasn't had a problem either. If You don't hear from me again, my problem is fixed. Best of luck folks.
 

kdmsnow

macrumors newbie
Nov 22, 2016
1
0
I'm in Australia. I just signed up for a 24 month Optus contract. I have the standard size iPhone 7, 32GB. This problem happens randomly, no matter the message size. A teammate has the same issue on his iPhone 7. Not only does it say message failed to deliver, but a lot of the time it will say message failed to deliver, and the message will actually get sent. I've sent the same message 3 times to people before because each time it's said message failed to deliver.
 

OzCrayfish

macrumors newbie
Oct 18, 2016
10
0
I'm in Australia. I just signed up for a 24 month Optus contract. I have the standard size iPhone 7, 32GB. This problem happens randomly, no matter the message size. A teammate has the same issue on his iPhone 7. Not only does it say message failed to deliver, but a lot of the time it will say message failed to deliver, and the message will actually get sent. I've sent the same message 3 times to people before because each time it's said message failed to deliver.
Sorry to hear it mate. That's exactly the problem I had. I switched to Woolworths mobile which uses Telstra and the problem has never happened again. Same thing for my wife. Doesn't help you I know. I can't explain it.
 

Dave the plumber

macrumors newbie
Jan 24, 2017
1
0
Hey guys,
In Australia here too on Optus, Iphone 7plus on ios 10.1.1,
Same problem with the failing to send, 8/10 times it will fail but actually send through and same as everyone, my mates receive 2-3 of the same message. This is kinda annoying seeing I came from a IPhone 5s which I never updated off ios 8.4 and it was jail broken and I never had a problem with ios 8.4 and that's why I never wanted to update because I know apple stuffs up with all their new softwares but I like the size of the screen and the cameras too much to change back to my little toy of a 5s now, locked in with Optus on a 24month plan, so if it keeps messing up I'm going to make a case to Optus and maybe replace the phone or get a different one all together seeing as the new Sony has double the megapixels per square inch than the 7plus and a 25mp camera with 4K resoulotion, only thing keeping me with apple is all my iCloud data and photos really,
Come on apple, fix your ****. From a loving customer :)
 

saavedramark

macrumors newbie
Iphone 7 Plus
IOS 10.1 updated 2 days ago
AT&T, NY and Miami

I got the iPhone 7 Plus as soon as it came out. It started exhibiting this behavior immediately.
I don't use iMessage. So I would send a text, and it says "Failed to Send" in red and an exclamation point.
This occurs on maybe 25% of the texts I attempt to send, in other words constantly.
Gives you the option to "Try Again" at the bottom. I would try again, 90% of the time when you try again immediately it goes thru. 10% of the time it takes 2 to 3 attempts for it to go thru. Everyone and then it takes 5-10 attempts.
This occurs when the signal is full bars and the data has "LTE", so it's not in marginal coverage.

I have reset all settings.
This never occurred on my iPhone 6S even once.
So I think it's clearly some issue of IOS 10 coupled with the iPhone 7.
Really annoying, sigh.

Doe
Hey guys,
In Australia here too on Optus, Iphone 7plus on ios 10.1.1,
Same problem with the failing to send, 8/10 times it will fail but actually send through and same as everyone, my mates receive 2-3 of the same message. This is kinda annoying seeing I came from a IPhone 5s which I never updated off ios 8.4 and it was jail broken and I never had a problem with ios 8.4 and that's why I never wanted to update because I know apple stuffs up with all their new softwares but I like the size of the screen and the cameras too much to change back to my little toy of a 5s now, locked in with Optus on a 24month plan, so if it keeps messing up I'm going to make a case to Optus and maybe replace the phone or get a different one all together seeing as the new Sony has double the megapixels per square inch than the 7plus and a 25mp camera with 4K resoulotion, only thing keeping me with apple is all my iCloud data and photos really,
Come on apple, fix your ****. From a loving customer :)
Do you still experience this up until now? Or if not, how did you solve this problem? Please help im on iOS 10.3.3, iPhone 7.
 

bei_bryle

macrumors newbie
Jan 21, 2019
1
0
ever since I got my iPhone 7 plus, when I try to send a text message or an iMessage, it says message failed to send and usually I retry and it goes through , is this some kind of a bug in IOS 10? Hopefully it gets resolved soon as this is very annoying, every other text I send almost every day says failed to send and I need to click retry,

I tried disabling iMessage and waiting for a few minutes and then re enabling iMessage but still the same,

I never had this problem on my iPhone 6S, and this happens when I send out texts to numerous people , it's not a problem with just one recipient
[doublepost=1548122814][/doublepost]i have the same issue with my Iphone 7 IOS 10