No sleep after Catalina.


SoYoung

macrumors 6502a
Jul 3, 2015
892
360
Do you have something plugged that recharge a battery ? Like a controller for exemple? I though I have the same problem until I found out that my DualShock 4 prevent my iMac to enter sleep mode when connected to USB
 

Richard8655

macrumors 65816
Mar 11, 2009
1,126
454
Chicago
Could it be that Time Machine needs to run doing a lengthy backup with a new OS installed?

EDIT: I have my sleep setting to start after 3 minutes. After upgrading to Catalina, I let my Mac do its thing overnight. This morning my Mac was in sleep mode. So I think after a huge upgrade like this, the system needs to do cleanup and well as a more intense backup.
 
Last edited:

coder21

macrumors newbie
Aug 14, 2018
2
0
ATX
FWIW: I'm having the same issue (on an older Late 2014 mini w Catalina 10.15, that won't stay in sleep mode at all). I disconnected USB devices (as per above advice), rebooted, set settings to sleep after 3 minutes. Tried hot corners again and still won't sleep.

I have always used Hot Corners in Mission Control to manually put it to sleep. Previously it worked flawlessly with Mojave.

Hopefully they will launch a patch soon to fix this. Otherwise, I have to manually shut down every night and turn power on every morning. Not a big deal, but it's nice to have it go to sleep on command, and not have to restart daily...I'm not running Time Machine on this particular dinosaur either.
 
Last edited:

dylanw

macrumors newbie
Jul 18, 2002
2
2
In the Terminal, pmset -g assertions will tell you what processes are keeping your Mac awake. In my case, MDS (Spotlight) wanted to do a full refresh that took a couple of days.
 

Furby2005

macrumors newbie
May 9, 2019
10
4
Surrey, UK
This is definitely a Catalina bug which has persisted throughout the Beta stage and into the final release. My 2012 mini hasn't slept since Public Beta 1. This has included clean installs with no third party software or devices and everything turned off. All the settings for sleep show as they should in Terminal and assertions shows nothing, it simply will not sleep. I've sent feedback many, many times to no avail. I hope they fix this by the .1 update. I'm holding off installing Catalina on any other Macs until I'm confident this has been sorted.
 

CC88

macrumors regular
Sep 29, 2010
202
23
In the Terminal, pmset -g assertions will tell you what processes are keeping your Mac awake. In my case, MDS (Spotlight) wanted to do a full refresh that took a couple of days.
Also my macpro won't sleep after Catalina... The command say it's Time Machine that prevent it from sleep. But Time Machine has finished the backup and is not running.
 

Richard8655

macrumors 65816
Mar 11, 2009
1,126
454
Chicago
My 2012 Mac Mini does sleep. But only after quitting Music and TV. Before Catalina, iTunes could be running with sleep mode also working. So could be a bug in how sleep interacts with those apps.
 

coder21

macrumors newbie
Aug 14, 2018
2
0
ATX
RESOLVED Issue setting Mac Mini to Sleep (and staying asleep) after updating to Catalina 10.15

FWIW: I have an older Late 2014 Mac Mini connected to a 27" Cinema Display, and I finally figured out how I can set it to sleep (from my previously configured Hot Corners in Mission Control-see 2nd screenshot) without immediately waking back up.

In System Preferences I went to Energy Saver (3rd screenshot) & disabled "Wake for network access" and "Prevent computer from sleeping automatically when the display is off."

Voila! Boom, now it finally works (stays asleep)! Hope this helps someone else...👍

Screen Shot 2019-10-18 at 10.12.30 AM.png



Screen Shot 2019-10-18 at 10.09.15 AM.png



Screen Shot 2019-10-18 at 10.07.09 AM.png
 

Richard8655

macrumors 65816
Mar 11, 2009
1,126
454
Chicago
Sounds good if it works. But how to wake your Mac remotely if "wake for network access" is turned off? Strangely, I also don't have the first option "prevent computer from sleeping...". Might have to do with your Cinema Display.
 
Last edited:

SoYoung

macrumors 6502a
Jul 3, 2015
892
360
Sounds good if it works. But how to wake your Mac remotely if "wake for network access" is turned off? Strangely, I also don't have the first option "prevent computer from sleeping...". Might have to do with your Cinema Display.
I also have this option and I have an iMac.
 

Richard8655

macrumors 65816
Mar 11, 2009
1,126
454
Chicago
I also have this option and I have an iMac.
Per Apple Support website for sleep options, Mac Mini does not have the first option, which explains why I don't see it with my 2012 Mac Mini, while you see it on your iMac. I see the second screen below. But I don't know how the earlier poster is getting it with his 2014 Mac Mini as he states.

https://support.apple.com/en-us/HT202824

These options are available on iMac and Mac Pro:


Mac mini has these options:
 
Last edited:

Amorun

macrumors member
Dec 3, 2016
52
43
Hey guys! Nothing helps with this issue -non turning Sleep Mode on automatically (iMac). Any fresh ideas?
 

Paulinfo

macrumors newbie
Sep 16, 2015
5
1
I'm having trouble with sleep Imac 2017 I can put into sleep mode but when I wake the iMac up after 1 hr or two it does a hard reboot so for past couple weeks when Catalina came out it not been to sleep
 
Last edited:

Richard8655

macrumors 65816
Mar 11, 2009
1,126
454
Chicago
Auto sleep seems unpredictable since Catalina. I've been putting my Mac Mini to sleep manually lately, but not so sure it's a huge deal if it doesn't automatically.
 
Last edited:

jhkuo

macrumors newbie
Aug 25, 2009
5
0
I found that if I (sudo) kill the two UserEventAgent processes twice (once doesn't work), although those processes would be respawned, they will no longer prevent sleep. After which Mac can sleep automatically (until the machine is rebooted).

e.g. run this twice
ps -ef | grep UserEventAgent | grep -v grep | awk '{print $2}'| sudo xargs kill -9

Also, I found that enabling handoff sometimes would prevent sleep, so I had to switch it off as well.

Very strange, but having done both of these seems to have fixed the Catalina sleep issue on my 2017 5k iMac.
 
Last edited:

Phazer

macrumors regular
May 19, 2010
100
11
London, UK
I had the same problem with my 2019 MBP, even if I put the laptop to sleep manually, or closed the lid, the battery would keep draining at a rate of about 10% an hour, and the laptop was warm.
I solved the problem by turning off “find my Mac”. Now it behaves normally and doesn’t drain battery when in standby.
 

hardtofin

macrumors member
Mar 4, 2009
76
12
I have had this problem for some time and now have it solved. The first thing to do is find out what it is that is actually stopping your mac from sleeping.

Type: pmset -g assertions in terminal and that will give you some idea.

The next thing to do is open activity monitor and enable the column called "prevent sleep". Here you can see everything that is currently keeping your mac awake. After that is is just trial and error with different process to see which one was ACTUALLY keeping your mac awake, as most of them will cease when the screen goes off, so just test them one by one.

After than, i use an app called "eventscripts" here - https://apps.apple.com/us/app/eventscripts/id525319418?mt=12

I run scripts to exit the guilty apps as soon as my screen goes off. This was the second my screen goes black, the apps are quit enabling the machine to go to sleep. For me it is Spotify and Boom2 audio engine.

Hope this helps 👍
 

hardtofin

macrumors member
Mar 4, 2009
76
12
pmset -g says: (sleep prevented by UserEventAgent)
pmset -g assertions says: IODisplayWrangler

Will be waiting for next update.
Yeh but what agents? What did activity monitor say in the prevent sleep column? Maybe you should put some effort into solving the problem yourself rather than just posting abrupt comments. You clearly didn't do anything i mentioned above, so good luck with your problem.
 
Last edited:

jhkuo

macrumors newbie
Aug 25, 2009
5
0
I have had this problem for some time and now have it solved. The first thing to do is find out what it is that is actually stopping your mac from sleeping.

Type: pmset -g assertions in terminal and that will give you some idea.

The next thing to do is open activity monitor and enable the column called "prevent sleep". Here you can see everything that is currently keeping your mac awake. After that is is just trial and error with different process to see which one was ACTUALLY keeping your mac awake, as most of them will cease when the screen goes off, so just test them one by one.
i
After than, i use an app called "eventscripts" here - https://apps.apple.com/us/app/eventscripts/id525319418?mt=12

I run scripts to exit the guilty apps as soon as my screen goes off. This was the second my screen goes black, the apps are quit enabling the machine to go to sleep. For me it is Spotify and Boom2 audio engine.

Hope this helps 👍
UserEventAgent was the process preventing sleep in my case. It prevents the system from sleeping on a freshly installed Catalina (no 3rd party apps), and only a keyboard and mouse plugged in. UserEventAgent was misbehaving and only goes back to normal (i.e. disappears when no user inputs are active) until it was killed twice.

I did use pmset -g to discover that UserEventAgent was causing me issue

This problem only occurs on my 2017 iMac, it does not occur on my 2014 MacBook Pro, 2012 MacBook Air and 2019 MacBook Pro