THE Playing STWOR Thread

turbobass

macrumors 6502
Original poster
May 25, 2010
294
3
Los Angeles
Given that the last SWTOR thread was started for me to gripe about something that turned out to just be me being a n00b, I wanted to start a new thread that didn't dissuade others from playing SWTOR as I think it's pretty damn good.

Also, I was inspired by the Skyrim thread doing the same thing.

****

I'll start by adding that if you accidentally max out your graphical settings on your laptop you may accidentally black screen crash the game when you try to start up again, freezing you out of playing. To recover, you need to change the .ini file in your user folder at \AppData\Local\SWTOR\swtor\settings\client_settings

This article tells more about how to lower the settings back down to manageable size.

http://segmentnext.com/2012/01/13/swtor-ini-tweaks-guide-graphics-and-performance/3/
 

doh123

macrumors 65816
Dec 28, 2009
1,304
1
Still looking for a fix for the launcher crashing so I can actually install it. >.<
Sounds like a problem with just your machine... could be a driver, or some other program running thats interfering...
 

Jazwire

macrumors 6502a
Jun 20, 2009
896
117
127.0.0.1
Still looking for a fix for the launcher crashing so I can actually install it. >.<
Using ATI Tray Tools by chance?

SwTor don't work with it for some reason, few other DirectX / Video tweak programs I've noticed it doesnt play with well.

Try disabling those and test it.
 

turbobass

macrumors 6502
Original poster
May 25, 2010
294
3
Los Angeles
Still looking for a fix for the launcher crashing so I can actually install it. >.<
Can you not even install it? If you have the folders unpacked you might be able to try C:\Program Files (x86)\Electronic Arts\BioWare\Star Wars - The Old Republic\FixLauncher ?
 

Alaerian

Guest
Jan 6, 2005
1,928
0
A barstool, Innis & Gunn in hand
Using ATI Tray Tools by chance?

SwTor don't work with it for some reason, few other DirectX / Video tweak programs I've noticed it doesnt play with well.

Try disabling those and test it.
I am! Now this is something I haven't seen yet. Off to try!

Jazwire.
My good man.
I owe you some cookies.

I searched and searched and searched for a fix to this. Nothing pointed me to ATT. =D
 
Last edited:

shelhed217

macrumors member
Mar 4, 2010
85
0
VA
So i play during the week when I am traveling on my stock 13 in MBA. I think the fixes BW put in this past week for ability delay helped me a lot more on the MBA than on the other computer i play on, I am PVPing and it actually feels pretty responsive. The fans really get going but its otherwise quite serviceable. My commando trooper is 50, healing normal mode ops, and i'm leveling a sage.
What's everyone else playing?
 

Jazwire

macrumors 6502a
Jun 20, 2009
896
117
127.0.0.1
I am! Now this is something I haven't seen yet. Off to try!

Jazwire.
My good man.
I owe you some cookies.

I searched and searched and searched for a fix to this. Nothing pointed me to ATT. =D
Glad it helped , I wish it didn't conflict because its the only tool that actually lets us change voltage. For oc purposes sapphire trixx works but voltage portion does not.

Really hope ati tray tools works in the future with swtor but for now it doesn't seem too.
 

Shivetya

macrumors 68000
Jan 16, 2008
1,589
243
Anyone set up a profile for ATI cards specific to this game?

There are claims on the Bioware boards that they detect mobility cards incorrectly.

Also, if your running on Windows 7 with DX 11 you may want to install DX 9 as well http://www.microsoft.com/download/en/details.aspx?id=8109 - put that in a separate folder (don't extract to desktop) then run the dxsetup

Apparently 11 emulates libraries in 9 and that causes some performance hit
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.