FreAk6767

macrumors member
Feb 27, 2008
44
6
I've finally fixed it! I found a bunch of errors related to "AutoUnlock" in the Console that was hinting to me that there was some invalid state on my Mac with keys and plists not being reset properly. After clearing/resetting them, I can now successfully pair my watchOS 7 Series 3 to macOS 10.15.6.

Steps (follow at your own discretion)
  1. Open "Keychain Access"
  2. In "View", enable "Show Invisible Items"
    View attachment 954412
  3. Search for "Auto Unlock"
  4. You should see a whole bunch of application passwords for "Auto Unlock: XXXX's ..."
    View attachment 954403
  5. Select all records and delete (this will reset/disable auto unlock on other Macs if you use multiple Macs)
  6. Whilst still in "Keychain Access", search for "AutoUnlock" (no space)
  7. There should be 4 entries for "tlk" "tlk-nonsync" "classA" "classC"
    View attachment 954382
  8. Select 4 records and delete (don't worry if they re-appear, the system repairs this automatically)
  9. Open "Finder" and navigate to "~/Library/Sharing/AutoUnlock"
  10. There should be two files "ltk.plist" and "pairing-records.plist"
    View attachment 954386
  11. Delete both files
  12. Open "System Preferences" and try enabling auto unlock. You may need to enable it twice, the first attempt will fail.

Solution worked perfectly for me, thanks a lot!!
 

ulinerg

macrumors regular
Oct 21, 2014
120
31
Ottawa, Canada
I've finally fixed it! I found a bunch of errors related to "AutoUnlock" in the Console that was hinting to me that there was some invalid state on my Mac with keys and plists not being reset properly. After clearing/resetting them, I can now successfully pair my watchOS 7 Series 3 to macOS 10.15.6.

Steps (follow at your own discretion)
  1. Open "Keychain Access"
  2. In "View", enable "Show Invisible Items"
    View attachment 954412
  3. Search for "Auto Unlock"
  4. You should see a whole bunch of application passwords for "Auto Unlock: XXXX's ..."
    View attachment 954403
  5. Select all records and delete (this will reset/disable auto unlock on other Macs if you use multiple Macs)
  6. Whilst still in "Keychain Access", search for "AutoUnlock" (no space)
  7. There should be 4 entries for "tlk" "tlk-nonsync" "classA" "classC"
    View attachment 954382
  8. Select 4 records and delete (don't worry if they re-appear, the system repairs this automatically)
  9. Open "Finder" and navigate to "~/Library/Sharing/AutoUnlock"
  10. There should be two files "ltk.plist" and "pairing-records.plist"
    View attachment 954386
  11. Delete both files
  12. Open "System Preferences" and try enabling auto unlock. You may need to enable it twice, the first attempt will fail.
Thanks LongZheng
I couldn't find the plist files but did the rest and it seems to have worked for me.
 

drlalitv

macrumors newbie
Sep 18, 2020
1
0
Eldoret
I've finally fixed it! I found a bunch of errors related to "AutoUnlock" in the Console that was hinting to me that there was some invalid state on my Mac with keys and plists not being reset properly. After clearing/resetting them, I can now successfully pair my watchOS 7 Series 3 to macOS 10.15.6.

Steps (follow at your own discretion)
  1. Open "Keychain Access"
  2. In "View", enable "Show Invisible Items"
    View attachment 954412
  3. Search for "Auto Unlock"
  4. You should see a whole bunch of application passwords for "Auto Unlock: XXXX's ..."
    View attachment 954403
  5. Select all records and delete (this will reset/disable auto unlock on other Macs if you use multiple Macs)
  6. Whilst still in "Keychain Access", search for "AutoUnlock" (no space)
  7. There should be 4 entries for "tlk" "tlk-nonsync" "classA" "classC"
    View attachment 954382
  8. Select 4 records and delete (don't worry if they re-appear, the system repairs this automatically)
  9. Open "Finder" and navigate to "~/Library/Sharing/AutoUnlock"
  10. There should be two files "ltk.plist" and "pairing-records.plist"
    View attachment 954386
  11. Delete both files
  12. Open "System Preferences" and try enabling auto unlock. You may need to enable it twice, the first attempt will fail.
Thank you very much!Yours was the only solution that worked!
 

bit_bucket

macrumors regular
Jul 18, 2002
242
44
Summerville, SC
I've finally fixed it! I found a bunch of errors related to "AutoUnlock" in the Console that was hinting to me that there was some invalid state on my Mac with keys and plists not being reset properly. After clearing/resetting them, I can now successfully pair my watchOS 7 Series 3 to macOS 10.15.6.

I can’t express my grattitude enough. I have literally tried every single solution on the net and lots of debugging, but it was following your post instructions to the letter that fixed my issue. In my case I had started new with iOS14 GM on my Apple Watch and iPhone but kept my Mac at: 10.15.6. Followed your instructions to the letter and boom, it is working again. Huge thank you!
 

Qwaf

macrumors regular
Sep 11, 2010
107
33
+1 on LongZheng's solution working for me, only I had to reboot after deleting the plist files to get mine to work. A small extra step, but one worth trying if it doesn't work for you.
 

Brad Balkan

macrumors newbie
Sep 23, 2020
1
1
Edmonton, Alberta
I've finally fixed it! I found a bunch of errors related to "AutoUnlock" in the Console that was hinting to me that there was some invalid state on my Mac with keys and plists not being reset properly. After clearing/resetting them, I can now successfully pair my watchOS 7 Series 3 to macOS 10.15.6.

Steps (follow at your own discretion)
  1. Open "Keychain Access"
  2. In "View", enable "Show Invisible Items"
    View attachment 954412
  3. Search for "Auto Unlock"
  4. You should see a whole bunch of application passwords for "Auto Unlock: XXXX's ..."
    View attachment 954403
  5. Select all records and delete (this will reset/disable auto unlock on other Macs if you use multiple Macs)
  6. Whilst still in "Keychain Access", search for "AutoUnlock" (no space)
  7. There should be 4 entries for "tlk" "tlk-nonsync" "classA" "classC"
    View attachment 954382
  8. Select 4 records and delete (don't worry if they re-appear, the system repairs this automatically)
  9. Open "Finder" and navigate to "~/Library/Sharing/AutoUnlock"
  10. There should be two files "ltk.plist" and "pairing-records.plist"
    View attachment 954386
  11. Delete both files
    (Some users have reported better success restarting macOS at this stage)
  12. Open "System Preferences" and try enabling auto unlock. You may need to enable it twice, the first attempt will fail.

@LongZheng this did work for me, however it reverted to not working after the next reboot.

digging further (and I'm not a technical guy) I found a post from 2016 on the apple forum talking about resetting the keychain- which started by turning off the keychain on your phone. Although the context was different than what we're discussing here, I started to think that maybe there was some sort of mismatch of the keychain on my phone vs MacBook, and that the sync process between the devices and iCloud was somehow borked.

So I figured I would turn off keychain on all three devices (mbp, Xs and w4) and get a fresh copy out of what was saved in iCloud onto each device. Ended up I had to sign out of iCloud on all devices, and then reload my iCloud account to all. Took a bit, but its steady now and hasn't reverted like it had with your solution.

having said that, without you posting I was as lost as anyone else so I do appreciate you pointing in the right direction!
 
Last edited:
  • Like
Reactions: Wando64

Yuri Stepanov

macrumors newbie
Sep 24, 2020
2
0
I've finally fixed it! I found a bunch of errors related to "AutoUnlock" in the Console that was hinting to me that there was some invalid state on my Mac with keys and plists not being reset properly. After clearing/resetting them, I can now successfully pair my watchOS 7 Series 3 to macOS 10.15.6.

Steps (follow at your own discretion)
  1. Open "Keychain Access"
  2. In "View", enable "Show Invisible Items"
    View attachment 954412
  3. Search for "Auto Unlock"
  4. You should see a whole bunch of application passwords for "Auto Unlock: XXXX's ..."
    View attachment 954403
  5. Select all records and delete (this will reset/disable auto unlock on other Macs if you use multiple Macs)
  6. Whilst still in "Keychain Access", search for "AutoUnlock" (no space)
  7. There should be 4 entries for "tlk" "tlk-nonsync" "classA" "classC"
    View attachment 954382
  8. Select 4 records and delete (don't worry if they re-appear, the system repairs this automatically)
  9. Open "Finder" and navigate to "~/Library/Sharing/AutoUnlock"
  10. There should be two files "ltk.plist" and "pairing-records.plist"
    View attachment 954386
  11. Delete both files
    (Some users have reported better success restarting macOS at this stage)
  12. Open "System Preferences" and try enabling auto unlock. You may need to enable it twice, the first attempt will fail.
Thank you very much! Your solution works!
My 5 cents about item 11 - for me reboot did not work, it was solved without reboot.
Thank you again!
 

MichaelNRW

macrumors newbie
Sep 25, 2020
5
0
I can´t get it working again with watchOS 7.0.1
I already had it working with watchOS 7 but had to update because i had the GPS tracks bug.
Already tried everything around ContinuitySupport without a result.
And even this workaround doesn´t work.
I deleted everything as mentioned, rebootet all devices and tried to activate "Unlock with Watch" multiple times.
 

NoBoMac

Moderator
Staff member
Jul 1, 2014
3,181
1,430
Re: 7.0.1: took me a couple of reboots of my Mac, a reboot of Watch, and a couple of attempts to toggle on unlock before it took with this workaround. But got it to work.

Can't recall the sequence, but might have been reboot Mac, shutdown Watch while Mac reboots, restart Watch, try to toggle on the Security setting.
 

Max T

macrumors newbie
Feb 10, 2020
2
6
After resetting the keychain according to the instructions, logging in and out of iCloud several times and repairing my Watch, I still couldn't connect to the auto unlock. But I have now managed to fix it with the following approach: Turn off the iPhone, activate Wifi and Bluetooth on the Watch, then activate Watch Unlock in System Preferences on your Mac and after that turn on the iPhone again.
 
  • Like
Reactions: MacRoyal

Apple_Robert

Contributor
Sep 21, 2012
27,892
34,537
In the middle of several books.
Running the latest Catalina on Mac mini and WatchOS 7.01. I just tried setting up my series 6 as you normally would, and it worked the first time. I didn’t have to try any of the hints in the thread. Prior to the series 6 and WatchOS 7.01, I couldn’t log in with my series 5.
 

likegadgets

macrumors 6502a
Jul 22, 2008
515
117
US
Thanks LongZheng. Before seeing your solution I called Apple. They were not able to help - they wanted to unpair and repair the watch yet again (which I had tried). Your solution worked on my two MBP machines. I did reboot - and it took on the 2nd try
 

ISprainedMyUvula

macrumors member
May 7, 2017
41
59
I messed around with this for HOURS, even going thru the debug menu in Bluetooth. What finally worked for me was to do all of the steps above with the Keychain Access, THEN running the following Terminal script to clear the Bluetooth settings, as the clear/reset menu options in the Bluetooth menu don't ACTUALLY clear or reset anything <massive eyeroll>:

sudo rm /Library/Preferences/com.apple.Bluetooth.plist && sudo shutdown -r now
 

wilberforce

macrumors 6502a
Aug 15, 2020
681
522
I messed around with this for HOURS, even going thru the debug menu in Bluetooth. What finally worked for me was to do all of the steps above with the Keychain Access, THEN running the following Terminal script to clear the Bluetooth settings, as the clear/reset menu options in the Bluetooth menu don't ACTUALLY clear or reset anything <massive eyeroll>:

sudo rm /Library/Preferences/com.apple.Bluetooth.plist && sudo shutdown -r now
Let us know if it sticks.
I have successfully used the various fixes suggested (keychain and bluetooth resets), but then the next day or so it is no longer working and I have to repeat. Which completely defeats the purpose of the unlocking convenience.
 

kaostheory777

macrumors newbie
Feb 13, 2008
29
32
Rockhampton, Australia
I've finally fixed it! I found a bunch of errors related to "AutoUnlock" in the Console that was hinting to me that there was some invalid state on my Mac with keys and plists not being reset properly. After clearing/resetting them, I can now successfully pair my watchOS 7 Series 3 to macOS 10.15.6.

Steps (follow at your own discretion)
  1. Open "Keychain Access"
  2. In "View", enable "Show Invisible Items"
  3. Search for "Auto Unlock"
  4. You should see a whole bunch of application passwords for "Auto Unlock: XXXX's ..."
  5. Select all records and delete (this will reset/disable auto unlock on other Macs if you use multiple Macs)
  6. Whilst still in "Keychain Access", search for "AutoUnlock" (no space)
  7. There should be 4 entries for "tlk" "tlk-nonsync" "classA" "classC"
  8. Select 4 records and delete (don't worry if they re-appear, the system repairs this automatically)
  9. Open "Finder" and navigate to "~/Library/Sharing/AutoUnlock"
  10. There should be two files "ltk.plist" and "pairing-records.plist"
  11. Delete both files
    (Some users have reported better success restarting macOS at this stage)
  12. Open "System Preferences" and try enabling auto unlock. You may need to enable it twice, the first attempt will fail.

THANK YOU :) This was bugging the hell out of me! Followed these steps and one restart and three clicks of the enable button later it worked. I also managed to repeat this process on my two other Macs both running the current Big Sur beta. Really great post and thank you again for your hard work! :)
 

zygiboos

macrumors newbie
Sep 27, 2020
1
0
Well, it works for me, but i tried 5 times. Looks like You have to try check Apple Watch unlock several times before restart MacOS and then restart and try again 2 times.

First when I restarted computer without try to check unlok option - was not working.

Funny thing - after those steps on iPhone cameras and Face ID stops working (black screen) but two reboots of phone and all ok again :)
 

MichaelNRW

macrumors newbie
Sep 25, 2020
5
0
Looks like You have to try check Apple Watch unlock several times before restart MacOS and then restart and try again 2 times.

Thanks for that hint!
I finally managed to get it working.

1. Delete keychain entries and files in the AutoUnlock folder
2. Try to activate unlock with watch -> directly shows an error without any delay
3. Shutting down my iPhone
4. Try to activate unlock with watch -> directly activated without any delay

kind regards
Michael
 

MacRoyal

macrumors newbie
Sep 27, 2020
1
0
The steps on LongZheng's post work for me, but I have to do the whole process every time I reboot. It's only happening on a MacBook Pro and Watch S5. The same watch pairs right away and unlocks an iMac without issue.
 

orson39

macrumors newbie
Mar 25, 2008
2
0
I've finally fixed it! I found a bunch of errors related to "AutoUnlock" in the Console that was hinting to me that there was some invalid state on my Mac with keys and plists not being reset properly. After clearing/resetting them, I can now successfully pair my watchOS 7 Series 3 to macOS 10.15.6.

Steps (follow at your own discretion)
  1. Open "Keychain Access"
  2. In "View", enable "Show Invisible Items"
    View attachment 954412
  3. Search for "Auto Unlock"
  4. You should see a whole bunch of application passwords for "Auto Unlock: XXXX's ..."
    View attachment 954403
  5. Select all records and delete (this will reset/disable auto unlock on other Macs if you use multiple Macs)
  6. Whilst still in "Keychain Access", search for "AutoUnlock" (no space)
  7. There should be 4 entries for "tlk" "tlk-nonsync" "classA" "classC"
    View attachment 954382
  8. Select 4 records and delete (don't worry if they re-appear, the system repairs this automatically)
  9. Open "Finder" and navigate to "~/Library/Sharing/AutoUnlock"
  10. There should be two files "ltk.plist" and "pairing-records.plist"
    View attachment 954386
  11. Delete both files
    (Some users have reported better success restarting macOS at this stage)
  12. Open "System Preferences" and try enabling auto unlock. You may need to enable it twice, the first attempt will fail.
After 2 days of agony your post fixed it for me! Thank you very much
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.