02 online bill issues, iphone.

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Ashapalan, Mar 8, 2008.

  1. Ashapalan macrumors 6502a

    Joined:
    Apr 17, 2005
    Location:
    England
    #1
    Since thursday i have not been able to access my 02 iphone online bill with safari or firefox. When i click the 'view my bill' tab a certificate warning pops up (this happens with both browsers) warning me about continuing, if i continue anyway, i get to a page that says 'successfully signed in, click link to return to home page' and so i keep getting looped around and around.

    Am i alone? I've phoned 02 customer services and they are baffled, but they've set up a case.

    The woman on the other end could get to my online bill using internet explorer, just not with firefox or safari.

    So it would seem that a recent update has knocked compatibility out of any browser other than internet explorer. But then anyone using a mac couldn't get onto their bill but i've heard no mention of anyone else having problems.

    Is anybody experiencing the same problem?
    Or are the 02 IT department targeting me?
     
  2. PatrickF macrumors 6502

    Joined:
    Feb 16, 2006
    Location:
    Blighty
    #2
  3. arkitect macrumors 601

    arkitect

    Joined:
    Sep 5, 2005
    Location:
    Bath, United Kingdom
    #3
    When I try to access my online bill i get the message

    That is with Firefox…

    With Safari I get a "unable to verify certificate" message and then a spinning wheel…

    Hummmm. :(
     
  4. Ashapalan thread starter macrumors 6502a

    Joined:
    Apr 17, 2005
    Location:
    England
    #4
    That link causes my certificate issues.

    Anyone with safari try clicking it, do you have issues as well?

    Seems so strange that it's selective.
     
  5. Ashapalan thread starter macrumors 6502a

    Joined:
    Apr 17, 2005
    Location:
    England
    #5
    I'm not alone then! 02 say they will get back to me next week after an investigation, guess i have to sit tight till then:)
     
  6. arkitect macrumors 601

    arkitect

    Joined:
    Sep 5, 2005
    Location:
    Bath, United Kingdom
    #6
    Well I am on the phone right now with them having the password reset…

    No, that didn't work.

    Everyone at O2 seems clueless though.
     
  7. Ashapalan thread starter macrumors 6502a

    Joined:
    Apr 17, 2005
    Location:
    England
    #7
    The woman i spoke to said 'we're all baffled'... doesn't bode well for a fix.

    I think they need to put us onto the IT guys who maintain web browser support. Surely it's a case of a recent update breaking support.
     
  8. CD3660 macrumors 68040

    CD3660

    Joined:
    Jun 6, 2007
    Location:
    Cheshire, United Kingdom.
    #8
    It works with Firefox and Safari.

    What's more the new look website is superb compared to the old one.
     
  9. page3 macrumors 6502

    Joined:
    Feb 10, 2003
    Location:
    Vicar of Dibley-land, UK
    #9
    Definitely not working for me - Safari 3.0.4. I just get a blank page :(

    Hmm, blank page with Firefox too!
     
  10. Ashapalan thread starter macrumors 6502a

    Joined:
    Apr 17, 2005
    Location:
    England
    #10
    Just got a call back from 02 customer services and have been told a number of people are phoning in today with this same issue. And so 02 have moved it up to high priority :)

    Should be a fix by monday.
     
  11. arkitect macrumors 601

    arkitect

    Joined:
    Sep 5, 2005
    Location:
    Bath, United Kingdom
    #11
    What is truly stupid is that I cannot even access it with my iPhone… what use is that? :rolleyes:

    Oh… and I can access it with IE on Parallels… so what does that tell us? ;):mad:
     
  12. domness macrumors 6502a

    domness

    Joined:
    Jan 14, 2008
    Location:
    Sheffield, UK
    #12
    Hmm.. well I'm using Firefox and it works fine for me!

    The new 02 Dashboard is so much better! Finally you can see how much extra you have spent on the homepage bit!

    What the iPhone needs is a counter like the call time one, so you can track the amount of texts sent..
     
  13. sparkyms macrumors 65816

    Joined:
    Feb 22, 2007
    Location:
    Southampton UK
    #13
    cant access it, must be issues with this new "dashboard".

    I'll give camino a go, but I don't hold out much hope + report back.

    ok literally nothing is working. :S not even IE6.
     
  14. sparkyms macrumors 65816

    Joined:
    Feb 22, 2007
    Location:
    Southampton UK
    #14
    I can't even log in now.

    Fantastic!

    EDIT: just got this from o2
    so, hold tight i guess.
     
  15. thworple macrumors 6502

    thworple

    Joined:
    Oct 20, 2005
    Location:
    Sussex, England
    #15
    I sen an email to o2 yesterday regarding this and got the following reply:-

    Thanks for emailing us and I'm sorry you're having problems viewing your online bill.

    This is a known fault and our engineer's are looking at it to resolve at the highest priority. Once this issue is resolved, you'll be able to view and print your online bills. I'm sorry for any inconvenience that may have been caused.
     
  16. scootermac macrumors newbie

    Joined:
    Feb 23, 2007
    #16
    Yip, I've been having problems viewing my bill:( I did a quick search, and low and behold I find this thread:mad:

    Can someone tell me how to view minutes I have used? Also, do the unused minutes carry over?

    Here's the message I got when I clicked the above link

    "There was a problem processing your login

    If you are not automatically redirected please click here and try again. If the problem persists please contact the helpdesk and quote - Login Error 2"
     
  17. sparkyms macrumors 65816

    Joined:
    Feb 22, 2007
    Location:
    Southampton UK
    #17
    I have come accross something really weird also. You know how I said I couldn't even log in this afternoon? Someone had changed my password!

    This is getting really strange, I guess they could have reset the password perhaps because of the amount of "failed" logins on my account with the dashboard messing up. But, I'm rather concerned now, especially seeing as I can't view my bill!!

    Has this happened to anyone else?
     
  18. arkitect macrumors 601

    arkitect

    Joined:
    Sep 5, 2005
    Location:
    Bath, United Kingdom
    #18
    The changes must have been made through the night as it seems to be working in Firefox right now.

    They changed my password when I spoke to customer services… that didn't help me though. Until this morning I was unable to access my information.

    Now it seems OK. :)
     
  19. scootermac macrumors newbie

    Joined:
    Feb 23, 2007
  20. arkitect macrumors 601

    arkitect

    Joined:
    Sep 5, 2005
    Location:
    Bath, United Kingdom
    #20
    That is what was the case for me since the changes were made.
    I can still not see my payment details. So i guess it is a "work in progress". :eek:
    At least O2 have acknowledged there is a problem. And that is usually half the battle won. :)
     
  21. page3 macrumors 6502

    Joined:
    Feb 10, 2003
    Location:
    Vicar of Dibley-land, UK
    #21
    I still get a totally blank screen on both Firefox and Safari.
     
  22. phannon666 macrumors regular

    Joined:
    Feb 1, 2008
    Location:
    Bucks, UK
    #22
    Fact is the O2 website was created, and is maintained by retards. It breaks if you look at it funny, and any website that was seemingly targeted for IE users only (because clearly thats the only browser anyone ever uses...), its creators deserve to be stabbed to death with a rusty, ill-shapen spork.

    Rant over.
     
  23. page3 macrumors 6502

    Joined:
    Feb 10, 2003
    Location:
    Vicar of Dibley-land, UK
    #23
    7/10 for the rant. So true.

    I'd be fired if I allowed my team to release a site with so little testing.
     
  24. arkitect macrumors 601

    arkitect

    Joined:
    Sep 5, 2005
    Location:
    Bath, United Kingdom
    #24
    Agreed! :mad:

    I could not even access my iPhone bill via the iPhone's Safari browser… surely you would think O2 would have tested that. :rolleyes:
     
  25. blacksheepblues macrumors newbie

    Joined:
    Mar 1, 2008
    Location:
    UK
    #25
    I've got what sounds like a similar problem (can't log onto O2 online billing) except mine's NEVER worked - I first tried about 3 years ago. I tried again about 2/3 months ago - still didn't work. It lets me log in but when I click on the 'see my bill' link (or whatever it's called) then it just reloads the start page in an endless loop. I couldn't be bothered to figure out what was wrong so I just gave up.
     

Share This Page