'08 MBP Display Not Working Correctly?

Discussion in 'MacBook Pro' started by Stack7, May 2, 2011.

  1. Stack7 macrumors newbie

    Joined:
    May 2, 2011
    #1
    I had been using my MBP all morning with no problems. I shut the screen and let it go into sleep mode for about an hour before I went back to get on it. At first I thought it just wasn't waking up from sleep mode, because the screen just stayed black but the fans booted up and I could hear it running. So, I shut the lid again, opened, and nothing.

    Tried rebooting. The screen stays black the entire time, and I hear the faint sound of the start up sound. When I close the screen, the light at the front doesn't do the "breathing" that it does when in sleep mode. It just stays lit.

    Does this sound like a display problem, or some other issue? Any ideas/suggestions?
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
  3. knightrider macrumors newbie

    Joined:
    Mar 28, 2008
    #3
    Weird. The exact same thing happened to me today. Mine is an early 08 model... Will check the link.

    Edit... I was afraid that was going to be what the link said. Friggen 8600.
     
  4. Stack7 thread starter macrumors newbie

    Joined:
    May 2, 2011
    #4
    Thanks for the link!

    I took it to an Apple store today and they diagnosed it as the graphics card failure. They are replacing the MLB for free (would be a $863 repair otherwise..ouch.)

    Knightrider, I suggest you do the same thing! It was a pretty quick diagnosis and I should have it back within 3-5 days.
     
  5. dringkor macrumors member

    Joined:
    Jan 8, 2008
    #5
    I had the same problem, took it to the Apple store where they diagnosed it right away and fixed it at no charge, in about 45 minutes, while I waited.
     
  6. knightrider macrumors newbie

    Joined:
    Mar 28, 2008
    #6
    Yup I literally took it to the Apple store immediately after I posted last and it was the logic board. It was two months out of warranty, but they are doing it for free anyway.

    Four days later, the status finally went from "Pending - Preparing to Ship" to "On Hold - Part on Order". Have you received yours back, yet?
     
  7. Stack7 thread starter macrumors newbie

    Joined:
    May 2, 2011
    #7
    Yes, they called me on Monday saying the repair was done and I just picked it up today. Works like a charm. I was just wondering, if anyone wouldn't care to explain, how exactly do they repair this? What all gets replaced? I meant to ask at the Apple store, but they were kind of rushing me out.
     

Share This Page