Resolved 09 13" MBP Display Won't Turn On?

Discussion in 'MacBook Pro' started by KUguardgrl13, Aug 15, 2015.

  1. KUguardgrl13 macrumors 68020

    KUguardgrl13

    Joined:
    May 16, 2013
    Location:
    Kansas, USA
    #1
    Hi! I have a 2009 13" MBP as my spare Mac. I haven't done anything with it in a few months since I loaned my MagSafe charger to a friend who bought a used Mac that didn't come with one. I found a used MagSafe on Craigslist for $60 (it's an L-shaped that came with a 15", but I know that's not a problem with the 13" model) and decided to boot up my Mac to update it and make sure it's still running.

    So I plugged in the replacement MagSafe and the orange light came on to show that it's charging. I pressed the power button assuming my Mac would start booting up like normal. Granted this particular MBP has had some problems with hard drive cables and sleep/wake issues. But I figured it was with a shot to see if it would start up fine. Unfortunately the display didn't come on. I heard the hard drive or fan start making quiet noise, but the sleep/wake light was solid. No chime, but it's entirely possibly I left it muted last time I used it.

    In the mean time I've forced shutdown and have left it plugged in. I'll see if it starts up in a little while after its had some time to charge even though it looks to have 50% or more battery per the indicator. But I wanted to see if you all had some suggestions. I also need to track down my screw drivers before I can unplug the battery and such.

    Thanks!
     
  2. KUguardgrl13 thread starter macrumors 68020

    KUguardgrl13

    Joined:
    May 16, 2013
    Location:
    Kansas, USA
    #2
    Never mind, it seems to have resolved itself! Booting up now
     

Share This Page