1.01 Firmware - imap email no longer working!!!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by danny-bonaducci, Aug 1, 2007.

  1. danny-bonaducci macrumors member

    Joined:
    Jul 3, 2007
    #1
    I upgraded my phone this evening only to find my email settings for work no longer work. They worked just fine under 1.0, but now mail locks up every time I try and check my messages. I have no problems with the yahoo account I use, but the imap servers I use are a no go. The servers are up and working (I can connect using another client without issue), so I am guessing some "fix" killed my server connection.

    I have deleted and created the account a number of times. It verifies just fine, but when it is "checking email" it locks up, the screen goes black and eventually it bounces me back to the main screen.

    I was about to do a restore, and I noticed it does not appear to revert me back to 1.0, but essentially cleans up my 1.01 firmware. Is there any way to downgrade back to the 1.0 firmware? I really need access to that email account, without it I may have to simply try and return the phone, if I still can...
     
  2. honeytoast macrumors regular

    Joined:
    Sep 15, 2004
    Location:
    bay area, CA
    #2
    so you havent done a restore yet? have you tried a hard reset? just hold the sleep/wake & home button until you see the apple logo. That way you wont lose your settings.
     
  3. danny-bonaducci thread starter macrumors member

    Joined:
    Jul 3, 2007
    #3
    I tried the hard-reset, no dice.. I have not done the restore, since it seems to just clean up my 1.01 install, I did not see the point.

    Update: I think there is something different in 1.01 and the way IMAP folders are supported. I changed the IMAP prefix from the default value to "Inbox" which seems to have helped. I am not sure if this is going to help anyone else though, it could be very specific to my setup at work. I can now see my inbox, but since I changed the IMAP prefix I cannot see anything but my inbox folder. I am ok with this for now, but I sure would like to get things back to where I can see both my inbox and all of its folders. I know my mail server at work has a ton of public folders (Exchange server that I am accessing via an IMAP proxy) perhaps the phone is attempting to read all of them and this is making things crap out.. Not sure, but I do have a little success to share here..
     
  4. BwanaZulia macrumors regular

    Joined:
    Jun 8, 2002
  5. Roy Hobbs macrumors 68000

    Roy Hobbs

    Joined:
    Apr 29, 2005
    #5
    I use 3 IMAP accounts on my iPhone all are working properly
     

Share This Page