1.1.1 Unlocked ----> 1.1.2 Unlocked using iNdependence 1.3.1?

Discussion in 'Jailbreaks and iOS Hacks' started by ventro, Dec 17, 2007.

  1. ventro macrumors 6502a

    Joined:
    Sep 23, 2006
    #1
    Has anyone tried this?

    The new iNdependence has a set of instructions to upgrade to 1.1.2, which involve a "Pre Firmware Upgrade" instead of Oktoprep. These instructions look really simple.

    ----------------------

    To upgrade from 1.1.1 to 1.1.2 so that you can activate/jailbreak your phone:
    1. Check the firmware version that's reported in the status line at the bottom of the iNdependence window. If it doesn't say 1.1.1 then these instructions aren't for you.
    2. Activate your phone using the activation instructions below. Make sure to leave your phone jailbroken after activation.
    3. Install SSH on your phone.
    4. Ensure that your phone is connected to a Wi-Fi network (read the iPhone manual for instructions on how to set up Wi-Fi). Also ensure that it's IP address does not conflict with any other devices on your Wi-Fi network (sorry, I can't offer network admin help).
    5. Get the IP address for your phone by launching the Settings application on the phone, navigating to Wi-Fi and pressing the blue arrow beside the name of the Wi-Fi network that your phone is connected to.
    6. Select the Firmware tab and press the Pre Firmware Upgrade button.
    7. Enter the IP address of the phone and the root password.
    8.Follow the instructions given in the dialog windows. If iNdependence gives you a warning about host verification failure and asks to edit your known_hosts file, choose the Yes option (which is now the default).
    9.Once you are told to upgrade using iTunes, quit iNdependence, and select the Update button in the iTunes window (not the Restore button). Note that the button might be labelled Upgrade instead of Update.
    10. Wait for iTunes to finish.
    11. Quit iTunes and relaunch iNdependence. In the status bar at the bottom of the iNdependence window you should see Firmware 1.1.2.
    12. Congratulations! You are now ready to activate/jailbreak your 1.1.2 phone using the instructions below.

    ----------------------

    They even have an AnySim button now that will install the right version of AnySim. Has anyone tried these instructions?

    Also, on an unlocked 1.1.2,

    1. Does YouTube work?
    2. Does SMS work?
    3. Does Phone work perfectly?
    4. Do 3rd party apps, specifically Terminal and Customize.app work?
    5. How do you enter in your EDGE APN? I heard there's no more place to enter it in anymore.
     
  2. lodev macrumors newbie

    Joined:
    Dec 18, 2007
    #2
    Yup, did it yesterday. Works fine, certainly a lot faster than the previous oktoprep + upgrade + downgrade + anysim + upgrade scenario.
    iNdependence can install the correct anySIM for you.

    To answer your questions:

    1. Yes
    2. Yes
    3. Yes. Please note that on phones with foreign sim cards Phone and Sms will appear to crash randomly. To resolve this, install iWorld from Installer.app. Afterwards it works fine.
    4. Yes. iNdependence does not include Installer.app/Apptapp though, so you'll have to download it yourself and add it to your iPhone using iNdependence.
    5. Settings > General > Network. Works fine.


    Best,
    Lode

    My iPhone unlocking/upgrading/jailbreaking history:
    iPhone with 1.1.2 working on Base (Belgium), via oktoprep (mine)
    iPhone with 1.1.2 working on Mobistar (Belgium), via oktoprep
    iPhone with 1.1.2 working on Proximus (Belgium), via iNdependence
    iPhone with 1.1.1 working on Proximus (Belgium), via iNdependence
    iPhone with 1.1.1 working on Proximus (Belgium), via Jailbreakme

    All of those were bought in the US with 1.0.1 or 1.0.2 out of the box.
     
  3. dalvin200 macrumors 68040

    Joined:
    Mar 24, 2006
    Location:
    Nottingham, UK
    #3
    does all this imply that there is a legit version of anySim working on 1.1.2?
    instead of all the dodgy 1.2u versions of anySim?

    might be tempted to up from 1.1.1 to 1.1.2 if independence has made it much easier - just how i upgraded from 1.0.2 to 1.1.1

    ta
     
  4. lodev macrumors newbie

    Joined:
    Dec 18, 2007
    #4
    The version included with iNdependence 1.3.1 is 1.2.1u for 4.02.13G (Phone Dev/Elite teams). I believe this is the one available at code.google.com/p/iphone-elite. The difference with before is that using the oktoprep routine (where you had to upgrade to 1.1.2, then downgrade to 1.1.1, then to 1.0.2, then run anysim, then upgrade again, then pray), with the way iNdependence jailbreaks the phone anySIM works directly on 1.1.2.

    Of course, this all still implies you haven't gotten an OOB 1.1.2 (Out of the box). It seems you can jailbreak those, but not unlock them yet. I can't tell this for sure, because I don't have one of those laying around.
     
  5. psychofreak Retired

    psychofreak

    Joined:
    May 16, 2006
    Location:
    London
    #5
    AnySim claims to have worked but my O2 P&G SIM doesn't work (this is on both a US iPhone that came with 1.02, and a UK iPhone, they are both now on 1.1.1). Is it because the SIM is too old?
     
  6. lodev macrumors newbie

    Joined:
    Dec 18, 2007
    #6
    I had the same problem when doing my first upgrade to 1.1.2. anySIM said it worked, but it could'nt connect to the network.
    I don't recall 100% how it went, but when downgrading all the way to 1.0.2 suddenly it started working, and then I could upgrade to 1.1.1 and 1.1.2.

    Another problem I once encountered (on a different iPhone) was that after restoring the settings trough iTunes, I got "no service". This phone had a specific carrier selected as default, instead of automatic. Just setting it back to automatic did the trick. Apparently some ID got changed in the process, and the phone was looking for a network it couldn't find.

    I don't know about the UK phones, as I supposed they're out of the box 1.1.2. Maybe they do work as long as you stay on o2, but I haven't gotten any experience with those so far.
     

Share This Page