1.1.2 Jailbreak worked, But no Mail, Stocks, Maps, Etc. (HELP)

Discussion in 'iPod touch Hacks' started by cecoleman, Nov 13, 2007.

  1. cecoleman macrumors regular

    Joined:
    Nov 13, 2007
    #1
    Okay, I followed all the steps in doing the update to 1.1.2 for my Ipod Touch. I did all the prep work before hand. I did the install of the Jailbreak, it worked like a charm. However the first I didn't check off the SSH box. Then when it was finished the installer was there, I went through and installed stuff no problem. The problem was it didn't put back the Mail, Maps, Weather, etc. back on the ipod. You can't get it through the installer...so I re-ran the jailbreak and this time checked off the SSH. That didn't help. I've read on the net you can manually do this, using the "FETCH" program. The problem is I don't know how to connect to it with this program.

    Is there someone who can guide me how to get back the mail, weather, maps programs back? Can you give me specific details? What did i do wrong?
     
  2. mattydub macrumors member

    Joined:
    Oct 29, 2007
    #2
    You just install them the same way you did on the 1.1.1 firmware.
    SSH into your ipods application directory, frameworks etc.
     
  3. cecoleman thread starter macrumors regular

    Joined:
    Nov 13, 2007
    #3
    I didn't do the original jailbreak on the 1.1.1 firmware. A friend of mine did it for me when I didn't know what was going on with Jailbreak. I need step by step...
     
  4. solyd macrumors regular

    Joined:
    Oct 15, 2007
    #4
    Search the forum, there are plenty of threads on this.
     
  5. CalMin macrumors 6502a

    CalMin

    Joined:
    Nov 8, 2007
  6. cecoleman thread starter macrumors regular

    Joined:
    Nov 13, 2007
    #6
    Okay I did the directions below that I found...it worked! HOWEVER, my mail program does crash after opening. It starts to work, then boom. Back to springboard.

    Any other help on this?
     
  7. mattydub macrumors member

    Joined:
    Oct 29, 2007
    #7
    you need to get the 1.1.2 version of mail.
    PM me with your email address... ;)
     
  8. cecoleman thread starter macrumors regular

    Joined:
    Nov 13, 2007
  9. redheadguy719 macrumors newbie

    Joined:
    Oct 14, 2007
    #9
    yeah, I've downloaded "1.1.2" iphone apps from a bunch of different places, and my ipod still crashes whenever I load Mail.app (and stocks, but i didn't care about that in the first place). Any ideas as to what is still wrong?

    EDIT: this solution fixed all problems; you need to set-up proper rights for the applications:
    [in Terminal/ssh]

    cd /Applications/[appname].app/

    chmod -R 644 * <--the only thing different this did, therefore important

    chmod 755 [appname]

    then, test it by [still in Terminal] “./[appname]” (without quotes of course)

    you can close the app with ctrl+c


    this solved everything for me...i don't know exactly what made the difference, it might have even been the force starting of the apps in SSH
    this is from a reply here: http://http://www.hacktheipodtouch.com/install-application/mail/mail-app-on-ipod-touch
     

Share This Page