1.1.5 or 2.0 better for jailbreaking iPod Touch?

Discussion in 'iPod touch Hacks' started by codycalifornia, Jul 24, 2008.

  1. codycalifornia macrumors newbie

    Joined:
    Jul 16, 2008
    #1
    Hey! Just got my new iPod Touch in the mail yesterday and it is 1.1.5 firmware. I was wondering if it would be better to jailbreak it at 1.1.5 or to buy the $10 upgrade to 2.0 and then try jailbreaking it? (i heard 1.1.4 is good too, i really just want to know the best version to jailbreak it in)

    Also, if 2.0 is the better choice.. i know you can download the 2.0 firmware at http://www.felixbruns.de/iPod/firmware/ ... would that make it possible for me to get 2.0 for free?
     
  2. codycalifornia thread starter macrumors newbie

    Joined:
    Jul 16, 2008
    #2
    Anyone? :p Sorry I'm being impatient.. just really eager to do this!!!

    Thanks
     
  3. andybno1 macrumors 68040

    andybno1

    Joined:
    Nov 6, 2007
    Location:
    Liverpool, UK
    #3
    no you cannot use that link to get 2.0 as apple have now protected the direct download link.

    there is a trick using itunes, I found if you uninstall iTunes reboot then reinstall it and have 1.1.4 on your touch when you open iTunes 7.7 after reinstalling it will popup a notification 2.0 is available, if you click download only you can get it that way. this also means you could restore to official 2.0 for free lol

    pwning 2.0 will give you the update for free yes, if your on a jailbroken 1.1.4 there no point going to 1.1.5 theres really no difference
     
  4. codycalifornia thread starter macrumors newbie

    Joined:
    Jul 16, 2008
    #4
    No my iPod is 1.1.5 and it has never been jail broken. I am wondering what th best version (1.1.4 - 2.0) is the best for it to be jail broken so I can make it that version before i jailbreak it
     
  5. asskick3r macrumors regular

    asskick3r

    Joined:
    Jun 9, 2008
    Location:
    "Somewhere ... In las vegas"
    #5
    I find 1.1.5 faster than 1.1.4. Plus it is more stable... with the same jailbreak as 1.1.4.
    But the only problem is... that some 1.1.4 apps don't work... so you have to install fwchanger off of installer to trick the ipod into thinking it is on 1.1.4.
     
  6. codycalifornia thread starter macrumors newbie

    Joined:
    Jul 16, 2008
    #6
    You confused me... your saying keep my version at 1.1.5 but use the 1.1.4 jailbreak...?

    Is there any reason I should not upgrade to 2.0 and jailbreak that? (i.e - buggy, not as good apps, etc?)
     
  7. codycalifornia thread starter macrumors newbie

    Joined:
    Jul 16, 2008
  8. rd261 macrumors regular

    Joined:
    Sep 24, 2007
    #8
    no

    No. He meant that you could jailbreak 1.1.5 and it will work good, however when you are going to install applications from installer, some of those apps require 1.1.4 and therefore you need to install a program that tricks your ipod into thinking you have firmware 1.1.4 instead of 1.1.5. There is not much difference between 1.1.4 and 1.1.5, although I've heard that the latter is a bit more stable. 2.0 is good because of the official applications but is really crappy at the moment and most unofficial applications are not compatible with 2.0 no matter what (not even by tricking your ipod). If you are not interested in the app store and other features of 2.0 you should just stick with 1.1.4 or 1.1.5 (your choice really) and wait until apple fixes 2.0 and more unofficial apps are remade for 2.0.
     
  9. codycalifornia thread starter macrumors newbie

    Joined:
    Jul 16, 2008
    #9
    Thank you! So my next steps would be first finding a jailbreak method for 1.1.5, then getting an app once its jailbroken to make my iPod thinks it is 1.1.4?
     
  10. rd261 macrumors regular

    Joined:
    Sep 24, 2007
    #10
    Yes. The name of the application to trick your ipod is fwchanger or something like that. When you jailbreak and go to installer you should first try to install the applications that you want. Some of them will install fine. If you find one that is not compatible with 1.1.5 then you should install fwchanger and install that application. After you are done installing the apps you could easily uninstall fwchanger from installer and your ipod will think it is 1.1.5 again.
     
  11. asskick3r macrumors regular

    asskick3r

    Joined:
    Jun 9, 2008
    Location:
    "Somewhere ... In las vegas"
    #11
    @Codycalifornia:
    My bad for not explaining it a little bit softer in my last post.
    But yeah... rd261 said it right.
     
  12. codycalifornia thread starter macrumors newbie

    Joined:
    Jul 16, 2008
    #12
    Oh no problem asskick3r! If I knew anything at all about jailbreaking and installing at the time it would have made sense. I have jailbroken it at 1.1.5 and when an app calls for 1.1.4 i just install fmswitcher or whatever switch it to 1.1.4 then uninstall it again :) most apps seem to be 1.1.5 compat. your previous post makes complete sense now!
     
  13. asskick3r macrumors regular

    asskick3r

    Joined:
    Jun 9, 2008
    Location:
    "Somewhere ... In las vegas"
    #13
    Well thanks!
    But if you have the ispazio official repo then you can install a 1.1.5 Compatibility patch.
    Which lets you install 1.1.4 apps on a 1.1.5 device.
    I never tried this only because I used fwchanger for all the apps I needed.
    But I'm sure it will work just fine.

    (The Compatibility Patch is only a suggestion... if you decide to use your original method, that you think is easier, go ahead with that instead)
     
  14. itzdemo macrumors regular

    itzdemo

    Joined:
    Jul 12, 2008
    Location:
    Austin Texas
    #14
    2.0 rocks

    i did my 1.1.5 with ziphone with no probs at all (the 1.1.4 jailbrak)

    and used the fwchanger to edit it as 1.1.4 to get all my apps back..

    after i got board of it i dumped it for the 2.0 and glad i did !!
     
  15. dukebound85 macrumors P6

    dukebound85

    Joined:
    Jul 17, 2005
    Location:
    5045 feet above sea level
    #15
    why not jb now and if you dont like it, pay the 10 bucks and get 2.0 lol
     
  16. itzdemo macrumors regular

    itzdemo

    Joined:
    Jul 12, 2008
    Location:
    Austin Texas
    #16
    You would pay 10$ for the 2.0 upgrade ? Everyone I know even me got it free !! GOOGLE IS YOUR FRIEND !!
     
  17. Elvebrinduil macrumors newbie

    Joined:
    Jul 25, 2008
    #17
    OFF COURSE u can get it for freee!!! just search well in the web, and in youtube ;) hahaha
     

Share This Page