1 Password 4 (Agilebits)

Discussion in 'iOS Apps' started by BasilFawlty, Jun 6, 2013.

  1. BasilFawlty macrumors 6502

    Jun 20, 2009
    New Mexico
    I have been using 1 Password 3 for some time on my iPhone 3GS. I recently upgraded to an iPhone 5 and 1 Password 3 still works, but I decided to go ahead and buy 1 Password 4 (it's not just an upgrade, but a whole new program you must buy again). Anyway, I'm hoping someone else here has moved from 1 Password 3 to 1 Password 4 and can help me with a problem in whihc the data from 1 Password 3 will NOT migrate over to 1 Password 4. For the record, I do NOT use icloud nor drop box to sync multiple devices. I do NOT want to have all my passwords out of some server in who-knows-where, regardless of how "secure" it claims to be. Here is what I have done to try to follow the steps to migrate the data to the new app:

    Ok, I have 1Password 3.6.5 on my iPhone. Originally it was on my iPhone 3GS, but I recently upgraded. as I type this, I am doing the steps (again) from scratch. I have deleted the new version and re-downloaded to my iphone 5, so I can go through this from scratch. Someone PLEASE tell me what I'm mising here. I go through these steps and it doesn NOT migrate my data:
    1.Downloaded new version to iPhone (4.2.1) (Old version still on myiPhone)
    2.Tap to open the NEW 1 Password.
    3.Select the option "I've used 1Password before"
    4.From "Syncing Page" I select option: "Import from old version"
    5.It asks me to set a new master password, so I do
    6.At this point it says "You are now ready for migration" and "Unlock th eold app and then select the option to migrate your date" (Note, there is a button on this page that says "Get Started")
    7.I click "Get Started and my old app opens.
    8.I select "Migrate to 1Password 4" At this point I'm in my old app but nothing seems to be happening.
    9.I go back to my NEW app - no data has been migrated.
    10.If I can't get this solved, I intend to ask for a refund. This is ridiculous!

    I have asked this question on the Agilebits forum but not getting any good responces, so thought this might be a good place to try. I have of course emailed their tech support but got an automated reply telling me how busy they are and that it could be some time before I get an answer from them.

    So - has anyone done this upgrade and had success in simply migrating the data from 1 Pass 3 to 1 Pass 4??

    Thanks in advance.
  2. AGKyle macrumors 6502

    Jun 10, 2012
    Sorry you're having trouble with the import.

    If you have all of the data on your Mac, you can just use our iTunes import process. It's outlined here:


    This is a one time thing. It isn't a sync. So, if you change any items on your Mac you'd not get them on your iPhone automatically.

    But, that will get your data to the iPhone. If you want to sync you can use our USB Sync, it's beta but works for most people. The only setting you need to change before trying it is to click Options->Use Beta version, and uncheck that option. It's fully outlined here:


    Both of those should work to get your data from the Mac to the iPhone.

    If this does not work, please email us. Details in my signature. You're welcome to put "attention Kyle" in the subject. Someone will find it (we're a tad overwhelmed right now due to the sale) and assign it to me. You can also just PM me the email you sent it from and I'll look it up that way.
  3. BasilFawlty thread starter macrumors 6502

    Jun 20, 2009
    New Mexico
    Expect an email. I may not have been clear in my original post. Forget an Mac, forget syncing - all I want to do it transfer the data that is currently ON MY iPHONE in Version 3.6.3 and "migrate" it to version 4.2.1 ON THE SAME PHONE! When I open a newly downloaded version 4.2.1 and open it for the first time, there is a selection that says "I've used 1Password before". I select that and there is an option on the next screen that says "import from old version". Seems simple enough - so I tap that option. Then it asks me to set up a master password, which I do. Then, after I set the Master PW on the NEW version, there is a screen that says "Unlock the old app and then select the option to migrate your data" Seems straight forward so far. I tap the "Get Started" button and viola, my OLD 1 Password opens with a pop up that contains an option (button) "Migrate to 1 Password 4". I tap that option, expecting my data to migrate, but NOTHING happens. I get no error message, no indication that anything else needs to be done. It just sits there in the old version and does nothing. When I open the NEW version, there is NO data that has been transferred.

    Either one of two things are going on:

    1. Your instructions suck and I really need to do some other step that is not clear in the instructions or:

    2. Your software has a major BUG and needs to be updated immediately.

    This is a pretty glaring issue in my humble opinion (and BTW I do operational testing for a living) and needs to be addressed.

    If the migration I'm attempting to do simply isn't possible, then just tell me that and I'll spend a couple of hours manually entering all my data. Please don't tell me to use my MAC or Dropbox or iCloud or anythign else - either I can migrate from version 3.x to version 4.x from withing my iPhone or I can't - which is it?
  4. CylonGlitch macrumors 68030


    Jul 7, 2009
    You can, I did it as well as many others. But just an FYI, you're coming across as quite rude. I understand the frustration but Kyle is trying to help.
  5. BasilFawlty, Jun 7, 2013
    Last edited: Jun 7, 2013

    BasilFawlty thread starter macrumors 6502

    Jun 20, 2009
    New Mexico
    Sorry, not trying to be rude - just specific - and only after posting on their web site and getting only replys that don't answer what I thought was a simple question. So yes, I'm getting frustrated. I understand they are busy, but I bought this app expecting it would work as advertised and so far it doesn't. Kyle said "If" my data is on a Mac." Ok, but it isn't on a MAC it is only on my iPhone.

    That is what I am trying to get across. All I want to do is transfer the data from the old App to the New App on my iPhone. The process I described above is how the new app directs me to migrate the data - step by step - but it doesn't work. Since you indicate that you have done this, I would greatly appreciate knowing how. What, in the above listed steps, did I do wrong, or am I missing some step that maybe isn't obvious?

    Again, I'm simply trying to do one thing: Transfer the data from the OLD app on my iPhone to the NEW app on my iPhone. If this can't be done, ok, tell me that. But I'm just trying to get someone to tell me if it is or isn't possible, and if it is possible, then what am I doing wrong in the previosuly listed steps?
  6. AGKyle macrumors 6502

    Jun 10, 2012
    Yes, there is a bug in the import. It's a bug in 1Password 3, not version 4. Usually this helps:


    If that doesn't help, then the best option is to backup your data, then use the Mac version to sync your data from the iOS app (version 3) to the Mac. Finally, you can copy the file from the Mac to the iOS device (for version 4) using the instructions I mentioned previously.

    It's a bit of a roundabout way of doing it, but it works, and I can help you do this.

    I just searched through our support system for anything with my name in the subject but found nothing. I also didn't get a PM with your email. So, if you sent an email already (no worries if you haven't yet gotten to it) please PM me your email so I can look it up by that. Otherwise it's like looking for a needle in a haystack at the moment. Our support queue is overflowing from the sale.

    I'd prefer we continue in our own support system so that it can be actively monitored more closely. (I get notified when you reply for example). Here, a lot of stuff can get lost since it isn't our system.
  7. BasilFawlty thread starter macrumors 6502

    Jun 20, 2009
    New Mexico
    Ok, thanks. I'll try what you suggested and let you know via support system. At least I know now there is a bug somewhere, and it's not just me not doing some step correctly. I don't use drop box (I don't want a file with all my passwords out on some server over which I have no control), but I'll try the second method in the link you provided. I'll let you know by your support system, but will also post results here for benefit of anyone else who may have similar problem.
  8. BasilFawlty thread starter macrumors 6502

    Jun 20, 2009
    New Mexico
    I have tried everything suggested. Also, on the Agilebits forum, one of the guys suggested I try wi-fi sync to 1Pass on my Mac. That didn't work either. At this point, having spent the past two days to solve this, I am throwing in the towel and accepting that I am going to manually copy all my data from 1 Password 3 and re-enter it into 1 Password 4. Thanks for all the attempts to help.
  9. AGKyle macrumors 6502

    Jun 10, 2012
    I sent another PM. But the only way we can really help is to give you specific instructions. Specific instructions for your situation won't work for everyone, thus I am hesitant to put them on a public forum where they may not work for someone else.

    If you can email us, and send me a PM with the email address you used, I'll take a look at it and help you personally. I'm here to help, but you have to email us so I can give you the best help I can provide. I'll check in throughout the weekend to see if you've sent any messages on here so we can take another look at this.
  10. Troneas macrumors 65816


    Oct 26, 2011
    At the alternatives section.
    for the record OP, I understand that the file that stores your passwords in dropbox (1Password.agilekeychain) is encrypted, so its irrelevant if its stored in an insecure server (although i doubt dropbox's servers are that vulnerable).

    just saying this because you might be going through a lot of hassle or limiting your experience because of some unfounded concern... what will happen if you lose your phone?

    so unless your copy of 1Password is hosting nuclear weapon launch codes you should be fine.

Share This Page