1 USB working/1 USB not working

Discussion in 'MacBook Pro' started by rad4d, Nov 6, 2008.

  1. rad4d macrumors newbie

    rad4d

    Joined:
    Nov 5, 2008
    #1
    I have just bought a second hand Powerbook G4 17" 1.5GHz and have a problem with my usb ports. The one on the lhs of machine doesn't work and the one on the rhs does. Has anyone else had this problem at all? Or have any idea why this might be? I'm new to macs so please bear in mind that i'm a novice when answering please...

    cheers
     
  2. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
  3. themoonisdown09 macrumors 601

    themoonisdown09

    Joined:
    Nov 19, 2007
    Location:
    Georgia, USA
    #3
    I had the same issue as you at the beginning of this year with my Macbook Pro. I would plug my thumb drive into the right USB port and it would work fine, but if I plugged it in the left side, it would constantly get disconnected, sometimes not even working. I took it to an Apple Repair shop and they ended up replacing the logic board... now it works perfectly. I had AppleCare, so it was free.

    I'm not saying that's what's wrong with yours, but I'd get it checked out. If it is the logic board and you don't have AppleCare for it, I think the fix is kind of pricey, I'm not really sure.
     
  4. TDM21 macrumors 6502a

    TDM21

    Joined:
    Jul 7, 2004
    #4
    You could try resetting the NVRAM and PRAM of the system to see if that clears the issue up. I've had issues with the USB ports on my PowerBook that were fixed by doing that.

    Resetting NVRAM:
    1. Shut down you computer
    2. Press the power button and immediately hold Command + Option + O + F . That will boot you into Open Firmware
    3. Type the following: reset-nvram (press enter) reset-all (press enter)

    Resetting PRAM:
    1. Shut down your computer
    2. Press the power button and immediately hold Command + Option + P + R
    3. Wait until you hear the system bong and then release the keys
     
  5. rad4d thread starter macrumors newbie

    rad4d

    Joined:
    Nov 5, 2008
    #5
    thanks

    i have tried the usb ports with mac mouse and external powered hard drive. the lhs one doesn't see either of them and the rhs does.
    I've reset nvram and pram but no difference i'm afraid.

    thanks for your answers

    i'll have to get it checked over properly
     

Share This Page