10.1.2

MacRumors

macrumors bot
Original poster
Apr 12, 2001
46,777
8,956
Numerous readers wrote in to say that Mac OS X 10.1.2 was released overnight.

The 10.1.2 update delivers improvements and new functionality, as well as expanded peripheral support for Mac OS X. Enhancements include:

- Updated and new USB and FireWire device support, including FireWire-based digital cameras
- PC Card storage devices, including media readers
- IrDA modem support for FireWire-based PowerBook models
- Audio, Display, and Speech improvements
- Networking and Printing improvements
- AirPort v2.0
- Apache web server v1.3.22
- AppleScript v1.8
 

marco114

macrumors 6502
Jul 17, 2001
324
128
USA
Not supported?

What kinda ATI card are you running? I got a G3/350 with an ATI card that runs great, my 233 iMacs even work pretty good.
 
Not enough & worse

Mac OS X: Optimizing for Earlier ATI Graphics Accelerators

TOPIC

Movies and 2D graphics perform better at lower color depths when using Power Macintosh computers with earlier ATI graphics chipsets.

DISCUSSION


Symptom

QuickTime movies may play with a lower frame rate than expected. Games and other software that utilize hardware graphics acceleration or OpenGL may perform more slowly than expected.

Products affected
* Mac OS X 10.0 and later
* Power Macintosh G3 (Desktop, Mini Tower, and All-In-One models)
* iMac (233, 266, and 333 MHz models)
* PowerBook G3 Series
* PowerBook G3 Series (Bronze Keyboard)
* iBook (original)

These computers include one of these graphics accelerators:
* ATI RAGE II+
* ATI RAGE IIc
* ATI RAGE Pro
* ATI RAGE Pro Turbo
* ATI RAGE LT Pro
* ATI RAGE Mobility

Solution

Lowering the display color bit depth to thousands improves performance of some movies and applications.
1. Choose System Preferences from the Apple Menu.
2. Click Displays .
3. Click the Display tab.
4. Choose Thousands from the Colors pop-up menu.
Use the latest version of Mac OS X for best overall performance and feature set. Further Mac OS X support for the graphic accelerator chipsets listed above is not planned.

 

Fat Tony

macrumors member
Dec 13, 2001
59
0
What is the build of the 10.1.2? I had the 5P28 build a few weeks ago and wondering if it was still the same.
 

Bophonic

macrumors newbie
Nov 13, 2001
23
0
My Sony Spressa USB still after 10.1.2 doesn't work with OS X, I have to boot up with OS 9. Anyone have the same problem, or know how o fix it??? FYI Apple sent invitations like the ones back in October for the new devise today.
 

nerveosu

macrumors member
Sep 17, 2001
85
0
it fixed the iMac DV audio problem.

I am very happpy. They fixed the audio on the 400 DV iMacs.. now I can listen to my tunes.

awsome. can't wait for macworld.

-bill
 

kaneda

macrumors 6502
Oct 27, 2001
430
184
crashed

Sadly to say...10.1.2 just crashed on me twice in the row. What is going on? It crashed when I tried to run Words, and the other when I tried to open classic enviroment. It hadn't crash since I used 10 and 10.1. I just upgrade to 10.1.2...and It crashed twice.

 

bunge

macrumors member
Nov 3, 2001
39
0
SETI

I'm running the command line version of seti@home and it appears to be completing a work unit in just over 10 hours instead of 14. Could be coincidence, but it could be optimizations as well. I have the 667 TiBook and perhaps something has been recompiled for a newer G4?
 

dantec

macrumors 6502a
Nov 6, 2001
605
0
California
No problems so far... I needed an update to re pre_bind my comp. cause it was getting slow (stuff took 4,5,6 bounces and on a 867 quicksilver that is NOT normal!). Now everything works fine, not crashed yet.

Kaneda, did you do any work with the terminal? That can sometimes mess up your computer! & during installs some files are overwrites or the comp gets confused with the different files.

Also, with downloads, they sometime get interrupted so some of the data gets corrupted. I think that's what happened kaneda. Never have an Airport base station using it's 56k modem for large internet downloads...
 

Hes Nikke

macrumors member
Apr 16, 2001
93
7
unstable

it doesn't work to well for me :(

i have had to restart my computer 3 times since i installed the update, and classic twice more!

Aqua issues:
the computer doesn't actuly crash, after about 2-4 hours of usage, programs (usuly Finder, DragThing, and sometimes the terminal!) just become unresponsive (spining wheel of death) indefinatly, and if i have a look at top, the proccess kernel_tas (as shown in top) is using 60-90% of my CPU. when my system is being responcive, kernel_tas is using 0-2% of my CPU and setiathome is using anything that is idle...(rather then 1-5% in this unresponsive state)

if i tell the computer to log out, it just sticks on any of the prozen programs if i tell them to force quit nothing happens, and i just give up and use the 3 button solute.

Classic issues:
the screen refuses to redraw in any classic app, i have a gray menubar and the windows are there and clickable, if i move a window, it just moves an image of any Aqua window behind it! if that window goes off screen (or behind the dock) or a new window shows up, it is just white. the only way i can get classic to work, when it is in this state, i have to tell classic to restart.

overall, i wish i could go back to Mac OS X 10.1.1 :(
 

DannyZR2

macrumors 6502
Sep 18, 2001
331
0
Texas
reinstall .1

I just got off the phone with apple tier2.. my iMac at home will not install any updates! it got hung up a while back on the 'installer update 1.0' that came out around with the airport 2.0 update.. it errors out using software update, and when i download the .pkg file.. and open it, the installer window comes up, but there is nothing in thwindow, just a close button.. no text, no lock to unlock.. nothing.. it sucks..

tier2 said to reinstall 10.0 over it and then go through the updates and stuff again.. this rendered my os x useless, and i can't get in except in 9..

i am going to have to wipe it and do a clean install..


my point. tier2 said to reinstall a prev version!? over an existing??? if this in fact IS a good idea, then maybe you could get the 10.1.1 update and reinstall it.. maybe it would go back>> ??? i really doubt it.. sad to say, but this guy at apple seemed to not really be interested in fixing my mac.. he kinda left me with no solution except to 'try this and if that doesn't work.. wipe it!'..

oh well.. it's about to get mandrake linuxppc to run as a server for a while until my girlfriend gets it..
 

kaneda

macrumors 6502
Oct 27, 2001
430
184
terminal

Okay, I did mess around with the terminal...but I didn't know what I did..I am pretty new to Unix...I don't know crap about Unix. I just listened to my friend about trying new stuffs...

I will give it a try again! if I doesn't work for me! I am switching to PC..:O)
 

Xapplimatic

macrumors 6502
Oct 23, 2001
417
0
California
10.1.2 tumbs up

No problems here with 10.1.2.. Seems a bit snappier on the menus with the iMac 400 DV. As for the Sony Spressa.. I've never had trouble with mine.. works great ever since 10.1.0.. but then again, mine's FireWire, not USB.
 

Hes Nikke

macrumors member
Apr 16, 2001
93
7
crashing update

well now DragThing 4.1 constantly quits (usuly when i dissconect from a server) and Entourage 2001 (in classic) constantly quits when i send an email! happily, classic stays up. i'm getting realy mad at this update! :mad:

btw, i do have a few extra unixy things installed, X10, Webmin, doublecommand, and a couple of others, i don't think those are what are causing the issues, but i'll have to start turning these things off... :(
 

dantec

macrumors 6502a
Nov 6, 2001
605
0
California
You have to make sure with these downloads that they aren't corrupted. Just a few missed 0's & 1's and the update is screwed. Unfortunately I don't think software update actually verifies the package and just install's it any way.

I would try redownloading it... But if you have a slow connection (modem) try downloading at night...

The problems I had before with Apple installers where with those system 7 looking installers. When I installed an OpenGL update, it screwed up my system and put this folder that I could not untrash. Thankfully Norton Utilities repaired the corrupted folder and I could trash it. Since 9.1 I have not had any reinstalls (with 9.1/9.2.2 I havn't found any bugs yet). The only time I had to reinstall X is when Norton Utilites repaired the date of a kernel file which rendered is useless (? somehow) and I got a grey screen with an X folder ripped in half.

I just reinstalled over (just like tier2 told you danny) and it worked fine, the bad kernel file was overwritten and worked flawlessly afterwards (note this was 10.0).
 

eyelikeart

Moderator emeritus
Jan 2, 2001
11,897
0
Metairie, LA
10.1.2

I've been running it on my PowerBook for a few days now...

no problems whatsoever!

My apologies to those out there having difficulty...
 

DannyZR2

macrumors 6502
Sep 18, 2001
331
0
Texas
powerbook

Mine's been okay too.. can't say i noticed any speed bumps, but it hasn't crashed yet.. (it had before) and I do like the IRDA support. I was wondering about this.. my rev.a iMac needed to get some use out of it's IRDA port!
 

Hes Nikke

macrumors member
Apr 16, 2001
93
7
IR on the iMac?!

as far as i know the IR port can only be used to get on the internet through a cell phone, great for the PowerBook on the road, but what would be the point of using a cell phone on an iMac?