10.10.3 iMac Bluetooth Keyboard/Mouse lag??

Discussion in 'OS X Yosemite (10.10)' started by phartsy, May 9, 2015.

  1. phartsy macrumors newbie

    Joined:
    May 9, 2015
    #1
    This is the most annoying thing I've ever had to deal with on a Mac. I've owned Macs for years but since 10.10.3 I've had a problem with the bluetooth keyboard and mouse(both official Apple products) lagging while typing and moving.

    Often times the connection drops, about once a MINUTE while using them.
    I'm a photographer/graphic designer and it's impossible to get any work done like that. I've been patient hoping that a fix would come but now I dread using my iMac BECAUSE I know I will have to put up with this problem while using it.

    Hoping someone has a fix for this because Apple has not responding to the support emails. Didn't really expect them to anyway.

    Thanks for any information. :apple:

    Just in case anyone needs this..

    iMac 21.5 inch, late 2013
    2.7 GHz Intel Core i5
    8gb ram
    Intel Iris Pro
     
  2. AndyK macrumors 65816

    AndyK

    Joined:
    Jan 10, 2008
    #2
    Not experiencing this at all. Do you have a USB 3.0 hub near your machine by any chance ?
     
  3. phartsy thread starter macrumors newbie

    Joined:
    May 9, 2015
    #3
    No USB hub near me at all. Seems to be only a select few of us with these problems. It's gotten to the point that I'm thinking of buying the wired versions so that I'll be able to use my computer for the time being.
     
  4. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #4
    USB3
    Handoff
    WiFi 2.4GHz

    Any of these can interfere with BT operation. Try disabling them one by one and all together and see if any combination works better and take it from there.
     
  5. eattherich macrumors 6502

    eattherich

    Joined:
    Jul 8, 2011
    Location:
    Berlin
    #5
    Have a search on here and you'll see a few other threads talking about the same issue. I've also been getting it on my 27" iMac (specs below). What's weird, though, is that there are sometimes days when it never happens. I restart it more than I do my MacBook as I use Boot Camp to play games on Windows. It's almost like some times I restart it's set to be a pain and others everything is fine.
     
  6. cosmic68 macrumors 6502

    cosmic68

    Joined:
    Dec 26, 2007
    #6
    x2

    I've unpaired everything/restarted everything/signed out of iCloud etc. Works for awhile then comes back (have lost Continuity/handoff in the process).
     
  7. iamawl macrumors newbie

    Joined:
    May 16, 2015
    #7
    Turning off wifi seemed to fix the bluetooth lag for me. Are there any fixes so that I can have them both enabled?
     
  8. iamawl macrumors newbie

    Joined:
    May 16, 2015
    #8
    I called Apple Support and they helped me fix it. What they had me do was the following:

    1) Close all programs. Go to Apple > Force Quit to make sure all are closed.
    2) Apple Icon > Sleep, then wake back up
    3) Apple Icon > Restart
    4) Apple Icon > Shut down
    5) Once shut down, press Shift+Ctrl+Option+Power once and let go
    6) Press power button and boot back up.
    7) Log in and hopefully the lag is gone.
     

Share This Page