10.10.3 keeps asking for Google password

Discussion in 'OS X Yosemite (10.10)' started by Howard Ellacott, May 7, 2015.

  1. Howard Ellacott macrumors member

    Howard Ellacott

    Joined:
    Jun 10, 2012
    Location:
    United Kingdom
    #1
    I keep getting a notification asking to re-enter my Google account password in 10.10.3. I've tried entering the password, deleting my account and adding it again, but the notification keeps coming back! I've got 2 factor authentication turned on. Anyone got any ideas? thanks!
     

    Attached Files:

  2. Ledgem macrumors 65816

    Ledgem

    Joined:
    Jan 18, 2008
    Location:
    Hawaii, USA
    #2
    10.10.3 did some strange things with Google accounts. It's a step in the right direction, but it seems like there are bugs that were introduced.

    You have two-factor authentication enabled; do you also use app-specific passwords? Are you using that account for mail only, or are you having OS X do other things with it? For your own security you don't have to answer those questions here. If you are using app-specific passwords, one thing worth trying would be to delete and recreate the password for Mail (or whichever applications you're using), and then update that password in the appropriate program.

    That seemed to have fixed it for me. However, looking in my Console logs, I (and some others) are still getting various errors, although the operating system isn't prompting us to take action on them. Hopefully 10.10.4 will sort all of this out.
     
  3. bingefeller macrumors 6502

    Joined:
    Jun 25, 2007
    Location:
    Northern Ireland
    #3
    Howard, I have exactly the same problem. Earlier on in the week I was asked to re-enter my gmail.com account password (I only have the Mail app linked in with gmail). I did this and things seemed to be OK.

    I was working on Logic and noticed the fans were running louder than usual and the computer was quite hot. I figured this was normal, as I had a big project open, and it wasn't until about 10 minutes after I'd quit Logic that the fans were still going. I checked my Console was noticed these messages appearing approximately 4 times every second:

    [​IMG]

    I tried various things, including deleting and setting up my Gmail accounts in Mail and nothing worked. Only solution, for me, was to install Thunderbird and everything seems to be OK.
     
  4. idoccurt macrumors regular

    Joined:
    Aug 25, 2006
    #4
    annoying!
     
  5. Howard Ellacott thread starter macrumors member

    Howard Ellacott

    Joined:
    Jun 10, 2012
    Location:
    United Kingdom
    #5
    I only use it with mail, and I used to have app specific passwords, but since 10.10.3 supported 2 step with code verification I switched to that. Might go back to app specific, but it just seems rather odd! Hopefully 10.10.4 will fix it all

    ----------

    Has it asked you since then to re-enter? Mine asks me every few days.
     
  6. amazingrugs macrumors newbie

    Joined:
    May 15, 2015
    #6
    Having the same exact issues. I have deleted accounts multiple times from my Macbook Pro and Mac Pro, turned off 2-factor authentication, re-enabled it, and still running into issues. Strangely, everything works as it should on my iPhone with iOS 8.3.

    Do you happen to use Google Apps for an additional email account? I have my main account, and then one registered on Google Apps for my website, so I'm wondering if this is why we could be running into issues?
     
  7. simonmason macrumors newbie

    Joined:
    Jul 21, 2013
    #7
    Same issue here. Would be interested in any workarounds that people figure out. Thanks.
     
  8. Howard Ellacott thread starter macrumors member

    Howard Ellacott

    Joined:
    Jun 10, 2012
    Location:
    United Kingdom
    #8
    I've found a workaround! Create an app-specific password and use that, and it won't ask again, it's just an odd 2-step bug. It's strange since my phone is fine with 2-step but I'm sure they'll fix it sometime.
     
  9. b0fh666 macrumors 6502a

    b0fh666

    Joined:
    Oct 12, 2012
    Location:
    south
    #9
    my workaround is to install thunderbird and ditch mail.app

    only regret is taking so long to do that... can delete my spam/mail now, no password crazyness, it just works, unlike appel's app
     
  10. henhowc macrumors regular

    Joined:
    Jun 12, 2007
    Location:
    Los Angeles, CA
    #10
    https://discussions.apple.com/thread/6984508?start=0&tstart=0

    seems like a common issue introduced in 10.10.3 and is still in 10.10.4 beta :rolleyes:

    to try and eliminate the need of app specific passwords for Google accounts that have 2FA turned on, they perform web authentication through Google now.

    this works fine for my regular gmail account but not my google apps one. this is because use shibboleth sso for our google apps web auth. so when google sees me trying to add a google apps account it redirects to our sso sign in. unfortunately it doesn't support imap/pop so we still need the option of inputting an app specific password.

    luckily there is a workaround if you select "Add Other E-mail Account" instead of Google and also go to Mail > Preferences instead of Mail > Accounts to try and update your settings.
     

Share This Page