10.10.3 Mail is a nightmare...for me.

Discussion in 'OS X Yosemite (10.10)' started by junebug1, Feb 6, 2015.

  1. junebug1 macrumors regular


    Jan 24, 2007
    NE Ohio
    Situation: At work the main email account is a standard Gmail. Let's call it business@gmail.com. There are 4 people whom all pull/share the same main account. To avoid confusion with the inbox we have it setup as a POP account with the username box under Mail preferences saying recent:business@gmail.com. This allows us to not affect each other seeing every message and the ability for 4 of us to read and delete emails without others losing them as well. It has worked for many many years exactly like this until today.

    I updated my machine to 10.10.3 and it essentially broke the ability to have a POP account. It appears that because Internet Accounts (under System Preferences) is handling all logins with the new sheet pop down that requires you to login through a mini-browser it cannot authenticate the additional settings that Mail was normally handling. I spoke with Apple for a few hours in the AM to see if there was any resolution or workarounds and was told by a Mail Senior Advisor that essentially POP isn't supported in the Beta and he couldn't confirm if there were definitive plans to include it once the general release hits. "IMAP is easier for customers to setup" - sure but what about those of us that have additional settings inputted or those that don't need their hand held when setting up an email client? The workaround for me is to completely restore my machine and go back to 10.10.2 and keep my fingers crossed that they resolve the issue with Mail not being able to push any settings to Internet Accounts.

    If anyone has a better setup where multiple users can use Apple Mail with a singular Gmail account I would love to know. POP and the recent: add-on were the most effective way to accomplish this but that was a long time ago. It is important that everyone receive each email and be able to handle it their own way without affecting others as well as having the ability to compose and email from that account to respond to clients. I have thought about forwarding all the mail to each persons name@businessname.com address but we lose the ability to respond using the main account.

    For the moment if you use POP with Gmail for any reason DO NOT UPGRADE!
  2. cincygolfgrrl macrumors 6502


    Apr 2, 2012
    Somewhere In Time
    At the risk of sounding arrogant

    Why would you ever, ever base your business on the first developer seed of a BETA OS? I'm sorry, but this speaks more to your lack of judgement than a problem with the first beta release of an operating system update.
  3. mvdw84 macrumors newbie


    Jul 30, 2010
    I don't use my mac for business but I too am having the same problem.

    My gmail account is no longer downloading any new messages in Mail on 10.10.3 beta.

    I tried the Mavericks workaround of taking the account offline and that didnt' help.

    It worked once, when I clicked under accounts and put my gmail password in there once, but nothing since.

    Also, can't seem to log into the beta bug reporting website to inform apple of this.
  4. bwat47 macrumors regular

    Oct 1, 2013
    The comments from the apple mail advisor do sound concerning... do we know if this issue only effects pop, or does it no longer respect the settings in the apple mail 'accounts' tab at all? it sounds like they are trying to deprecate those settings and only use the crappy ub3r simplified "internet accounts' settings which would be an awful choice. I don't use pop but I do have an exchange account that does not work just after setting it up in internet accounts and requires some account settings changed in mail itself.

    I also do tech support for an ISP and I can foresee the huge PIA if apple decides to all the sudden deprecate these settings in 10.10.3 :/

    Hopefully this isn't the case and its just a beta bug

    That said, I'd have to echo what others said that installing 10.10.3 beta on a mission critical machine wasn't a good idea lol :)
  5. Cisco_Kid macrumors 6502


    Apr 24, 2005
    British Columbia
    I'm not having a problem with two gmail accounts, seems to be working nicely.
    You should have the Feedback App on your Mac, it will help you to report the issue.

  6. junebug1 thread starter macrumors regular


    Jan 24, 2007
    NE Ohio
    Wow. Did I touch a nerve? God forbid that someone has an issue with a beta. Did I ever once say shame on Apple for not giving me a perfect release? I've been around this for quite some time. I have a nightly Time Machine and I only install the betas on a separate partition. Never said my entire business was based on a dev seed or that my personal machine was mission critical. I was simply explaining to others that may have similar setups what issues I ran into, what I was told to do in order to resolve them, and what Apple MAY have in store for us in the future when it comes to how Internet Accounts talks to Mail.app - and if you can believe it, I asked the community for help in regards to a possible workaround if the issues with POP continue in future releases. Instead of offering any help or solutions I was scolded by you. So actually you (and the 4 people that enjoyed your remarks) do seem ignorant.

    To those that took the time to formulate a reasonable response and understood what the core issue at hand is I thank you. I agree and hope that it is a stupid bug and Apple works it out, otherwise Mail.app going forward will be a total nightmare for me. What concerned me was that the Mail Advisor seemed to think because of the new sheet style login through Internet Accounts there may be issues going forward.

    PS - I did submit this as a known bug to Apple.
  7. mvdw84 macrumors newbie


    Jul 30, 2010
    Thanks, was able to submit via Feedback
  8. maflynn Moderator


    Staff Member

    May 3, 2009
    My recommendation is to roll back the update, i.e., reinstall OSX and not use the beta on your work computer. Apple recommends that people don't apply their betas on mission critical or computers needed for business operations. At the very least create two partitions (or use an external drive) and keep two versions of OSX :)
  9. leman macrumors G3

    Oct 14, 2008
    I have tried it out, and indeed, they seem to have removed POP3 support for Gmail. In my eyes, its a quite reasonable move, given that POP3 does not support core feature like folders.

    Of course, your situation is different, but you also should see that its very exotic. I would argue that your solution is also a bad design, but if it works for you, fair enough.

    Now to possible solutions. You could start using a different email client that supports POP3 with gmail. You could move to a different email provider and forward your gmail emails there. You could also forward the emails from your business account to the personal gmail account of the relevant employees and use the 'send mail as' option in gmail + alias in Apple Mail to answer mails from the business account. That is what I do with my mails — I have a number of personal and official mailboxes, which all get collected in gmail and I have configured my client to use different outgoing email addresses. This is how I can conveniently send replies as any of my email aliases.
  10. junebug1 thread starter macrumors regular


    Jan 24, 2007
    NE Ohio

    Wow you may have the solution I need! Any chance you can give me a little more insight into the 'send mail as' option in gmail + alias in Apple Mail. That solution would work perfectly as we do already have all the employees set up with their own name@companyname.com accounts and forwarding the mail to those accounts would obviously be simple. My concern was not being able to reply from the original businessname@gmail.com address. Thanks in advance.
  11. leman macrumors G3

    Oct 14, 2008
    Sure! Its actually very easy but due to lack of documentation, the initial setup can be a bit tricky to figure out.

    1. In the individual gmail account (not the businessname@gmail.com), go to Settings -> Accounts and Import -> Send mail as -> Add another email address you own

    2. Follow the instructions to add businessname@gmail.com as an outgoing address. I am not 100% sure what 'treat as alias' does. Google has some documentation on it, you'll have to experiment a bit to find out the best settings for you. You can test if it worked by looking if you can change the outgoing email address from the gmail interface.

    3. In Apple Mail, go to the Preferences -> Accounts. In the field 'Email Address', add the businessname@gmail.com after a comma. It should look something like

    name@companyname.com, businessname@gmail.com

    4. You are done! Now Apple Mail should show allow you to select your 'From' address any time you write an email!

    Hope this helps!

    P.S. This feature is very powerful, because it works will all kinds of email providers. Essentially, it uses gmail as a relay to send emails via correct email servers.
  12. d21mike macrumors 68040


    Jul 11, 2007
    Torrance, CA
    At my company we do what Leman recommended and it works very well. Except we do not use gmail. We have a company domain with GoDaddy where we all have a personal email and other shared forward only emails.


    My MailBox:
    me@mycompany.com (IMAP)

    Forward only Accounts: (forwarded to appropriate employees)


    All 4 above and more are listed under my email address which show up in the From drop down list when I send mail.

    Good Luck
  13. dleclair55 macrumors newbie

    Feb 12, 2015
    My Gmail was borked by the 10.10.3 beta too but this worked for me:

    But first be aware that by doing this you are going to delete all of your Mail messages and pull fresh copies from Gmail. For example if you deleted a message in Mail, it will come back from Gmail when you are done. If you had your messages organized in mailboxes you will have to recreate them. It's not ideal but it will get you back up and running with Gmail, POP and Mac Mail.

    I can't be responsible if it doesn't work for you.


    1) Log into Gmail with your web browser

    2) Navigate to Settings > Forwarding and POP/IMAP

    3) In the "IMAP Access" section select "Enable IMAP" (bear with me here)

    4) In the "Folder Size Limits" section select "Do not limit the number of messages in an IMAP folder".

    5) In the "IMAP Access" section select "Disable IMAP"

    6) Click on "Save Changes"

    7) Repeat this for each of your Gmail accounts (I have 4).

    8) On your Mac go to Settings & Preferences > Internet Accounts and remove all of the mail accounts listed there (don't remove iCloud)

    9) Launch Mail. If it immediately asks you to add a new account, don't just exit. If it lets you into the Mail interface go to Preferences > Accounts and remove all accounts.

    10) Close Mail.

    11) On your Mac go to Settings & Preferences > Internet Accounts and add a Google account for your first Gmail account. When the account is added it will say it is a Google IMAP account but under the hood it's actually using POP (yay!).

    12) Once it stops beachballing and the account is active, open Mail and it will start to download all of your mail from Gmail using POP. Use the Activity window in Mail to watch progress.

    13) Repeat for your other Gmail accounts.

    Good luck!

Share This Page

12 February 6, 2015