10.10.3 repeatedly asking for iCloud Password

Discussion in 'OS X Yosemite (10.10)' started by slenpree, Mar 21, 2015.

  1. slenpree macrumors 6502a

    slenpree

    Joined:
    Apr 13, 2010
    Location:
    UK
    #1
    Hi,

    Anyone else on the second 10.10.3 public BETA experiencing a box repeatedly asking for your iCloud password? for me and a friends computer it does this immediately after logging in.

    Jonathan
     
  2. ABC5S macrumors 68040

    ABC5S

    Joined:
    Sep 10, 2013
    Location:
    Florida
    #2
    Yes for me as well and others. Make a bug report please
     
  3. Tygrz macrumors member

    Joined:
    Dec 28, 2014
    Location:
    Hawaii
    #3
    My 2008 iMac has been ding that since I first installed Yosemite
     
  4. slenpree thread starter macrumors 6502a

    slenpree

    Joined:
    Apr 13, 2010
    Location:
    UK
    #4
    Thanks, just sent feedback to apple so hopefully if everyone does the same, this gets addressed soon. I also noticed "iPhone cellular calls" in FaceTime had disappeared, and also handoff and instant hotspot are no longer working. Everything is still working between the iPad and iPhone in this regard. So I put an app-specific password in the pop-up box and it only asked twice and went away, now the "iPhone cellular calls" option has returned but when I tick it, I get a message telling me to login to the same iCloud account on both the phone and mac - even though they already are. This is all very strange.
     

Share This Page