10.10.3 Spring loaded folders & drag-n-drop in Finder

Discussion in 'OS X Yosemite (10.10)' started by stol, Apr 10, 2015.

  1. stol macrumors member

    Joined:
    Apr 11, 2011
    Location:
    Greece
    #1
    Since I updated to 10.10.3 yesterday I cannot find anymore the setting that controls the speed of spring-loaded folders in the Finder Preferences.

    Moreover, when in a finder window (but not on the desktop) dragging an item onto a folder takes me immediately into that folder so when I release my finger dragged items may end up in another folder contained in the intended destination. I am sure this happens too fast, no way this was the behavior in 10.10.2 - makes me feel paranoid!

    Does this happen to you too, or is it just me?
    Can I find the setting mentioned above somewhere else?
     

    Attached Files:

  2. Wheelie4 macrumors regular

    Wheelie4

    Joined:
    Jun 6, 2007
    Location:
    NC, USA
    #2
    The Spring-loaded folders settings is also missing in my Finder preferences on 10.10.3. I had spring-loaded folders disabled and they are still disabled.
     
  3. secretanchitman macrumors 6502

    secretanchitman

    Joined:
    Sep 13, 2007
    #3
    Thought I was the only one as well with this issue but glad I'm not. Seems like it has been removed as of 10.10.3, even though 10.10.2 still had the option (confirmed with my iMac running 10.10.2).

    I'm with you OP - I want my delay to be as minimal as possible and now it feels slowed down with the possibility of moving files in to the wrong folder.

    I was looking for a possible terminal command to eliminate the delay but I haven't come across any yet.
     
  4. stol thread starter macrumors member

    Joined:
    Apr 11, 2011
    Location:
    Greece
    #4
    Actually, Finder moves too fast in the folder I drag items onto - at least for my taste. I don't want to move my view into the folder, I just want to drop some items into it... I found out that if I release my mouse button VERY fast, it won't move into that folder, but it's gotta be reaaally fast, it's not very forgiving.
     
  5. stol thread starter macrumors member

    Joined:
    Apr 11, 2011
    Location:
    Greece
    #5
    After some searching, I've come up with the following terminal commands, which still work on 10.10.3 :

    Enable spring loading:

    Code:
    defaults write NSGlobalDomain com.apple.springing.enabled -bool true
    
    Disable spring loading:

    Code:
    defaults write NSGlobalDomain com.apple.springing.enabled -bool false
    
    To set the delay time (0.5 - 1 sec is ok for me) - higher than 1 is really a drag...

    Code:
    defaults write NSGlobalDomain com.apple.springing.delay -float 1
    
    As usual, press space while hovering to move in the folder immediately.

    Set delay to 0 to always move into that folder immediately:

    Code:
    defaults write NSGlobalDomain com.apple.springing.delay -float 0
    
    No finder restart required, changes apply immediately.
     
  6. Wheelie4 macrumors regular

    Wheelie4

    Joined:
    Jun 6, 2007
    Location:
    NC, USA
  7. Victor Star macrumors member

    Joined:
    Dec 3, 2008
    #7
    The Spring-loading delay setting is in System Preferences - Accessibility - Mouse & Trackpad.

    Hope that helps.
     
  8. Wheelie4 macrumors regular

    Wheelie4

    Joined:
    Jun 6, 2007
    Location:
    NC, USA
    #8
    Wow! Nice of Apple to inform us of that move. SMH! I'm paralyzed from the neck down and even I don't necessarily consider that an accessibility feature. But I guess it could be seen as that. :)
     
  9. secretanchitman macrumors 6502

    secretanchitman

    Joined:
    Sep 13, 2007
    #9
    I came in here to post this after randomly discovering it 5 minutes ago! Weird that they moved it but happy to see that it isn't gone.
     

Share This Page