10.10.5 Broke my Wifi

Discussion in 'OS X Yosemite (10.10)' started by Rover110, Aug 15, 2015.

  1. Rover110 macrumors newbie

    Joined:
    Nov 13, 2012
    Location:
    Surrey, UK
    #1
    I went from Mavericks to Yosemite just before 10.10.3 came out on a late 2013 IMac 27".

    I didn't use 10.10.2 long enough to notice if Wifi worked for me.
    But with 10.10.3 I found Wifi unusable. (My router is TP-Link TD-W8960N).

    With 10.10.4 I found I could use Wifi again.

    Last night I upgraded to 10.10.5 and lost Wifi again.
    I tried a reboot and it was still unusable.

    For the moment I've gone back to 10.10.4

    - Rover
     
  2. Luap, Aug 25, 2015
    Last edited: Aug 26, 2015

    Luap macrumors 65816

    Luap

    Joined:
    Jul 5, 2004
    #2
    I've read of boat loads of wifi issues with the Yosemite OS. Yet it always worked 100% fine for me, until 10.10.5 that is...
    My MacMini (2012 i7) became very stubborn to connect to my own network. And if/when it did eventually connect, the connection isn't as fast as its supposed to be.

    After a bit of googling, I found this:
    https://discussions.apple.com/thread/7187176

    After following the tips there, it seems I can now reliably connect to my own network again. Good!
    But it still isn't as fast as its supposed to be. I don't think it's connecting over N, or 5ghz? And instead its using some slower wifi standard.. No idea what I should try next?

    [edit] Its bad enough that I really need to see if I can go back to 10.10.4, or maybe hold out for El Capitan.. :(
     
  3. border terrier macrumors regular

    Joined:
    Feb 6, 2013
    Location:
    England
    #3
    I've been plagued with wifi issues since Mavericks though 10.10.4 seemed to resolve most issues. 10.10.5 and I am having disconnection issues on my MBP but no issues yet on my Mac Pro. Frustrating, will it never end?
     

Share This Page