Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

kappaknight

macrumors 68000
Original poster
Mar 5, 2009
1,595
91
Atlanta, GA
Anyone testing the latest beta having issues with this? On two separate locations with the latest Apple Extreme ac, and my wifi is now choosing the 2.4GHz wifi over the 5GHz every time. It can't seem to keep the internet connection intact if it's on the 5GHz band.
 

ABC5S

Suspended
Sep 10, 2013
3,395
1,646
Florida
View attachment 584941 no issues for me.


Screen Shot 2015-09-24 at 2.05.38 AM.png
 
Last edited:

campyguy

macrumors 68040
Mar 21, 2014
3,413
957
I've got the 2.4 and 5GHz networks separated in 5 locations with different names - no problems with 4 Macs running 10.11.1 or 21 Macs running 10.10.5. All stay locked onto the 5GHz networks.
 

dugbug

macrumors 68000
Aug 23, 2008
1,861
1,923
Somewhere in Florida
Anyone testing the latest beta having issues with this? On two separate locations with the latest Apple Extreme ac, and my wifi is now choosing the 2.4GHz wifi over the 5GHz every time. It can't seem to keep the internet connection intact if it's on the 5GHz band.

Have you had the wifi diagnostics tool monitor the connection?
 

kappaknight

macrumors 68000
Original poster
Mar 5, 2009
1,595
91
Atlanta, GA
5g is fine here as well. have you tried rebooting your modem/airport extreme?

One was rebooted a couple of times yesterday. Both were rebooted recently.

2.4Ghz OFF?

I leave 2.4 on because I have some older devices that can only see those bands.

Things seem to be more stable today though. It was just weird that the same problems happened on both locations yesterday.
 

Reality4711

macrumors 6502a
Aug 8, 2009
731
558
scotland
In system preference > Network > Advanced > I say both my 5 Ghz and 2.4 Ghz listed, then I just highlighted the 2.4 Ghz and removed it. Unknown if you have same.


View attachment 585226

Does that actually turn off the routers 2.4Ghz signal or just stop the machine you are using from seeing it?

On third party routers you have to dial up the routers ip address and turn off the 2.4Ghz or select one frequency usage (whichever is offered).

I have not turned off 2.4 Ghz just set up Mac equipment only on 5 Ghz and left everything else to find the 2.4Ghz because a lot of older stuff/cheaper will only use 2.4Ghz anyway.
 

ABC5S

Suspended
Sep 10, 2013
3,395
1,646
Florida
Can't tell you. It just worked for me after experiencing what others have stated in that the 2.4 Ghz would appear from time to time and what I did just worked. I'm not to technical as you can tell
 

Reality4711

macrumors 6502a
Aug 8, 2009
731
558
scotland
Can't tell you. It just worked for me after experiencing what others have stated in that the 2.4 Ghz would appear from time to time and what I did just worked. I'm not to technical as you can tell

OK. Me neither. Thanks for the chat.

Regards

Sharkey
 

rnbwd

macrumors regular
Jul 6, 2015
111
38
Seattle
I've had some issues with my old laptop (unibody macbook pro 2009) - and changing the frequency of the router itself can make most the difference. The 2.4ghz and 5 ghz bands don't overlap whatsover, turning one off won't do anything. The most common cause would be that (if you're in an area with lots of wifi) there could be interefence, and someone logging onto youtube a few doors down that's running the same channel you're on could create a lot of noise. 5ghz channels don't have nearly the range as 2.4hz channels too, so you need to be relatively close to the router. I usually use 5ghz channels because the transfer rate (for me) is 140 mbs while the 2.4gz channels are out around 20-60 mbps. But my old macbook gets like 20 mbps from 5ghz and is running a driver 6 years old. (like a boss).

If you 'option' click on the wifi icon it'll upon up a diagnostic tool that let you examine that. If everything is fine, no router issues, and you're certain it was caused by el capitan - slight chance something in the network protocol is configured wrong or corrupted so maybe try redownloading - including the bootloader. But 90% of the time it's network interference and router issues.
 

Donfor39

macrumors 68000
Jul 26, 2012
1,893
371
Lanarkshire Scotland
I've had some issues with my old laptop (unibody macbook pro 2009) - and changing the frequency of the router itself can make most the difference. The 2.4ghz and 5 ghz bands don't overlap whatsover, turning one off won't do anything. The most common cause would be that (if you're in an area with lots of wifi) there could be interefence, and someone logging onto youtube a few doors down that's running the same channel you're on could create a lot of noise. 5ghz channels don't have nearly the range as 2.4hz channels too, so you need to be relatively close to the router. I usually use 5ghz channels because the transfer rate (for me) is 140 mbs while the 2.4gz channels are out around 20-60 mbps. But my old macbook gets like 20 mbps from 5ghz and is running a driver 6 years old. (like a boss).

If you 'option' click on the wifi icon it'll upon up a diagnostic tool that let you examine that. If everything is fine, no router issues, and you're certain it was caused by el capitan - slight chance something in the network protocol is configured wrong or corrupted so maybe try redownloading - including the bootloader. But 90% of the time it's network interference and router issues.


I use 5gh 99% time -with option 2.4gh if required no probs at all...try a app like wifi explorer to check wich channels to avoid.
 

RabidMacFan

macrumors 6502
Jun 19, 2012
355
169
California
If the 2.4Ghz and 5Ghz network have the same name (SSID), then Mac OS will decide which to connect to based on which has the best reception. 2.4Ghz can actually penetrate through walls better than 5Ghz, so it's actual range is sometimes better.

If you insist on staying on the 5Ghz network, give it a different name and select to connect to that network.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.