10.12.4 External Drive not mounting

Discussion in 'macOS Sierra (10.12)' started by Summez, Apr 1, 2017.

  1. Summez macrumors member

    Summez

    Joined:
    Mar 20, 2011
    #1
    Hi all,

    I have a late 2015 iMac 5k and have just updated to 10.12.4.

    I have two identical 2TB Western Digital Elements connected via USB one as a Time Machine Drive the other as an iTunes library etc..

    After performing the 10.12.4 update the Time machine drive no longer mounts automatically. I have tried running first aid on the drive, resetting the SMC and PRAM. I have also plugged the drive into my 2009 Macbook Pro running ElCap and the drive automatically mounts.

    Anyone got any ideas how to solve this problem?

    Many Thanks
     
  2. canuckkim macrumors newbie

    canuckkim

    Joined:
    Apr 3, 2017
    Location:
    Michigan
    #2
    I have a late 2015 Macbook Pro with a WD My Book 4TB and am having the SAME problem. I have updated drivers and anything else I could find at WD, but cannot open the external drive. Please help!
     
  3. Summez thread starter macrumors member

    Summez

    Joined:
    Mar 20, 2011
    #3
    The only workaround I have found so far is to manually mount the drive image in disk utility. This works until you either restart or shutdown the Mac, then once rebooted the drive does not auto mount again. Anyone else having this issue?
     
  4. dudu307 macrumors newbie

    Joined:
    Jun 30, 2010
    #4
    Yes, same problem here.

    Mac mini (Late 2014). Since 10.12.4 update, the USB external drives don't auto mount, you have to do it manually in disk utility. The drives (WD Green) and enclosure (Orico 9558U3) appears to be fine.
     
  5. Dobrun macrumors newbie

    Joined:
    May 14, 2017
    Location:
    USA
    #5
    Basically, I could not get external drives (USB and Thunderbolt) to automatically mount to Finder/Desktop on startup. I could see the drives in Disk Utility and do an unmount/mount action to get the drives to be visible. I have checked all of the formatting.

    I have been trying to fix the same issue for three days and may have finally found a solution. I have a G-Drive on Thunderbolt and a seagate USB 4 TB as well as a WD My Book, all of which would not show in Finder but would show in Disk Utility. On one of the apple community areas I fund this terminal command:

    sudo defaults write /Library/Preferences/SystemConfiguration/autodiskmount AutomountDisksWithoutUserLogin -bool YES

    This has worked for me. I am NOT an IT expert but this terminal command seems to change a default SysConfig to allow drives to mount without the user login (doh) ..

    As I said, I am not an expert but this has worked for me (and yes, I did try firmware, 3rd Party Utils, etc) ..

    Hope it helps - perhaps someone with knowledge and experience can confirm the above for others to try?
     

Share This Page