10.3.8 Mail Crashing

idkew

macrumors 68020
Original poster
After updating to 10.3.8 Mail is now crashing whenever I switch to a different message. My guess is the little fade in/out transition is messed up somehow.

Anyone else have this happen? I have removed the mail preferences, imported old mail and re-did all 7 of my (work) mailboxes, and this did not help.

Anyone know a fix, I searched and found none.

Can someone send me the older Mail.app? If you can, please send it to bnau (at) plunkettfurniture.com

thanks

oh- permissions have been repaired. i have restarted....
 

varmit

macrumors 68000
Aug 5, 2003
1,830
0
Was this an Archive install or upgrade? Since Upgrading is buggy, while Archive install has better success.
 

wrldwzrd89

macrumors G5
Jun 6, 2003
12,107
75
Solon, OH
idkew said:
this was a regular OS update from 10.3.7, there was no archive and install option.
I think varmit wants to know not about the 10.3.8 upgrade itself, but whether or not the last time you installed Mac OS 10.3.0 (or whether you installed 10.3.X because that's what came with your Mac) as an archive and install or an upgrade install over 10.2.X, since an upgrade install can be a potential source of trouble.
 

idkew

macrumors 68020
Original poster
wrldwzrd89 said:
I think varmit wants to know not about the 10.3.8 upgrade itself, but whether or not the last time you installed Mac OS 10.3.0 (or whether you installed 10.3.X because that's what came with your Mac) as an archive and install or an upgrade install over 10.2.X, since an upgrade install can be a potential source of trouble.

ah- this was a clean install of 10.3. no X was on the machine before this.
 

wrldwzrd89

macrumors G5
Jun 6, 2003
12,107
75
Solon, OH
I remember back in the days of Mac OS X 10.3.5, my Mail.app got messed up. It wasn't the same problem you're having, but what I did was zapped the caches (~/Library/Caches/Mail and ~/Library/Mail/Mailboxes/*.mbox/Contents/CachedData), and it fixed the problems I was having. You might give that a try.
 

idkew

macrumors 68020
Original poster
i have moved all old mail into a new folder, in mail.app. same with sent mail. this way, when i a looking at new messages, there is no old messages in my inbox, and when i sned a message, it goes into a clean folder.

so far, this has worked. no crashes yet. seems like something was corrupted in a mailbox, maybe all mailboxes. i still get crashes if i look in the old mail folder, but i don't think i will be doing it much.

i will try the new user idea if this stops working.

thanks for all the help everyone.
 

idkew

macrumors 68020
Original poster
yeah- i've tried that several times.

no- i have not tried the new user account. i am too bust with work to log out and setup all the necessary stuff. maybe if i have a free moment....

love being my own it department. :rolleyes:
 

rinseout

macrumors regular
Jan 20, 2004
160
0
Mail.app is really screwed up

I too updated to 10.3.8, and find that Mail.app no longer works for me. I run my own SMTP server (on localhost) and point Mail.app to that server for outgoing mail. After the update, Mail.app can no longer send outgoing mail, even though "telnet localhost 25" shows that Postfix is still running & listening. Also, the mail log shows that Mail.app never connects.

This is a pain in the neck, since built-in apps like (like iCal) like to send email via Mail.app, which is the only reason I have Mail set up.

I think Mail is really broken, but can't find a way to submit a bug report. How do you submit a bug report for Mail.app? Who do I email?
 

kasei

macrumors 6502a
Dec 30, 2003
561
10
Los Angeles, CA
I had similar problems. It got even worse when a 6 meg file for some strange reason got stuck in the Outbox. After that I could not send any more e-mails. I had to drag mail into the trash can, so now I am stuck with Entourage.

I was tempted to reload Panther, but I don't want to go throught the entire process of upgrading the OS again. I guess I will have to wait unitl Tiger's release before I can have Mail again.
 

paulrbrown

macrumors newbie
Sep 3, 2003
4
0
Chicago
Mail.app crashing for me, too...

I'm in the same boat as others here, although it's crashing for me after the security update that recently went out. It crashes immediately after it completes sending a piece of mail.

From my perspective, this is pretty ridiculous -- the update system for MacOS X is so broken as to be comical, and I can't see how Apple wouldn't be sufficiently emarrassed by it to invest some effort in improving it.
 

PalmHarborTchr

macrumors member
Feb 26, 2003
94
0
Florida
Apple Mail buggy

the apple mail program has always had more bugs than a cheap florida motel and apple has done little about it. I am using os 10.3.8 and I cannot send mail anymore. I used Disk Warrior...nothing........System Optimizer X
no help. the send icon is barely seen. YOu can't click on it anymore.
I tried the apple mail help and it is useless. I went to apple site and it
is confusing at best as they have found a new way to make getting help much more complicated.
Anyone with ideas?
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.