10.4.11 Macbook auto connects to someone elses wireless

Discussion in 'macOS' started by Ben Kei, Mar 4, 2009.

  1. Ben Kei macrumors regular

    Joined:
    Oct 30, 2002
    Location:
    London UK
    #1
    Hi,

    I've been having an issue with my wireless for a while now where each time I turn on my Macbook it auto connects to a neighbours wireless rather than my own despite it being set as the default location.

    I've tried trashing preferences, rebuilding my wireless configuration etc... but it still connects to my neighbours wireless and not mine.

    Also, it's recently decided that each time they turn on or off their wireless it'll temporarily interfere with mine and kick me offline (it doesn't do the same for my girlfriend who is connected through an Acer laptop)

    Is there a way to change this?

    It's not too much hassle manually changing networks but enough of one that I'm posting this thread!

    Thanks,
    Ben
     
  2. SHADO macrumors 6502a

    SHADO

    Joined:
    Aug 14, 2008
    Location:
    Beach
    #2
    What is the order of Networks in System Preferences-->Network-->Advanced-->Airport Tab? Make sure your wireless network is at the top of that list. If it's not, drag it to the top and hopefully that will fix your problem.
     
  3. rdowns macrumors Penryn

    rdowns

    Joined:
    Jul 11, 2003
    #3
    Try this.

    System Preferences>Network>Airport>Advanced>

    Drag your preferred network to the top position. Delete other networks in there that you don't want to connect to.

    HTH
     
  4. SHADO macrumors 6502a

    SHADO

    Joined:
    Aug 14, 2008
    Location:
    Beach
    #4
    lol great minds think alike :p
     
  5. Ben Kei thread starter macrumors regular

    Joined:
    Oct 30, 2002
    Location:
    London UK
    #5
    Thanks to both of you.

    I'm at work now but will give that a shot when I get home.

    Not sure how the neighbours wireless would have made it in to my trusted networks as I've never willingly connected to it but it's certainly worth a shot.

    Cheers! Ben
     
  6. Ben Kei thread starter macrumors regular

    Joined:
    Oct 30, 2002
    Location:
    London UK
    #6
    Well for some reason the neighbours wireless had made its way on to my trusted networks and was also top of the list.

    So I've removed that and it no longer auto-connects but will also not auto-connect to my own wireless box.
    Picking it from the list on the top menu results in a 'cannot connect' dialog box and I need to wait for at least a minute until it'll successfully connect.

    Worth noting is that it is a secure network and doesn't ask me for my password, so it's obviously authenticating the connection fine, just not automatically joining when I log on.

    Any ideas?

    Thanks,
    Ben
     

Share This Page