10.4.3 is causing kernel panics!

Discussion in 'macOS' started by yellow, Nov 11, 2005.

  1. yellow Moderator emeritus


    Oct 21, 2003
    Portland, OR
    Just thought I'd post this to share and see if anyone else in a similar situation is seeing what I'm seeing..

    I have a bunch of Tiger boxes bound to Active Directory. All the users have cached (mobile) logins and use the autosync feature to sync their home directories to a mounted SMB file share. This has been working great for months. Until 10.4.3.

    I think a bug was introduced in 10.4.3 and it's "includes fixes for: - AFP, SMB/CIFS, NFS and FTP network file services". For some strange reason now, 2 of my user are starting to have random kernel panics associated with SMB.

    Fri Nov 11 11:40:31 2005
    panic(cpu 0 caller 0x000E7FF4): vnode_put(1ebead4): iocount < 1
    Latest stack backtrace for cpu 0:
             0x00095698 0x00095BB0 0x0002683C 0x000E7FF4 0x000E7FA0 0x2F846C38 0x000FD734 0x000E5D9C 
             0x000E60AC 0x000E8508 0x000E7DE4 0x000E868C 0x00221500 0x00226E44 0x002270E0 0x000FB140 
             0x000E20C8 0x000E1C5C 0x000F4B24 0x000ED008 0x000ED3C8 0x002A9BF4 0x000ABE30 0x9004A304 
          Kernel loadable modules in backtrace (with dependencies):
    Proceeding back via exception chain:
       Exception state (sv=0x2F6C3000)
          PC=0x8FE2196C; MSR=0x0000F030; DAR=0xE0B06884; DSISR=0x40000000; LR=0x8FE044E8; R1=0xBFFFD590;
     XCP=0x00000030 (0xC00 - System call)
    Kernel version:
    Darwin Kernel Version 8.3.0: Mon Oct  3 20:04:04 PDT 2005; root:xnu-792.6.22.obj~2/RELEASE_PPC
    Both haven't installed anything, nothing major has changed. No crazy data has been created to be sync'd. There's not much in the way of time stamping that points to anything. The only commonality between the 2 is, 1) they both have Macs (though one is a laptop, the other a quicksilver), and 2) both user are Chinese (which is a non-issue, but is a commonality). We all joked that it's the first Mac virus, releasedreleased by Microsoft, transmittable via Mandarin. :)

    So what have I tried to fix it/work around it?

    Repaired Permissions (nothing unusual in the results).

    So far on one, I've turned off AutoSync and made it a Manual sync. I want to see if it's the autosync that might be breaking. For the other, I'm just trying to reinstall the 10.4.3 Combo Updater, but I cannot seem to download it from Apple. Every time I do, the checksum verification fails (tried on multiple Macs). So there's something f-ed at Apple right now. But anyway.. I'll post back with more results and troubleshooting later on.

    Anyone else seeing this?
  2. Makosuke macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    I don't use AD, but I have a quick question: Since you mentioned both users were Chinese, do they use non-English characters in the filenames that're being synched, and if so, are they the only ones that do so?

    I'm mainly wondering if it's possible that the bug introduced is specific to unicode conversion or something--it would explain why only those two would be having problems, anyway (and of interest to me, since I work with non-English filenames all the time).
  3. yellow thread starter Moderator emeritus


    Oct 21, 2003
    Portland, OR
    Nope.. all file names are standard English and don't have any illegal characters (according to Windows doctrine) that would disallow them from being autosync'd to the Win2k3 server.

Share This Page