10.4.8 crashes with Jumbo frame sizes (gigabit ethernet)

Discussion in 'macOS' started by dmelgar, Dec 28, 2006.

  1. dmelgar macrumors 68000

    Apr 29, 2005
    Hello, I'm trying to network from my Macbook to a computer with a realtek 8169 gigabit ethernet card using a crossover cable. If I set the MTU size greater than 1500 the Mac crashes frequently.

    This seems like a very common scenario. Has anyone else experienced this?
    Are jumbo frame sizes still too new, bugs not worked out? I tried networking between the Macbook and an IBM T41. If using jumbo frame sizes the Thinkpad crashes. What gives?

    I've also noticed that if I do an NFS mount with default parms, ie using UDP, that the connection is amazingly slow, ie max 1MB/sec. If I force it to use TCP, I get 10-13MB/sec. Any ideas why thats happening?

    I'm surprised to have found a scenario which consistently crashes an otherwise very reliable system.
  2. ClimbingTheLog macrumors 6502a

    May 21, 2003
    I'm seeing the same thing - the gigabit card is a netgear, MTU set to 7200. I've tried 9000 and 7200 on the MacBook. Ka-boom. If I set it to 1500 everything works stably.

    I'm using a gigabit switch - not sure if it supports jumbo frames itself. I'd guess your cross-over cable either doesn't support it at all, or supports it implicitly. I'm not sure here, but a kernel panic is definitely the wrong behavior.

Share This Page